nouveau pb de somme.si (recherche critère)

Le
besman
j'ai lu un maximum de reponses sur les pb de somme.si sur excel mais
je ne trouve tjs pas la solution. Je dois additionner des cases de
Type Y1Q1, Y2Q2 selon des critères Y1, Y2 Ce qui ne va pas c'est
que la formule gauche qui me renvoie Y1 ou Y2 dans Y1Q1 et Y2Q1 ne
marche pas pour la sélection des plages de références.je voudrais
faire qq chose de type
=SOMME.SI(gauche($N$7:$CG$7;2);E$9;$N11:$CG11)et utiliser un critère
"Y1**" rend la tache trop compliquée car ne permet pas de faire
glisser la formule pour l'étendre à un tableau.
qq'un aurait il une solution?
merci.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent.
Le #1291888
Il te faut utiliser SOMMEPROD et non somme.si ou alors la
validation matricielle (Ctrl+Shift+Entrée)

-----Message d'origine-----
j'ai lu un maximum de reponses sur les pb de somme.si sur
excel mais

je ne trouve tjs pas la solution. Je dois additionner des
cases de

Type Y1Q1, Y2Q2... selon des critères Y1, Y2... Ce qui ne
va pas c'est

que la formule gauche qui me renvoie Y1 ou Y2 dans Y1Q1
et Y2Q1 ne

marche pas pour la sélection des plages de références.je
voudrais

faire qq chose de type
=SOMME.SI(gauche($N$7:$CG$7;2);E$9;$N11:$CG11)et utiliser
un critère

"Y1**" rend la tache trop compliquée car ne permet pas de
faire

glisser la formule pour l'étendre à un tableau.
qq'un aurait il une solution?
merci.
.



ChrisV
Le #1288978
Bonjour besman,

Pas sûr d'avoir bien saisi le type de recherche et d'extraction
souhaitées... il faudrait donner d'avantage de précisions ainsi que le
résultat souhaité...

Avec les plage nommées YxQx et Yx, en supposant que tu veuilles compter le
nombre de cellules répondant aux critères: plage YxQx = Y?Q? et Yx = Y?
(à saisir sans les { } et valider par Ctrl+Shift+Entrée)

{=SOMME(SI(ESTERR(CHERCHE("Y?Q?";YxQx));0;
CHERCHE("Y?Q?";YxQx))*(STXT(Yx;1;1)="Y"))}


ChrisV


"besman" news:
j'ai lu un maximum de reponses sur les pb de somme.si sur excel mais
je ne trouve tjs pas la solution. Je dois additionner des cases de
Type Y1Q1, Y2Q2... selon des critères Y1, Y2... Ce qui ne va pas c'est
que la formule gauche qui me renvoie Y1 ou Y2 dans Y1Q1 et Y2Q1 ne
marche pas pour la sélection des plages de références.je voudrais
faire qq chose de type
=SOMME.SI(gauche($N$7:$CG$7;2);E$9;$N11:$CG11)et utiliser un critère
"Y1**" rend la tache trop compliquée car ne permet pas de faire
glisser la formule pour l'étendre à un tableau.
qq'un aurait il une solution?
merci.


Publicité
Poster une réponse
Anonyme