Le noyau / kernel 4.13.0-26 qui causait beaucoup de probl=c3=a8mes n'est plus propos=c3=a9e dans les mises =c3=a0 jour

Le
Pierre www.aribaut.com
Salut, sans le supprimer ou masquer des mises à jour, ce kernel
4.13.0-26 qui est rempli de bugs (plantage wifi chez moi, reboot à
l'infini chez d'autres etc) n'est plus proposé (enfin!) chez moi,
c'est désormais le kernel 4.13.0-31 qui m'est proposé.
J'hésite à le tester, même si il faudra pour corriger les fameuses
failles meltdown et spectre au niveau du kernel, j'espère que les bugs
ont été corrigés.
Quelqu'un a testé le kernel 4.13.0-31 ? Des plantages ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre www.aribaut.com
Le #26461022
Le 23/01/2018 à 21:50, Pierre www.aribaut.com a écrit :
Salut, sans le supprimer ou masquer des mises à jour, ce kernel
4.13.0-26 qui est rempli de bugs (plantage wifi chez moi, reboot à
l'infini chez d'autres etc...) n'est plus proposé (enfin!) chez moi,
c'est désormais le kernel 4.13.0-31 qui m'est proposé.
J'hésite à le tester, même si il faudra pour corriger les fameuses
failles meltdown et spectre au niveau du kernel, j'espère que les bugs
ont été corrigés.
Quelqu'un a testé le kernel 4.13.0-31 ? Des plantages ?

Ce topic n'est pas très encourageant :
https://www.reddit.com/r/linuxmint/comments/7sapgi/413031_kernel_install_failure/
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.aribaut.com
Le #26461021
Le 23/01/2018 à 21:53, Pierre www.aribaut.com a écrit :
Le 23/01/2018 à 21:50, Pierre www.aribaut.com a écrit :
Salut, sans le supprimer ou masquer des mises à jour, ce kernel
4.13.0-26 qui est rempli de bugs (plantage wifi chez moi, reboot à
l'infini chez d'autres etc...) n'est plus proposé (enfin!) chez moi,
c'est désormais le kernel 4.13.0-31 qui m'est proposé.
J'hésite à le tester, même si il faudra pour corriger les fameuses
failles meltdown et spectre au niveau du kernel, j'espère que les bugs
ont été corrigés.
Quelqu'un a testé le kernel 4.13.0-31 ? Des plantages ?

Ce topic n'est pas très encourageant :
https://www.reddit.com/r/linuxmint/comments/7sapgi/413031_kernel_install_failure/


Merde j'utilise aussi Cinnamon :
"rodneyck 1 point il y a 5 heures
I am using Cinnamon and all the 4.13 kernels cause Cinnamon to crash
during startup. Even if you try restarting Cinnamon, it won't. I had to
revert back to the 4.10 kernel which has always been stable."
Le problème du bug wifi (chez moi le 4.13.0-26 coupait l'accès au wifi
et personne visiblement n'a de solution) ne semble pas vraiment résolu :
"captainslog 1 point il y a 6 heures
Same, wifi isn't stable."
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26461147
Le Tue, 23 Jan 2018 21:56:31 +0100, Pierre www.aribaut.com a écrit :
(chez moi le 4.13.0-26 coupait l'accès au wifi et personne visiblement
n'a de solution)

On ne sait même pas quel est précisément le problème. Peux-tu te
connecter avec un câble ce qui te permettra de transmettre aisément les
résultats de différentes commandes ?
Pierre www.zetrader.fr
Le #26461250
Le 24/01/2018 à 16:16, Jo Engo a écrit :
Le Tue, 23 Jan 2018 21:56:31 +0100, Pierre www.aribaut.com a écrit :
(chez moi le 4.13.0-26 coupait l'accès au wifi et personne visiblement
n'a de solution)

On ne sait même pas quel est précisément le problème. Peux-tu te
connecter avec un câble ce qui te permettra de transmettre aisément les
résultats de différentes commandes ?


Le problème c'est que cela fait comme si il n'y avait plus d'accès au
wifi, je ne peux plus voir les réseaux wifi, je n'ai pas essayé avec un
cable.
Par contre, en testant xubuntu 17.10.1 en usb live, j'ai vu que le
kernel dans ce live est le 4.13.0-21 et que la connexion wifi marche
très bien.
J'ai alors pensé à tester le kernel 4.13.0-21 avec linux mint mais avant
j'ai cherché dans google, et je suis tombé sur le problème du bios et
les pc lenovo, donc je suppose quand dans xubuntu 17.10.1 c'est la
version patchée /corrigée du kernel, j'ose pas essayer la version
4.13.0-21 dans les dépôts de mon linux mint car je ne sais pas si c'est
la version buggée ou non, le risque étant de foutre le bios en l'air et
devoir réparer ça ensuite (j'ai vu qu'il y avait moyen désormais de
régler ça mais bon si je pouvais éviter...) si par malchance c'est la
version buggée qu'ils laissent dans les dépôts.
Donc je pense peut-être essayer la 4.14 (qui corrige aussi d'autres bugs
et failles de sécurité par rapport à la 4.10.0-42 qui finalement se
concentre sur les failles récentes mais laisse non patchée d'autres
failles colmaltées dans des versions supérieuses de kernel, y compris
celles qui n'ont pas le patch contre les 2 dernières failles récentes et
médiatisées mais en fait peu exploitées...), j'ai installé Ukuu dans
cette éventualité, mais je me tâte encore, je regarde ce qu'il est dit
des différentes versions de kernel 4.14 et leur compatibilité possible
avec Linux Mint 18.3.
A priori, de ce que je lis jusqu'à la 4.14.8 des gens disent que cela
va, mais au-delà de cette version des gens font état de problèmes
importants, justement les versions patchées contre les failles qui
apportent des problèmes potentiellement plus gros que ceux des failles
rarement exploitées.
Au moins avec la 4.14.8 toutes les autres failles connues seraient déjà
colmatées, ce qui n'est pas le cas en kernel 4.10, peut-être déjà un peu
mieux en 4.13 à condition d'avoir une version de kernel compatible avec
mon linux mint, ce qui n'est pas sûr vu que les 2 dernières versions
sont problématiques.
J'aimerais savoir sur la 4.14.14 ou 4.14.15 (la toute dernière version)
a des chances de fonctionner correctement avec Linux Mint 18.3 ou risque
de tout foutre en l'air, si c'est mieux de le faire avec Xubuntu
17.10.1, si il y a plus de chances de compatibilité avec le dernier noyau.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26461273
Le Thu, 25 Jan 2018 12:38:35 +0100, Pierre www.zetrader.fr a écrit :
J'ai alors pensé à tester le kernel 4.13.0-21 avec linux mint mais avant
j'ai cherché dans google, et je suis tombé sur le problème du bios et
les pc lenovo,

ça fait longtemps qu c'est corrigé ce truc et ça ne pose de problème
catastrophique qu'à l'installation
donc je suppose quand dans xubuntu 17.10.1 c'est la
version patchée /corrigée du kernel, j'ose pas essayer la version
4.13.0-21 dans les dépôts de mon linux mint car je ne sais pas si c'est
la version buggée ou non

La version bogué a nécessairement un autre mineur inférieur et de toute
façon tu as la 4.14 que tu peux essayer sur linux mint. Si ça ne marche
pas j'espère que tu auras l'idée de brancher le câble, et que quelqu'un
aura l'amabilité de te dire les tests à faire
(prépare la sortie de sudo dmesg pour la publier quelque part, tu pourras
poster lspci -k du moins la partie qui nous intéresse etc.)

--
On ne prête qu'aux riches, et on a bien raison, parce que les autres
remboursent difficilement.
-+- Tristan Bernard (1866-1947) -+-
Pierre www.zetrader.fr
Le #26461482
Le 25/01/2018 à 15:14, Jo Engo a écrit :
Le Thu, 25 Jan 2018 12:38:35 +0100, Pierre www.zetrader.fr a écrit :
J'ai alors pensé à tester le kernel 4.13.0-21 avec linux mint mais avant
j'ai cherché dans google, et je suis tombé sur le problème du bios et
les pc lenovo,

ça fait longtemps qu c'est corrigé ce truc et ça ne pose de problème
catastrophique qu'à l'installation
donc je suppose quand dans xubuntu 17.10.1 c'est la
version patchée /corrigée du kernel, j'ose pas essayer la version
4.13.0-21 dans les dépôts de mon linux mint car je ne sais pas si c'est
la version buggée ou non

La version bogué a nécessairement un autre mineur inférieur et de toute
façon tu as la 4.14 que tu peux essayer sur linux mint. Si ça ne marche
pas j'espère que tu auras l'idée de brancher le câble, et que quelqu'un
aura l'amabilité de te dire les tests à faire
(prépare la sortie de sudo dmesg pour la publier quelque part, tu pourras
poster lspci -k du moins la partie qui nous intéresse etc.)

Bon finalement, pas besoin de faire ces commandes, j'ai trouvé tout seul
la solution, j'avais envie de retenter pour voir ;)
J'ai donc essayé 4.13.0-21, 26, 31 et là juste à l'instant la 4.13.0-32
qui avait le même problème que toutes les autres 4.13 sur mon linux mint
: coupure du wifi, en désactivant / réactivant le wifi, pas moyen de
voir les réseaux wifi, pas moyen de se connecter.
Là c'est bon, j'ai trouvé comment faire marcher le wifi, j'écris donc
depuis linux mint avec noyau 4.13.0-32 qui contient donc les derniers
patchs de sécurité :)
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Publicité
Poster une réponse
Anonyme