[OpenBSD 3.6] Plus de PPPoE après la mise à jour

Le
Arnaud Boudou
Bonjour,

Plaçons d'abord le contexte : j'avais jusqu'à ce matin une passerelle
sous OpenBSD 3.5, qui établissait la connexion au net en PPPoE via un
controleur ethernet (pilote ne), lui même relié à un bête SpeedTouch
Ethernet.

Je fais ma petite mise à jour vers OpenBSD 3.6, et là plus de connexion
possible. La LED du modem indiquant l'activité sur l'interface LAN reste
désespérément vide, indiquant qu'il n'y à même pas un simple essai de
connexion, et donc la connexion PPPoE ne se fait jamais.

Les infos habituelles :

* la connexion est lancée par un "ppp -ddial pppoe"

* la sortie d'un ifconfig -a (interfaces inutiles en moins)

lo0: flags49<UP,LOOPBACK,RUNNING,MULTICAST> mtu 33224
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6
ne3: flags63<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500
address: 00:20:18:81:41:16
media: Ethernet manual
inet 192.168.2.252 netmask 0xffffff00 broadcast 192.168.2.255
inet6 fe80::220:18ff:fe81:4116%ne3 prefixlen 64 scopeid 0x1
rl0: flags43<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1492
address: 00:48:54:3c:75:ba
media: Ethernet autoselect (100baseTX full-duplex)
status: active
inet 192.168.0.253 netmask 0xffffff00 broadcast 192.168.0.255
inet6 fe80::248:54ff:fe3c:75ba%rl0 prefixlen 64 scopeid 0x2
inet6 2001:7a8:3c21:1:248:54ff:fe3c:75ba prefixlen 64
tun0: flags10<POINTOPOINT,MULTICAST> mtu 3000

* le contenu de mon /etc/ppp/ppp.conf

default:
set log Phase Chat LCP IPCP IPV6CP CCP tun command
set redial 5 99999
set reconnect 5 99999

pppoe:
set device "!/usr/sbin/pppoe -vv -i ne3"
disable acfcomp protocomp
deny acfcomp
set mtu max 1492
enable ipv6cp
set speed sync
set cd 5
set dial
set login
set timeout 0
set authname xxx
set authkey yyy
add! default HISADDR
enable mssfixup

set server /var/run/internet "" 0177


* le log de la tentative de connexion

Nov 1 08:25:20 bampeikun ppp[12492]: Phase: Using interface: tun0
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: hangup ->
opening
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: Enter pause
(5) for redialing.
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Chat: deflink: Reconnect try
1 of 99999
Nov 1 08:25:20 bampeikun ppp[12492]: Phase: deflink: Created in closed
state
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: default: set redial
5 99999
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: default: set
reconnect 5 99999
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set device
!/usr/sbin/pppoe -vv -i ne3
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: disable
acfcomp protocomp
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: deny acfcomp
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set mtu max 1492
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: enable ipv6cp
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set speed sync
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set cd 5
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set dial
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set login
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set timeout 0
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set authname
********
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set authkey
********
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: add! default
HISADDR
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: enable mssfixup
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Command: pppoe: set server
/var/run/internet ******** 0177
Nov 1 08:25:20 bampeikun ppp[12492]: tun0: Phase: Listening at local
socket /var/run/internet.
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: PPP Started (ddial mode).
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: bundle: Establish
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: closed ->
opening
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Warning: Carrier settings
ignored
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: Connected!
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: opening -> dial
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: dial -> carrier
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: carrier -> login
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: login -> lcp
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: LCP: FSM: Using "deflink" as
a transport
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: LCP: deflink: State change
Initial --> Closed
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: LCP: deflink: State change
Closed --> Stopped
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: read (0):
Connection reset by peer
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: LCP: deflink: State change
Stopped --> Closed
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: LCP: deflink: State change
Closed --> Initial
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: Disconnected!
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: lcp -> logout
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: logout -> hangup
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: Disconnected!
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: Connect
time: 0 secs: 44 octets in, 0 octets out
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: 4 packets
in, 0 packets out
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: total 44 bytes/sec,
peak 0 bytes/sec on Mon Nov 1 08:25:20 2004
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: HUPing 30250
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: hangup ->
opening
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Phase: deflink: Enter pause
(5) for redialing.
Nov 1 08:25:20 bampeikun ppp[20551]: tun0: Chat: deflink: Reconnect try
1 of 99999
Nov 1 08:25:25 bampeikun ppp[20551]: tun0: Chat: deflink: Redial timer
expired.


* la sortie du dmesg

OpenBSD 3.6 (GENERIC) #59: Fri Sep 17 12:32:57 MDT 2004
deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Celeron ("GenuineIntel" 686-class, 128KB L2 cache) 368 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem = 133799936 (130664K)
avail mem = 115474432 (112768K)
using 1658 buffers containing 6791168 bytes (6632K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(32) BIOS, date 10/11/00, BIOS32 rev. 0 @ 0xfb240
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xb6bc
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfd4c0/160 (8 entries)
pcibios0: PCI Exclusive IRQs: 11 15
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371SB ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX AGP" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP" rev 0x03
pci1 at ppb0 bus 1
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <IBM-DTTA-350840>
wd0: 16-sector PIO, LBA, 8063MB, 16514064 sectors
atapiscsi0 at pciide0 channel 0 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <ASUS, CD-S340, 2.10> SCSI0 5/cdrom removable
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
cd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 15
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82371AB Power Mgmt" rev 0x02 at pci0 dev 7 function 3 not configured
ne3 at pci0 dev 16 function 0 "Winbond Linksys EtherPCI II" rev 0x0b: irq 11
ne3: address 00:20:18:81:41:16
vga1 at pci0 dev 19 function 0 "S3 ViRGE DX/GX" rev 0x01
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
rl0 at pci0 dev 20 function 0 "Realtek 8139" rev 0x10: irq 11 address
00:48:54:3c:75:ba
rlphy0 at rl0 phy 0: RTL internal phy
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask f7fd netmask fffd ttymask ffff
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302



Cordialement
--
Arnaud Boudou
http://www.goddess-gate.com
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Arnaud Boudou
Le #720452
Arnaud Boudou wrote:
[...]

Je fais ma petite mise à jour vers OpenBSD 3.6, et là plus de connexion
possible. La LED du modem indiquant l'activité sur l'interface LAN reste
désespérément vide, indiquant qu'il n'y à même pas un simple essai de
connexion, et donc la connexion PPPoE ne se fait jamais.

[...]



Bon, problème résolu, ça m'apprendra à oublier de merger les modifs du /etc

Cordialement
--
Arnaud Boudou
http://www.goddess-gate.com

Publicité
Poster une réponse
Anonyme