[OpenBSD] dépendances désinstallation

Le
footix
Bonjour,

Je souhaite savoir s'il existe un logiciel capable de gérer les
dépendances à la désinstallation pour les packages installés sous OpenBSD.

D'apres le man de pkg_delete ce n'est pas possible, il previent
uniquement si le package à désinstaller est requis par un autre, mais il
ne sait pas supprimer ceux qui par la suppresion du dit package
deviennent inutiles. (suis-je assez clair ? :)

Merci.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Paul GABORIT
Le #672390
À (at) Thu, 22 Apr 2004 04:47:56 +0200,
footix
Je souhaite savoir s'il existe un logiciel capable de gérer les dépendances à
la désinstallation pour les packages installés sous OpenBSD.

D'apres le man de pkg_delete ce n'est pas possible, il previent uniquement si
le package à désinstaller est requis par un autre, mais il ne sait pas
supprimer ceux qui par la suppresion du dit package deviennent
inutiles. (suis-je assez clair ? :)


Cette information n'est pas disponible !

Il faudrait pouvoir distinguer les packages qui ont été installés à la demande
*explicite* de l'utilisateur de ceux qui ont été installés *implicitement*
(via les dépendances).

--
Paul Gaborit -
espie
Le #672389
In article Paul GABORIT

À (at) Thu, 22 Apr 2004 04:47:56 +0200,
footix
Je souhaite savoir s'il existe un logiciel capable de gérer les dépendances à
la désinstallation pour les packages installés sous OpenBSD.

D'apres le man de pkg_delete ce n'est pas possible, il previent uniquement si
le package à désinstaller est requis par un autre, mais il ne sait pas
supprimer ceux qui par la suppresion du dit package deviennent
inutiles. (suis-je assez clair ? :)


Cette information n'est pas disponible !

Il faudrait pouvoir distinguer les packages qui ont été installés à la demande
*explicite* de l'utilisateur de ceux qui ont été installés *implicitement*
(via les dépendances).


On devrait l'avoir sous peu. Le pkg_delete d'Openbsd 3.5 et courant est
deja nettement plus intelligent que les versions anterieures. Typiquement,
il sait gerer des arbres de dependenace, et il est prevu de marquer des
packages comme installes explicitement par l'utilisateur... j'ai juste pas
pris le temps de le faire encore, mais c'est prevu!


Paul GABORIT
Le #672145
À (at) Thu, 22 Apr 2004 13:55:00 +0000 (UTC),
(Marc Espie) écrivait (wrote):
On devrait l'avoir sous peu. Le pkg_delete d'Openbsd 3.5 et courant est
deja nettement plus intelligent que les versions anterieures. Typiquement,
il sait gerer des arbres de dependenace, et il est prevu de marquer des
packages comme installes explicitement par l'utilisateur... j'ai juste pas
pris le temps de le faire encore, mais c'est prevu!


Super... C'est pour quand dans mon FreeBSD ? ;-)

--
Paul Gaborit -
Miod Vallat
Le #672142
(Marc Espie) écrivait (wrote):
[...]

Super... C'est pour quand dans mon FreeBSD ? ;-)


Une fois qu'il aura fini de tetter sa gentiane, peut-être ? (­:

Publicité
Poster une réponse
Anonyme