pas glop - live cd et kernel panic

Le
philippe
bonsoir

je me suis "amuser" a creer un live cd selon la methode de lea
ce live fonctionne parfaitement partout mais pas sur mon portable hp
un kernel panic apparait et "plouf!"
comment pourrais je savoir ce qui ne vas pas ?
merci d'avance
philippe

  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
Emmanuel Florac
Le #1622335
Le Sun, 09 Oct 2005 23:57:14 +0200, philippe a écrit :


je me suis "amuser" a creer un live cd selon la methode de lea
ce live fonctionne parfaitement partout mais pas sur mon portable hp
un kernel panic apparait et "plouf!"
comment pourrais je savoir ce qui ne vas pas ?


En donnant le détail du message d'erreur. En général, le problème
vient du pilote de contrôleur IDE. Si ton portable a un contrôleur
exotique, il faut mettre le pilote approprié dans l'initrd.

--
Je suis riche des biens dont je sais me passer.
Louis-Jean-Baptiste Etienne Vigée.

philippe
Le #1622327
Emmanuel Florac wrote:

bonsoir et merci pour ta reponse



je me suis "amuser" a creer un live cd selon la methode de lea
ce live fonctionne parfaitement partout mais pas sur mon portable hp
un kernel panic apparait et "plouf!"
comment pourrais je savoir ce qui ne vas pas ?



En donnant le détail du message d'erreur. En général, le problème
voila le message :

Code : 0f 0b ......(25 code en hexa)
<0>Kernel panic: Attempted to kill the idle task
In idle task - not syncing


vient du pilote de contrôleur IDE. Si ton portable a un contrôleur
exotique, il faut mettre le pilote approprié dans l'initrd.

c'est un portable hp nx 6110 celeron M360 1.4GHz


merci encore
philippe


Emmanuel Florac
Le #1622325
Le Mon, 10 Oct 2005 19:37:01 +0200, philippe a écrit :


En donnant le détail du message d'erreur. En général, le problème
voila le message :

Code : 0f 0b ......(25 code en hexa)
<0>Kernel panic: Attempted to kill the idle task
In idle task - not syncing



Bizarre, il ne dit pas un truc genre "can't mount root" un peu plus haut?


vient du pilote de contrôleur IDE. Si ton portable a un contrôleur
exotique, il faut mettre le pilote approprié dans l'initrd.

c'est un portable hp nx 6110 celeron M360 1.4GHz



Quel est le noyau utilisé?

--
De longs désirs, une longue admiration sans espérance, voilà le moyen
d'adorer les femmes, et de rendre l'amour une passion délicieuse!
N. Rétif de la Bretonne.


Emmanuel Florac
Le #1609821
Le Mon, 10 Oct 2005 23:19:19 +0200, philippe a écrit :

# uname -a
2.4.18-bf2.4


C'est carrément antédiluvien comme kernel! avec un Centrino, aucune
chance, il te faut un 2.4.30 au moins, ou mieux un 2.6 récent.

--
L'Algérie était au bord du gouffre, aujourd'hui elle a fait un grand pas
en avant.
Aït Ahmed.

philippe
Le #1609820
Emmanuel Florac wrote:


En donnant le détail du message d'erreur. En général, le problème


voila le message :
Code : 0f 0b ......(25 code en hexa)
<0>Kernel panic: Attempted to kill the idle task
In idle task - not syncing




Bizarre, il ne dit pas un truc genre "can't mount root" un peu plus haut?


ben non :-(



vient du pilote de contrôleur IDE. Si ton portable a un contrôleur
exotique, il faut mettre le pilote approprié dans l'initrd.



c'est un portable hp nx 6110 celeron M360 1.4GHz



Quel est le noyau utilisé?

# uname -a

2.4.18-bf2.4

merci
philippe



philippe
Le #1609818
Emmanuel Florac wrote:


# uname -a
2.4.18-bf2.4



C'est carrément antédiluvien comme kernel! avec un Centrino, aucune
chance, il te faut un 2.4.30 au moins, ou mieux un 2.6 récent.



ok merci
j'men donc en quette

philippe


philippe
Le #1609627
Emmanuel Florac wrote:


# uname -a
2.4.18-bf2.4



C'est carrément antédiluvien comme kernel! avec un Centrino, aucune
chance, il te faut un 2.4.30 au moins, ou mieux un 2.6 récent.



excusez ma "petitesse" mais....
j'ai telecharger debian 3.1_r0a et le kernel est 2.4.27
faut il que je telecharge un kernel 2.6.9 le compiler et "faire ma sauce"
ou bien existe til un debian en 2.4.30 ? et ou puis je trouver un miroir ?

merci philippe


Emmanuel Florac
Le #1609432
Le Tue, 11 Oct 2005 18:43:45 +0200, philippe a écrit :


excusez ma "petitesse" mais....
j'ai telecharger debian 3.1_r0a et le kernel est 2.4.27


2.4.27 ce n'est pas très frais, mais Debian a backporté pas mal de
choses dedans.
De la façon dont est bâtie la Debian, je te déconseille fortement
de compiler ton propre noyau si tu ne sais pas parfaitement ce que tu
fais. Pour un serveur c'est possible, pour une station beaucoup plus
problématique : il faut aussi recompiler ALSA par exemple.


--
Toutes les organisations ont leur règles, et les Femmes Algériennes
doivent avoir aussi leurs règles.
Aït Ahmed.

philippe
Le #1609427
Emmanuel Florac wrote:


excusez ma "petitesse" mais....
j'ai telecharger debian 3.1_r0a et le kernel est 2.4.27



2.4.27 ce n'est pas très frais,


je regarde sur debian.org et c'est la version stable de juin/juillet de 2005
ou ma "petitesse " est vraiment rectrecie

mais Debian a backporté pas mal de
choses dedans.
De la façon dont est bâtie la Debian, je te déconseille fortement
de compiler ton propre noyau si tu ne sais pas parfaitement ce que tu
fais. Pour un serveur c'est possible, pour une station beaucoup plus
problématique : il faut aussi recompiler ALSA par exemple.





Emmanuel Florac
Le #1622301
Le Tue, 11 Oct 2005 23:22:04 +0200, philippe a écrit :


je regarde sur debian.org et c'est la version stable de juin/juillet de 2005
ou ma "petitesse " est vraiment rectrecie


Oui, et? Le 2.4.27 est sorti en août 2004, ce n'est donc pas de la
dernière nouveauté. Même si c'est le plus récent disponible chez Debian.

--
Le commissaire : Comment vous appelez-vous?
Garance : Moi je ne m'appelle jamais, je suis toujours là. J'ai pas
besoin de m'appeler. Mais les autres m'appellent Garance, si ça peut
vous intéresser.
Prévert,"les enfants du Paradis".

Publicité
Poster une réponse
Anonyme