Passage de stable en testing : bilan

Le
Olive
Bonjour,

Voici un petit bilan de mon passage en testing ce WE.
Tout d'abord un grand merci à ceux qui m'ont aidé à préparer ce passage
et merci d'avance à tous ceux qui vondront bien m'éclairer sur les
quelques points obscurs qu'il reste.

Ma Debian était une Woody avec un noyau 2.6 et quelques backports ainsi
que quelques installations à partir des sources (notemment mplayer).

J'ai remplacé mon /etc/apt/sources.list et j'ai lancé l'installation par
lot de 4 ou 5 paquets avec apt-get.

1) Très peu de problèmes, les rares qui survenaient provenait des
installation à partir des sources qui installait des paquets non reconnu
et bloquait donc quelques fichiers (j'installais à partir des sources
avec checkinstall). Rien en tout cas qui ne puisse se résoudre en
désinstallant certains paquets récalcitrant avec apt-get remove ou dans
un cas extrême avec dpkg -r

2) Les questions posées lors de cet upgrade sont toutes très claires et
relativement peu nombreuses. Cependant j'aurais dû faire plus attention
lors que l'on m'a demandé un changement de politique de gestion des
droits: maintenant tous les utilisateurs sont en rwx par défaut
alors qu'ils étaient en rwx-r-xr-x avant. C'était mieux avant ! je ne
sais maintenant pas comment faire pour rechanger cette politique (je ne
vais pas mettre umask 022 en dur dans tous les .bashrc !).

3) Un petit moment déconcertant lorsque l'on me demande d'arrêter gdm,
xdm et autres C'est le retour sous la console ! je fais Ctrl-Alt-F1
et je tue à la main X et gdm.

4) On me conseille de rebooter pour des histoires de NSS ou de NFF je ne
sais plus (résolution de noms je crois). Pas de problème je reboote et
tout se passe bien (ouf !)

5) Comme tout se passe relativement bien, je finis par un sauvage
apt-get dist-upgrade en bloc et il installe tout sans problème

6) Je reboote : le tant redouté "LI" apparaît au boot et tout est bloqué
! Grattage de tête et je me souviens que l'on m'avait demandé de
relancer lilo à un moment après un remplacement de /boot/boot.d. Je sors
une vieille disquette de boot et je relance lilo, cette fois cela
démarre sans problème

7) Je suis sous le nouveau Gnome ! Qu'il est beau Je me familiarise
avec le fameux mode spatial de nautilus et j'aime beaucoup ! ;-)

8) Il est temps de passer au peaufinage ! je vérifie un à un que tous
mes logiciels fonctionnent :
-xawtv ne marche plus : classique, je réinstalle les drivers GATOS
pour mon ATI et ça marche !
-xmms ne veut plus démarrer ? après une brève recherche sur Google
groups, il est marqué qu'il faut effacer le répertoire .xmms et
relancer. Effectivement ça marche
- nedit ne veut plus se lancer du tout pour des histoires de bad
argument. Je laisse de côté pour l'instant
-mon fond d'écran géré par xplanetbg (une vue de la terre synchronisé
avec l'horloge) ne marche plus du tout et pour cause : xplanetbg
n'existe plus et est remplacé par xplanet. Bon je recommence mes
recherches sous Google et je me rends compte que personne n'a résolu le
problème : apparemment Nautilus monopolise le fond d'écran et pas moyen
d'afficher quelque chose de dynamique aussi facilement qu'avant !
Grrr moi qui avait passé tant de temps à trouver un bon fond d'écran.
Bref ce n'est pas trop grave

9) Je me déconnecte de Gnome pour la première fois et là stupeur :
l'écran devient noir et tout est bloqué ! Impossible d'accéder aux
autres consoles non plus, le seul truc qui marche encore sont les
Magic SysRq. J'arrête donc la machine à la main. Je reproduis
systématiquement le problème et lors de la 4e ou 5e fois X refuse
maintenant de démarrer à cause d'un problème de "fixed fonts" ! Il me
conseille d'aller lire/usr/share/doc/xfree86-common/FAQ.gz et je trouve
la solution à mes problème : il faut que je réinstalle xfonts-base. Ok
je réinstalle et X se relance. Toujours pas résolu le problème de la
déconnexion à ce jour si quelqu'un avait des indices

10) Je réinstalle dans le doute les fonts true type microsoft
msttcorefonts et là paf ! c'est maintenant Sylpheed qui crashe au
démarrage sur un gdk-error. Bon j'efface mon .sylpheedrc et je démarre
avec un Sylpheed avec des fontes toutes moches. Lorsque j'essaye de
sélectionner une des fontes microsoft (Arial), Paf ! ça replante sur un
gdk-error. Je suis les conseils sur le Net et je tente
defoma-reconfigure, dpkg-reconfigure x-ttcidfont-conf, apt-get install
--reinstall msttcorefonts, mkfontscale, mkfontdir, update-fonts-scale,
update-fonts-dir, etc sans trop comprendre ce que je fais et ça ne
marche toujours pas. C'est l'échec.

11) Tiens ? nedit marche maintenant, j'ai dû reinstaller le bon truc
avec tous ces problèmes de fontes

12) Apparemment les droits pour X sont encore plus reistreint qu'avant :
root ne peut plus utiliser le X d'un utilisateur. Je dois faire
explicitement un xhost+local: alors que ça marchait bien avant. Je ne
sais pas trop quoi faire pour permettre à root de toujours pouvoir
utiliser X. En passant il n'y a même plus de variable d'environnement
DISPLAY pour root ! je dois mettre dans mon .bashrc un export
DISPLAY=:0.0 ?

13) Je bascule sous une console vituelle pour vérifier un truc et la
police est devenue beaucoup trop grande ! Cela dépasse de mon écran. Ce
doit être une histoire de résolution à configer mais je ne sais pas
comment faire


Voilà, voilà, donc globalement il n'y a pas eu de gros problème mais
j'ai tout pleins de petits détails à régler
Merci à ceux qui m'aideront à régler ces détails mineurs !

J'espère que ce retour d'expérience sera utile à d'autres. En tout cas
je conseillerai plutôt à des débutants de rester sous la stable du moins
au début, gérer la testing n'est pas si facile (mais pas si dur non
plus).

Bonne soirée !


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Frédéric Bothamy
Le #7783521
* Olive
Bonjour,

Voici un petit bilan de mon passage en testing ce WE.



[...]

2) Les questions posées lors de cet upgrade sont toutes très claires et
relativement peu nombreuses. Cependant j'aurais dû faire plus attention
lors que l'on m'a demandé un changement de politique de gestion des
droits: maintenant tous les utilisateurs sont en rwx------ par défaut
alors qu'ils étaient en rwx-r-xr-x avant. C'était mieux avant ! je ne
sais maintenant pas comment faire pour rechanger cette politique (je ne
vais pas mettre umask 022 en dur dans tous les .bashrc !).



C'est peut-être adduser ou base-files, mais je ne vois rien dans les
scripts debconf qui fasse cela...

3) Un petit moment déconcertant lorsque l'on me demande d'arrêter gdm,
xdm et autres... C'est le retour sous la console ! je fais Ctrl-Alt-F1
et je tue à la main X et gdm.



Dans les futures notes de version de Sarge, il sera indiqué qu'il est
préférable d'éviter de mettre à jour depuis une session X (tout comme
pour Woody, il me semble).

4) On me conseille de rebooter pour des histoires de NSS ou de NFF je ne
sais plus (résolution de noms je crois). Pas de problème je reboote et
tout se passe bien (ouf !)



NSS certainement.

[...]

12) Apparemment les droits pour X sont encore plus reistreint qu'avant :
root ne peut plus utiliser le X d'un utilisateur. Je dois faire
explicitement un xhost+local: alors que ça marchait bien avant. Je ne
sais pas trop quoi faire pour permettre à root de toujours pouvoir
utiliser X. En passant il n'y a même plus de variable d'environnement
DISPLAY pour root ! je dois mettre dans mon .bashrc un export
DISPLAY=:0.0 ?



Euh, non. root n'a jamais eu les droits suffisants pour accéder à
l'affichage (display) d'un utilisateur (sauf, bien sûr, si tu fais un
"xhost +" dans ton script de démarrage de session X). Une bonne façon
d'accéder à cet affichage pour root est d'utiliser sudo.

Pas d'idée pour tes autres questions.


Fred

--
Comment poser les questions de manière intelligente ?
http://www.gnurou.org/documents/smart-questions-fr.html
Comment signaler efficacement un bug ?
http://www.chiark.greenend.org.uk/~sgtatham/bugs-fr.html


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Glennie Vignarajah
Le #7782901
Olive a écrit:

Bonsoir,


10) Je réinstalle dans le doute les fonts true type microsoft
msttcorefonts et là paf ! c'est maintenant Sylpheed qui crashe au
démarrage sur un gdk-error. Bon j'efface mon .sylpheedrc et je
démarre avec un Sylpheed avec des fontes toutes moches. Lorsque
j'essaye de sélectionner une des fontes microsoft (Arial), Paf ! ça
replante sur un gdk-error.



Essayez d'installer en plus le package xfonts-100dpi-transcoded si
votre résolution d'écran est supérieur 1024x768. Si elle est
inférieure , essayez xfonts-75dpi-transcoded.
A+

--
Glennie
"Personne ne survit au fait d'être estimé au-dessus de sa valeur."


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Olive
Le #7782451
On Thu, 07 Oct 2004 23:00:13 +0200, Glennie Vignarajah

> 10) Je réinstalle dans le doute les fonts true type microsoft
> msttcorefonts et là paf ! c'est maintenant Sylpheed qui crashe au
> démarrage sur un gdk-error. Bon j'efface mon .sylpheedrc et je
> démarre avec un Sylpheed avec des fontes toutes moches. Lorsque
> j'essaye de sélectionner une des fontes microsoft (Arial), Paf ! ça
> replante sur un gdk-error.

Essayez d'installer en plus le package xfonts-100dpi-transcoded si
votre résolution d'écran est supérieur 1024x768. Si elle est
inférieure , essayez xfonts-75dpi-transcoded.
A+




C'était bien ça !
J'ai réinstallé les deux (qui étaient déjà installés) et maintenant tout
fonctionne impeccable !
Comment pouvais-je deviner un truc comme cela ?
Et comment cela se fait-il que ces paquets aient été corrompues ?

En tout cas merci beaucoup !


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Olive
Le #7782441
On Thu, 7 Oct 2004 00:53:56 +0200, Frédéric Bothamy

> Voici un petit bilan de mon passage en testing ce WE.

[...]

> 2) Les questions posées lors de cet upgrade sont toutes très claires
> et relativement peu nombreuses. Cependant j'aurais dû faire plus
> attention lors que l'on m'a demandé un changement de politique de
> gestion des droits: maintenant tous les utilisateurs sont en
> rwx------ par défaut alors qu'ils étaient en rwx-r-xr-x avant.
> C'était mieux avant ! je ne sais maintenant pas comment faire pour
> rechanger cette politique (je ne vais pas mettre umask 022 en dur
> dans tous les .bashrc !).

C'est peut-être adduser ou base-files, mais je ne vois rien dans les
scripts debconf qui fasse cela...



C'était bien ça !
Lors de l'installation de adduser, il m'a posé la question pour savoir
si je voulais une installation "system wide", j'avais répondu non...
J'ai fait un dpkg-reconfigure adduser et j'ai répondu oui et maintenant
c'est bon !


> 3) Un petit moment déconcertant lorsque l'on me demande d'arrêter
> gdm, xdm et autres... C'est le retour sous la console ! je fais
> Ctrl-Alt-F1 et je tue à la main X et gdm.

Dans les futures notes de version de Sarge, il sera indiqué qu'il est
préférable d'éviter de mettre à jour depuis une session X (tout comme
pour Woody, il me semble).



J'aurais dû m'en douter remarque...

> 12) Apparemment les droits pour X sont encore plus reistreint
> qu'avant : root ne peut plus utiliser le X d'un utilisateur. Je dois
> faire explicitement un xhost+local: alors que ça marchait bien
> avant. Je ne sais pas trop quoi faire pour permettre à root de
> toujours pouvoir utiliser X. En passant il n'y a même plus de
> variable d'environnement DISPLAY pour root ! je dois mettre dans mon
> .bashrc un export DISPLAY=:0.0 ?

Euh, non. root n'a jamais eu les droits suffisants pour accéder à
l'affichage (display) d'un utilisateur (sauf, bien sûr, si tu fais un
"xhost +" dans ton script de démarrage de session X). Une bonne façon
d'accéder à cet affichage pour root est d'utiliser sudo.



Ah ? Bizarre cela marchait sous la Woody...
Bon je vais jeter un oeil sur sudo alors (même si je n'ai aucune idée de
comment cela marche...)


Merci pour ton aide !


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Glennie Vignarajah
Le #7782411
Olive a écrit:

C'était bien ça !
J'ai réinstallé les deux (qui étaient déjà installés) et maintenant
tout fonctionne impeccable !
Comment pouvais-je deviner un truc comme cela ?



J'ai eu les erreurs "Gdk-Error" subitement. Il m'a fallu des jours
pour trouver la solution en recoupant tout ce que j'avais trouvé sur
google...

Et comment cela se fait-il que ces paquets aient été corrompues ?


Je ne pense pas ce soit un corruption de paquets mais plutôt une
corruption d'un fichier qui cache les fonts...
A+

--
Glennie
"Personne ne survit au fait d'être estimé au-dessus de sa valeur."


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Poster une réponse
Anonyme