Pb apres un upgrade de Gnome 2.6 vers 2.6.1

Le
Thierry
Bonsoir,
Bon là, j'ai tout de meme un gros soucis
J'ai upgradé mon systeme, je tourne sous Debian SID Du coup, gnome a
aussi été upgradé, l'ennui, est que mes icones n'apparaissent plus

http://urania.ouvaton.org/Capture.png

Lorsque je vais voir dans /usr/share/pixmaps, le repertoire n'est pas
vide, je peux lister les icones que j'utilise, mais gnome ne reconnait
plus le type, et certaines applis ne demarre plus à cause de ce pb ex
gftp :

(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « industrial »
(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « industrial »
(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « industrial »
Erreur de segmentation

Concernant gaim, plus aucunes icones au niveau des contacts, gkrellm
refuse de demarrer :

(gkrellm:7555): GdkPixbuf-WARNING **: Error loading XPM image loader:
L'image du type « xpm » n'est pas supportée
Impossible de charger le xpm : krell_slider

Donc soit je downgrade (on fait comment ?) soit je trouve ou l'on m'aide
à trouver une solution

Une idée ?

Merci
Vos réponses
Trier par : date / pertinence
ericb
Le #1075558
Bonjour,

Bonsoir,
Bon là, j'ai tout de meme un gros soucis ...
J'ai upgradé mon systeme, je tourne sous Debian SID ... Du coup, gnome a
aussi été upgradé, l'ennui, est que mes icones n'apparaissent plus ...


As-tu la liste des paquets mis à jour ?



http://urania.ouvaton.org/Capture.png



Je vois. J'ai eu ce problème avec gdm, ou bonobo, une fois (plus très
sûr du nom). En réinstallant l'ancien, c'est reparti.

(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « industrial »
(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « industrial »
(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « industrial »
Erreur de segmentation


gtk-engines-industrial ?


(gkrellm:7555): GdkPixbuf-WARNING **: Error loading XPM image loader:
L'image du type « xpm » n'est pas supportée
Impossible de charger le xpm : krell_slider





Donc soit je downgrade (on fait comment ?) soit je trouve ou l'on m'aide
à trouver une solution ...


Si tu n'as pas fait d'apt-get clean, tous les paquets chargés se
trouvent dans /var/cache/apt/archives

Et il y a peut-être encore la version qui précède...

Il suffit d'un dpkg -i ancienne_version.deb


""" exemple à ne pas forcément suivre """"""""""

Quand j'ai un problème comme ça, j'invente un répertoire
~/problemes/date_du_jour et j'y place tous les paquets que je veux
réinstaller (les anciennes versions, je veux dire).

Ensuite, je me place dans ce répertoire je fais simplement un :

dpkg -i ./*.deb


Attention : je vérifie les dépendances AVANT...
"""""""""""""""""""""""""""""""""""""""""""""""""


Merci



Pas de quoi







--
revp onpuneq

Thierry
Le #1075554
On Sat, 22 May 2004 20:42:29 +0200, ericb wrote:

Bonjour,

Bonsoir,
Bon là, j'ai tout de meme un gros soucis ...
J'ai upgradé mon systeme, je tourne sous Debian SID ... Du coup, gnome a
aussi été upgradé, l'ennui, est que mes icones n'apparaissent plus ...


As-tu la liste des paquets mis à jour ?
ben disons qu'au prealable j'avais fait un apt-get dist-upgrade ... donc

y en a un paquet

http://urania.ouvaton.org/Capture.png



Je vois. J'ai eu ce problème avec gdm, ou bonobo, une fois (plus très
sûr du nom). En réinstallant l'ancien, c'est reparti.
j'aurais bien voulu downgrader aussi ...

(gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le moteur de
thème dans module_path : « industrial » (gftp-gtk:7500): Gtk-WARNING
**: Impossible de trouver le moteur de thème dans module_path : «
industrial » (gftp-gtk:7500): Gtk-WARNING **: Impossible de trouver le
moteur de thème dans module_path : « industrial » Erreur de
segmentation


gtk-engines-industrial ?
oui ... ? (aussi)


(gkrellm:7555): GdkPixbuf-WARNING **: Error loading XPM image loader:
L'image du type « xpm » n'est pas supportée
Impossible de charger le xpm : krell_slider





Donc soit je downgrade (on fait comment ?) soit je trouve ou l'on
m'aide à trouver une solution ...


Si tu n'as pas fait d'apt-get clean, tous les paquets chargés se
trouvent dans /var/cache/apt/archives
si si, bien sur, sinon se serait trop simple ;)

Et il y a peut-être encore la version qui précède...

Il suffit d'un dpkg -i ancienne_version.deb


""" exemple à ne pas forcément suivre """"""""""

Quand j'ai un problème comme ça, j'invente un répertoire
~/problemes/date_du_jour et j'y place tous les paquets que je veux
réinstaller (les anciennes versions, je veux dire).

Ensuite, je me place dans ce répertoire je fais simplement un :

dpkg -i ./*.deb


Attention : je vérifie les dépendances AVANT...
"""""""""""""""""""""""""""""""""""""""""""""""""


Merci



Pas de quoi




autrement d'y, mise a part attendre la nouvelle version de gnome, je dois


me forcer à m'orienter vers un autre bureau ??

merci pour ton aide


ericb
Le #1509509
On Sat, 22 May 2004 20:42:29 +0200, ericb wrote:

As-tu la liste des paquets mis à jour ?


ben disons qu'au prealable j'avais fait un apt-get dist-upgrade ... donc
y en a un paquet


Oui, mais c'est plutôt du côté des paquets gnome qu'il faut chercher, et
il ne doit pas y en avoir tant que ça de concernés...

À tout hasard, utilises-tu apt-listchanges ? Parce que si c'est le cas,
tu devrais avoir une trace + facilement. En effet, un mail t'est envoyé,
contenant tous les changelogs.
Tu peux aussi faire une recherche par date avec find...

Ensuite, si tu parcours les sites qui sont dans ton
/etc/apt/sources.list, tu pourra charger à la main toutes les versions
juste antérieures à la mise à jour.

Enfin, sur le site Debian, tu pourras essayer de chercher, avec le nom
des paquets que tu as installé, s'il n'y en a pas un qui provoque ton
bug, justement...




autrement d'y, mise a part attendre la nouvelle version de gnome, je dois


me forcer à m'orienter vers un autre bureau ??



Non, il y a forcément une trace de tout ce qui a été installé. Je ne
connais pas la commande, mais elle existe forcément. Quelqu'un peut aider ?


Je donne souvent ce conseil, mais tu en fais ce que tu veux :

Avec une sid, il n'y aura pas grand monde pour t'aider, alors il faut
"blinder" chaque mise à jour. Par exemple en installant apt-listbugs
Ainsi, avant d'installer un paquet, les bugs (si déjà) listés dans le
Debian Bug List te seront signalés pou ce paquet.




--
revp onpuneq



Publicité
Poster une réponse
Anonyme