pb ftps toujours pas résolu

Le
dadou pipo
Bonjour

J'essaye d'acceder à un site ftps à partir dune machine derriere un routeur
netgear RP614 voici le dialogue entre le ftps (client de mon micro) et le
site distant (serveur)

a partir d'une station sans routeur c'est bon, que faire
J'ai essayé le mode passif, rien n'y fait !!!
J'ai ouvert tous les ports vers la station cliente, rien n'y fait !!!

un peu d'aide svp, merci


Connecting to 80.13.182.183:21
Connected to 80.13.182.183:21 in 0.250, Waiting for Server Response
220 dxctr01 X2 WS_FTP Server 4.0.0 (2389233079)
Host type (1): WS_FTP Server
AUTH SSL
234 SSL enabled and waiting for negotiation
XAUT 2 ?1B???@B27:@4@4B:7??3@5A;;1@8?5A;87@3@6B>55@2@6B:;?@6D4
230 user logged in
Host type (I): WS_FTP Server
Host type (I): WS_FTP Server
PWD
257 "/" is current directory
pwd
257 "/" is current directory
PORT 192,168,0,2,4,123
504 Invalid PORT address -> ERREUR !!!!
Port failed 504 Invalid PORT address -> ERREUR !!!!
PASV
200 command successful
Unable to parse 200 command successful
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
dadou pipo
Le #403990
Voila la suite

J'ai donc passé le serveur en SSL data.

Coté client en normal, les messages sont les mêmes !!!
en passif... un peu différents, mais le résultat : identique... niet, niet
...

Connecting to 80.13.182.188:21
Connected to 80.13.182.188:21 in 1.552, Waiting for Server Response
220 ddxyz X2 WS_FTP Server 4.0.0 (3905093200)
Host type (1): WS_FTP Server
AUTH SSL
234 SSL enabled and waiting for negotiation
XAUT 2 98C@>>A999C3K6:5C;Z5:4D:A;B294D:>µ:3C???B8:3C;A5B465
230 user logged in
Host type (I): WS_FTP Server
Host type (I): WS_FTP Server
PWD
257 "/" is current directory
pwd
257 "/" is current directory
PASV
227 Entering Passive Mode (192,168,0,100,13,172).
connecting data channel to 192.168.0.100:3500
connection refused; the server would not accept an FTP connection. ->>>>>>
PORT 192,168,0,2,4,149
504 Invalid PORT address --->>>>>
Port failed 504 Invalid PORT address ---->>>>>>>

voila, toujours le même combat !!!

a+

"Annie D." <> a écrit dans le message de news:
dadou pipo wrote:

En ftp normal pas de problème.

Le serveur est aussi derrière un Routeur.

J'ai fait l'essai avec mon routeur et ma machine en serveur (et ftps),



pas de problème si une machine est en directe sur le web, mais je
retrouve


le même problème si elle est derrière un routeur...(tout comme moi..


C'est le problème archi-classique avec FTP+NAT. Quand un seul des deux
côtés est NATé, on peut s'en sortir car l'un des deux modes actif ou
passif marche sans précautions particulières : c'est le mode dans lequel
c'est le côté non NATé qui reçoit la connexion de données et transmet
son adresse publique à l'autre. Par contre quand les deux côtés sont
NATés, il faut qu'au moins un des deux côtés soit capable de modifier
l'adresse transmise dans la connexion de contrôle. Mais si cette
connexion est chiffrée, je ne vois pas comment c'est possible.

Sur le serveur il y a la possibilité SSL data (seul les données sont en
SSL)


donc normalement le reste non, j'ai essayé et j'ai toujours le même
problème, mais pas les mêmes messages.


Quels messages ? Des logs, bon sang !



Annie D.
Le #403932
dadou pipo wrote:

J'ai donc passé le serveur en SSL data.

Coté client en normal, les messages sont les mêmes !!!
en passif... un peu différents, mais le résultat : identique... niet, niet

227 Entering Passive Mode (192,168,0,100,13,172).
connecting data channel to 192.168.0.100:3500
connection refused; the server would not accept an FTP connection. ->>>>>>


Au moins cette fois le serveur retourne une réponse correcte contenant
son adresse IP locale. Mais son routeur NAT n'a pas modifié celle-ci,
qui n'est pas joignable par le client. Ne connaissant pas les modes
SSL/TLS du FTP, je ne peux aller plus loin.

dadou pipo
Le #406979
MERCI pour tout

a+

"Annie D."
dadou pipo wrote:

J'ai donc passé le serveur en SSL data.

Coté client en normal, les messages sont les mêmes !!!
en passif... un peu différents, mais le résultat : identique... niet,
niet



227 Entering Passive Mode (192,168,0,100,13,172).
connecting data channel to 192.168.0.100:3500
connection refused; the server would not accept an FTP
onnection. ->>>>>>



Au moins cette fois le serveur retourne une réponse correcte contenant
son adresse IP locale. Mais son routeur NAT n'a pas modifié celle-ci,
qui n'est pas joignable par le client. Ne connaissant pas les modes
SSL/TLS du FTP, je ne peux aller plus loin.



Poster une réponse
Anonyme