Pb LDAP upgrade Stable(sarge) vers testing (etch)

Le
fouinix
Bien le bonjour tout le monde.
Je m'tais cr un annuaire ldap sous ma debian sarge, mais j'avais
besoin de versions de paquets plus jour (mod_vhost_ldap d'apache
entre autre).
Du coup j'ai fait un petit coup d'apt-get update; suivi de apt-get
dist-upgrade.
Tout s'est bien pass, le hic c'est que la version de ldap a t
mise jour et j'ai t soumis deux problmes:
Le premier: slapd demande un fichier de config DB_CONFIG, en faisant un
peu de recherche on trouve quoi il sert et mme un example dans
/usr/share/doc/slapd/example/.

Deuxime problme plus majeur:
Lorsque je lance slapd, aucun problme a l'air de tourner nikel.
Mais lorsque je veux ajouter des donnes a se corse:
debian:/etc/ldap# slapadd -l annuaire.ldif
bdb_db_open: database already in use
backend_startup_one: bi_db_open failed! (-1)
slap_startup failed
debian:/etc/ldap#

Je tiens preciser que mon fichier de conf (slapd.conf) et mon
fichier annuaire.ldif n'ont pas t chang entre les mises jours.
Alors soit c'est un bug de la debian etch ou alors la nouvelle version
de slapd qui demande une configuration diffrente mais j'ai pas
trouv.

Je cherche trouver cet ventuel processus qui utiliserait la base
de donnes. Je tiens preciser qu'il n'y a qu'un instance de slapd
qui tourne !!
Si quelqu'un peut m'apporter ses lumires !!
NAYRAT Adrien
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent Lenouvel
Le #9437881
This is a MIME-formatted message. If you see this text it means that your
E-mail software does not support MIME-formatted messages.

--=_averell-25467-1161064484-0001-2
Content-Type: text/plain; charset=ISO-8859-15
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 16 Oct 2006 14:36:06 -0700
"fouinix"
Bien le bonjour tout le monde.



Bonjour,

Lorsque je lance slapd, aucun problème ça à l'air de tourner nikel.
Mais lorsque je veux ajouter des données ça se corse:
debian:/etc/ldap# slapadd -l annuaire.ldif
bdb_db_open: database already in use
backend_startup_one: bi_db_open failed! (-1)
slap_startup failed
debian:/etc/ldap#





Je cherche à trouver cet éventuel processus qui utiliserait la base
de données. Je tiens à preciser qu'il n'y a qu'un instance de slapd
qui tourne !!



La commande lsof sert à déterminer les fichiers ouverts.

Slapd est lancé, c'est bien la le pb.
Arrete slapd, slapadd sert à remplir la base lorsque
aucune instance du serveur ldap ne soit lancée.


--
Vincent Lenouvel - Université de Caen, Campus II, Bd Maréchal Juin, BP 5186, 14032 Caen
Empreinte de la clé = D14D EFE9 4F55 AF89 98B0 666B 17E5 C840 4B0D 80E4
wget -O - http://users.info.unicaen.fr/~vincent/signature.asc | gpg --import

--=_averell-25467-1161064484-0001-2
Content-Type: application/pgp-signature
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFNHAjF+XIQEsNgOQRAsc5AJ0ZraSsaYcmTzRETRBPuAlg/vhnIQCfa4WN
AS954gbId9Tk28ETmS5rwcQ =Sz5O
-----END PGP SIGNATURE-----

--=_averell-25467-1161064484-0001-2--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fouinix
Le #9437501
Vincent Lenouvel a écrit :

On 16 Oct 2006 14:36:06 -0700
"fouinix"
> Bien le bonjour tout le monde.

Bonjour,

> Lorsque je lance slapd, aucun problème ça à l'air de tourner nike l.
> Mais lorsque je veux ajouter des données ça se corse:
> debian:/etc/ldap# slapadd -l annuaire.ldif
> bdb_db_open: database already in use
> backend_startup_one: bi_db_open failed! (-1)
> slap_startup failed
> debian:/etc/ldap#


>
> Je cherche à trouver cet éventuel processus qui utiliserait la base
> de données. Je tiens à preciser qu'il n'y a qu'un instance de slapd
> qui tourne !!

La commande lsof sert à déterminer les fichiers ouverts.

Slapd est lancé, c'est bien la le pb.
Arrete slapd, slapadd sert à remplir la base lorsque
aucune instance du serveur ldap ne soit lancée.


--
Vincent Lenouvel - Université de Caen, Campus II, Bd Maréchal Juin, BP 5186, 14032 Caen
Empreinte de la clé = D14D EFE9 4F55 AF89 98B0 666B 17E5 C840 4B0D 8 0E4
wget -O - http://users.info.unicaen.fr/~vincent/signature.asc | gpg --imp ort

--=_averell-25467-1161064484-0001-2
Content-Type: application/pgp-signature
X-Google-AttachSize: 190



Bon, ben je me sens très con. Je suis en train de me poser la question
de pourquoi je n'avais pas fait ca avant. En tout ca felicitation le
problème venait de la !!
Publicité
Poster une réponse
Anonyme