Pb de scanner brother

Le
Daniel Caillibaud
Bonjour,

J'ai un souci sur un PC avec une imprimante / scanner brother DCP-7010.

Ça marchait très bien sur un vieux PC 32 i386 sous lenny/squeeze/=
jessie,
mais sur un nouveau PC installé en stretch amd64 pas moyen de lui
faire reconnaître le scanner.

J'ai récupéré les paquets sur
https://support.brother.com/g/b/downloadhowto.aspx?c=fr&lang=fr&prod==
dcp7010_eu_as&os=128&dlid=dlf006637_000&flang=4&type3=566
et lu (entre autres)
https://support.brother.com/g/b/faqend.aspx?c=fr&lang=fr&prod=dcp7010=
_eu_as&faqid=faq00100604_000&ot=eu_ot
https://wiki.archlinux.org/index.php/SANE/Scanner-specific_problems#Brother
https://doc.ubuntu-fr.org/brother_driver_install_tool

Pourtant tout semble ok

lsusb

Bus 004 Device 002: ID 04f9:0182 Brother Industries, Ltd DCP-7010


l /dev/bus/usb/004/002
crw-rw-r--+ 1 root lp 189, 385 avril 14 13:30 /dev/bus/usb/004/002

le user est bien dans le groupe lp, mais même en root j'ai

sane-find-scanner

found USB scanner (vendor=0x04f9, product=0x0182) at libusb:004:002

et
scanadf -l
scanadf: no SANE devices found

ou
scanimage -L
No scanners were identified

J'ai essayé de changer le /etc/udev/rules.d/60-brother-libsane-type1.r=
ules

qui contient

ACTION!="add", GOTO="brother_mfp_end"

SUBSYSTEM=="usb", GOTO="brother_mfp_udev_1"
SUBSYSTEM!="usb_device", GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_1"

SYSFS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
ATTRS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_2"

ATTRS{bInterfaceClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceSubClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceProtocol}!="0ff", GOTO="brother_mfp_end"

ENV{libsane_matched}="yes"

LABEL="brother_mfp_end"


(il est fourni par le paquet brother-udev-rule-type1-1.0.2-0.all.deb, qui
installe l'original
dans /opt/brother/scanner/udev-rules/type1/NN-brother-mfp-type1.rules) pour
remettre ce qu'on avait dans les distribs précédentes :

ATTRS{idVendor}=="04f9", MODE="0664", GROUP="scanner", ENV{libsane_=
matched}="yes"

mais ça change rien

Y'avait d'ailleurs déjà dans /lib/udev/rules.d/60-libsane.rules l=
a ligne

ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="2038", ENV{libsane_matc=
hed}="yes"

Les paquets installés sont, entre autre

udev
libudev1
brother-udev-rule-type1
brscan-skey
brscan2
sane
xsane
(avec leurs dépendances)

Bref, je vois plus trop où chercher… si qqun a une idée j=
e suis preneur ;-)


--
Daniel

A vaincre sans péril, on évite des ennuis !
Goscinny (un général Romain dans "Asterix chez les bretons")
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Publicité
Poster une réponse
Anonyme