Prise en charge de Java par les navigateurs en général // Compatibilité Mozilla/Opera

Le
Debug
Bonjour à tous ! Désolé de devoir encore solliciter votre aide

Débutant en Java, je programme en ce moment une petite applet destinée à
pouvoir être visible sur la majorité des navigateurs Web sans avoir à
installer "quoi que ce soit de spécifique à Java" : je voudrais que le
navigateur de n'importe quel internaute (même novice) puisse utiliser mon
applet.

Je m'explique : lors de mes premiers essais, je m'étais rendu compte que le
code Java 1.1 semblait pouvoir être interprêté par mon navigateur sans que
j'aie eu à installer une JVM ou un SDK particulier : mon navigateur (IE en
l'occurence, je suis sous WinXP) interprêtait sans difficulté toute applet
rédigée en Java 1.1. (J'avais ensuite lu sur un site Web que tout code
rédigé en 1.1 "passait partout" car les différents créateurs de browsers
s'étaient mis d'accord pour 'supporter' cette version de Java par
défaut).

Persuadé que le code 1.1 serait lisible par le navigateur de n'importe quel
quidam, je me suis alors lancé dans la rédaction de mon applet à grands
renforts de "javac File.java -target 1.1". Jusque-là : tout allait bien.

Or, je viens d'installer "Mozilla" et "Opéra" afin de faire qques tests et
voir comment mon applet se comportait, et je remarque que tous deux refusent
de lancer mon applet :
- Mozilla/Firefox m'indique sobrement "Java n'est pas activé" dans le cadre
de l'applet.
- Opera m'affiche le message suivant : "The Opera Java classes does not have
enough permissions to execute. () Java applets will not work".
( et pourtant, tout marche comme sur des roulettes avec IE !!)


D'où ces questions :
--

a) Ai-je tort de penser que le code 1.1 est connu de tous les navigateurs,
par défaut ?

b) Les erreurs de Mozilla et Opera sont-elles uniquement dûes à un problème
de paramètrage des softs, ou bien faut-il installer qqch de particulier pour
utiliser Java sur ces navigateurs ? (auquel cas mon beau rêve de
compatibilité et d'accessibilité pour les internautes novices n'est plus
qu'un tas de confettis)

c) Que faire pour faire en sorte que mon applet soit lisible par le
navigateur de n'importe quel internaute, aussi novice soit-il ? (ou par le
maximum de navigateurs, en tout cas)


Je vous remercie d'avance de vos réponses, dont va vraisemblablement
dépendre la suite de mon développement.

A++

Debug ;-)
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Phildes
Le #725694
Lire le sujet "Java et Window XP" qui parle déjà de ce sujet.

IE en l'occurence, je suis sous WinXP)
interprêtait sans difficulté toute applet
rédigée en Java 1.1
Ce n'est pas le cas de tous les XP. Microsoft a supprimé la Machine-Java

dans XP.

a) Ai-je tort de penser que le code 1.1 est connu de tous
les navigateurs, par défaut ?
redite : sur mon site, selon mes stats, seuls 8 visiteurs sur 10 peuvent

voir les Applet - en java 1.1

mon beau rêve de compatibilité et d'accessibilité
pour les internautes novices n'est plus
qu'un tas de confettis
Si vous voulez être lisible par la totalitié de vos visiteurs... Oui, ce

n'est qu'un tas confettis.

Dans le sujet "Java et Windows XP" Cédric écrit : "à mon avis, les applets,
c'est mort "
A mon grand regret, si Sun ne trouve pas une idée géniale je crains qu'il
ait raison.
( En espérant que Sun ait envie de défendre les Applets "grand public")

Philippe

Marc Collin
Le #725693
Debug wrote:

Bonjour à tous ! Désolé de devoir encore solliciter votre aide...

Débutant en Java, je programme en ce moment une petite applet destinée à
pouvoir être visible sur la majorité des navigateurs Web sans avoir à
installer "quoi que ce soit de spécifique à Java" : je voudrais que le
navigateur de n'importe quel internaute (même novice) puisse utiliser mon
applet.


win xp incluait une jvm, ce qui n'est pu le cas... de tout façon xp
représente même pas 25% du parc informatique en terme d'os


Je m'explique : lors de mes premiers essais, je m'étais rendu compte que le
code Java 1.1 semblait pouvoir être interprêté par mon navigateur sans que
j'aie eu à installer une JVM ou un SDK particulier : mon navigateur (IE en
l'occurence, je suis sous WinXP) interprêtait sans difficulté toute applet
rédigée en Java 1.1. (J'avais ensuite lu sur un site Web que tout code
rédigé en 1.1 "passait partout" car les différents créateurs de browsers
s'étaient mis d'accord pour 'supporter' cette version de Java par
défaut...).


autant opté pour une version beaucoup plus récente
une personne qui voudra faire rouler ton applet le téléchargera au
besoin... ce que toute personne doit déjà faire pour flash, shockwave,
realplayer... codec de wmp et cie

Persuadé que le code 1.1 serait lisible par le navigateur de n'importe quel
quidam, je me suis alors lancé dans la rédaction de mon applet à grands
renforts de "javac File.java -target 1.1". Jusque-là : tout allait bien.


le 1.1 est plus que vieux c'est rendu à 1.42_05 ou truc du genre

Or, je viens d'installer "Mozilla" et "Opéra" afin de faire qques tests et
voir comment mon applet se comportait, et je remarque que tous deux refusent
de lancer mon applet :
- Mozilla/Firefox m'indique sobrement "Java n'est pas activé" dans le cadre
de l'applet.
- Opera m'affiche le message suivant : "The Opera Java classes does not have
enough permissions to execute. (...) Java applets will not work".
(... et pourtant, tout marche comme sur des roulettes avec IE !!)


D'où ces questions :
--------------------

a) Ai-je tort de penser que le code 1.1 est connu de tous les navigateurs,
par défaut ?


oui

b) Les erreurs de Mozilla et Opera sont-elles uniquement dûes à un problème
de paramètrage des softs, ou bien faut-il installer qqch de particulier pour
utiliser Java sur ces navigateurs ? (auquel cas mon beau rêve de
compatibilité et d'accessibilité pour les internautes novices n'est plus
qu'un tas de confettis)

c) Que faire pour faire en sorte que mon applet soit lisible par le
navigateur de n'importe quel internaute, aussi novice soit-il ? (ou par le
maximum de navigateurs, en tout cas)



utilise une version plus récente... car le novice doit de toute façon
installer java

Je vous remercie d'avance de vos réponses, dont va vraisemblablement
dépendre la suite de mon développement.

A++

Debug ;-)





--
La boîte à prog http://www.laboiteaprog.com

Christophe M
Le #725454
Debug wrote:


D'où ces questions :
--------------------

a) Ai-je tort de penser que le code 1.1 est connu de tous les navigateurs,
par défaut ?


Oui, seul microsoft AVAIT les droits d'intégrer un runtime java dans son
système. Après les problèmes de microsoft vs sun, Sun à décidé de ne
plus licencer de runtime comme cela. Et les autres navigateurs ont
décidé de ne pas intégrer de runtime pour être plus "standard" avec
java, ils utilisent uniquement celui qui est installé sur l'OS ou ils
tournent. (ce qui permet tout de même d'utiliser celui qu'on veut,sans
être limité à une version précise)


b) Les erreurs de Mozilla et Opera sont-elles uniquement dûes à un problème
de paramètrage des softs, ou bien faut-il installer qqch de particulier pour
utiliser Java sur ces navigateurs ? (auquel cas mon beau rêve de
compatibilité et d'accessibilité pour les internautes novices n'est plus
qu'un tas de confettis)


Il faut, pour ces navigateurs, installer le runtime de Java.
Et tant qu'à faire, autant prendre le dernier.


c) Que faire pour faire en sorte que mon applet soit lisible par le
navigateur de n'importe quel internaute, aussi novice soit-il ? (ou par le
maximum de navigateurs, en tout cas)



Simplement, dans les tags de l'applet, mettre les liens qui permettent
de télécharger le runtime si celui-ci n'est pas installé.
Dans la docs sur les applets, il est expliqué comment écrire ces tags,
qui sont respectés par tous les navigateurs.

Après, évidemment, si l'utilisateur décide de dire "Non, je veux pas
l'installer pour voir le truc de la page", c'est son choix à lui, et
rien ne pourra l'empécher de ne pas l'installer et de se priver d'un de
tes services.


Je vous remercie d'avance de vos réponses, dont va vraisemblablement
dépendre la suite de mon développement.

A++

Debug ;-)




Debug
Le #725451
Merci beaucoup pour votre réponse, elle répond à mes questions.

Pourriez-vous essayer de répondre à mon prochain post : "Code HTML (?) pour
téléchargement d'une JVM si besoin", s'il vous plaît ?

Je vous remercie d'avance, je débute et je suis un peu perdu, même avec les
documentations officielles...

Debug ;-)
Debug
Le #725450
Merci beaucoup pour votre réponse, elle répond à mes questions.

Pourriez-vous essayer de répondre à mon prochain post : "Code HTML (?) pour
téléchargement d'une JVM si besoin", s'il vous plaît ?

Je vous remercie d'avance, je débute et je suis un peu perdu, même avec les
documentations officielles...

Debug ;-)
Debug
Le #725449
Merci beaucoup pour votre réponse, elle répond à mes questions.

Pourriez-vous essayer de répondre à mon prochain post : "Code HTML (?) pour
téléchargement d'une JVM si besoin", s'il vous plaît ?

Je vous remercie d'avance, je débute et je suis un peu perdu, même avec les
documentations officielles...

Debug ;-)
Poster une réponse
Anonyme