Probl=c3=a8me de r=c3=a9solution de nom Dnsmasq dans les navigateurs=2e

Le
contact
Bonjour

pour des besoins pédagogiques, j'ai installé une machine sous Linux
DEBIAN avec Dnsmasq dessus pour créer gérer un réseau local sans
connexion vers l’extérieur. J'ajoute que cette machine sert aussi de
serveur web avec Apache.

depuis un poste sous windows un nslookup ou bien un ping sur
nomMachine.nomreseau fonctionnent parfaitement.

Cependant depuis le navigateur le serveur web :

-> répond parfaitement quand je saisie l'adresse IP

-> une page introuvable avec nomMachine.nomreseau

-> une erreur 400 avec http://nomMachine.nomreseau

Et la je n'ai pas de piste, n'étant pas spécialiste dans ce domaine.

Ceci vient il de la configuration du navigateur, ou d'APACHE ?

Merci par avance pour votre aide

--
François-Marie BILLARD
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
contact
Le #26513449
Un virtual host dans la configuration d'apache règle le problème.
François-Marie BILLARD
Le 29/03/2019 à 09:03, Eric Degenetais a écrit :
Le jeu. 28 mars 2019 19:24, contact
Bonjour
Bonjour
pour des besoins pédagogiques, j'ai installé une machine sous Linux
DEBIAN avec Dnsmasq dessus pour créer gérer un réseau local sans
connexion vers l’extérieur. J'ajoute que cette machine sert aussi de
serveur web avec Apache.
depuis un poste sous windows un nslookup ou bien un ping sur
nomMachine.nomreseau fonctionnent parfaitement.
Cependant depuis le navigateur le serveur web :
-> répond parfaitement quand je saisie l'adresse IP
Il répond bien à http://xxx.xxx.xxx.xxx
C'est bien ça ?

-> une page introuvable avec nomMachine.nomreseau
Page introuvable, ie 404, ou impossible de se connecter (ce cas là
vient probablement de ce que les navigateurs a cru à une recherche et
tenté d'atteindre un moteur de recherche. Je ne félicite pas les...
individus... qui ont eu l'idée de fusionner barre d'adresse et barre
de recherche) ?
-> une erreur 400 avec http://nomMachine.nomreseau
Et la je n'ai pas de piste, n'étant pas spécialiste dans ce domaine.
Ceci vient il de la configuration du navigateur, ou d'APACHE ?
Si une erreur 400 ou 404 peut se produire, c'est que le navigateur est
probablement bien configuré car ces erreurs proviennent d'apache.
Lequel doit avoir un problème de configuration.
Merci par avance pour votre aide
--
François-Marie BILLARD
Éric Dégenètais
Publicité
Poster une réponse
Anonyme