probl

Le
Vincent Bain
Bonjour à tous,
fraîchement inscrit sur cette liste francophone des utilisateurs debian,
je parcours l'archive sans trouver de cas similaire au problème que je
rencontre :

dans l'idée de passer de Jessie à Stretch prochainement, j'ai commencé à
préparer le terrain (sauvegardes), puis mis à jour mon installation
(apt-get update et apt-get upgrade).

Depuis cette opération, je vois que l'installation de certains paquets
ne fonctionne plus ; en scrutant les logs je constate que c'est l'appel
à python3 qui renvoie une erreur :

$ python3
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Abandon

En revanche si j'appelle python3.2, ça fonctionne :

$ python3.2
Python 3.2.3 (default, Feb 20 2013, 14:44:27)
[GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

Je remarque en passant que le répertoire /usr/lib/python3.4 est vide

Est-ce que cela est déjà arrivé à l'un(e) d'entre vous ? que puis-je
faire pour remettre les choses en ordre ?

Merci de vos lumières éventuelle sur la question !

Vincent.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Alexandre Hoïde
Le #26439059
On Wed, Jul 19, 2017 at 09:44:21AM +0200, Vincent Bain wrote:
Bonjour à tous,
fraîchement inscrit sur cette liste francophone des utilisateurs debian,
je parcours l'archive sans trouver de cas similaire au problème que je
rencontre :
dans l'idée de passer de Jessie à Stretch prochainement, j'ai commencé à
préparer le terrain (sauvegardes...), puis mis à jour mon installation
(apt-get update et apt-get upgrade). […]

Salut Vincent,
Je n'ai strictement aucune idée à te proposer pour résoudre
directement ton problème. En revanche, je me permets de coller un p'tit
bout du « $ man apt-get » :
« apt-get
[…]
dist-upgrade
dist-upgrade in addition to performing the function of upgrade,
also intelligently handles changing dependencies with new versions
of packages; apt-get has a "smart" conflict resolution system, and
it will attempt to upgrade the most important packages at the
expense of less important ones if necessary. The dist-upgrade
command may therefore remove some packages. […]
»
[…] Depuis cette opération, je vois que l'installation de certains paquets
ne fonctionne plus ; en scrutant les logs je constate que c'est l'appel
à python3 qui renvoie une erreur : […]

Peut-être que l'utilisation de la commande « upgrade » d'apt-get
n'a pas permis, à elle seule, de passer proprement à la nouvelle version
de python, et qu'il faudrait en passer par la commande
« dist-upgrade » ?!
Accessoirement, puisque tu t'apprêtes à passer à Stretch, je signale
que le Cahier de l'administrateur Debian [Stretch] (paquet debian-handbook)
recommande désormais l'utilisation de « apt », dont la commande
correspondante est « full-upgrade ». (par contre, j'ignore ce qui est
recommandé pour passer de Jessie à Stretch)
… au cas où.
Merci de vos lumières éventuelle sur la question !

Dans l'incertitude, je ne puis t'en prier.
o/
--
 ___________________
| $ post_tenebras ↲ | waouh!
| GNU         /    |    
|          -- * --  |     o
| $ who ↲    /     |_-- ~_|
| Alexandre Hoïde   |  _/| |
 -------------------
nicolas.patrois
Le #26439068
Le 19/07/2017 09:44:21, Vincent Bain a écrit :
Depuis cette opération, je vois que l'installation de certains paque ts
ne fonctionne plus ; en scrutant les logs je constate que c'est
l'appel à python3 qui renvoie une erreur :
$ python3
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Abandon

Vérifie quel exécutable est en réalité python3. Chez mo i :
which python3

/usr/bin/python3
ll /usr/bin/python3

lrwxrwxrwx 1 root root 9 juin 29 05:07 /usr/bin/python3 -> python3.5
En revanche si j'appelle python3.2, ça fonctionne :
$ python3.2
Python 3.2.3 (default, Feb 20 2013, 14:44:27)
[GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.





Je remarque en passant que le répertoire /usr/lib/python3.4 est
vide...

Je n’ai même pas de répertoire /usr/lib/python3.4/.
Est-ce que cela est déjà arrivé à l'un(e) d'entre vou s ? que puis-je
faire pour remettre les choses en ordre ?

J’ai eu un problème vaguement similaire mais c’ét ait python 2.7 qui déconnait.
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...
=
maderios
Le #26439072
On 07/19/2017 09:44 AM, Vincent Bain wrote:
Bonjour à tous,
fraîchement inscrit sur cette liste francophone des utilisateurs debian,
je parcours l'archive sans trouver de cas similaire au problème que je
rencontre :
dans l'idée de passer de Jessie à Stretch prochainement, j'ai commencé à
préparer le terrain (sauvegardes...), puis mis à jour mon installation
(apt-get update et apt-get upgrade).
Depuis cette opération, je vois que l'installation de certains paquets
ne fonctionne plus ; en scrutant les logs je constate que c'est l'appel
à python3 qui renvoie une erreur :
$ python3
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Abandon
En revanche si j'appelle python3.2, ça fonctionne :
$ python3.2
Python 3.2.3 (default, Feb 20 2013, 14:44:27)
[GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.



Je remarque en passant que le répertoire /usr/lib/python3.4 est vide...
Est-ce que cela est déjà arrivé à l'un(e) d'entre vous ? que puis-je
faire pour remettre les choses en ordre ?
Merci de vos lumières éventuelle sur la question !

Dans ce cas, si l'objectif est de disposer au plus vite d'un système
opérationnel, le plus simple consiste à supprimer python3.x et les
paquets qui en sont dépendants puis de les réinstaller.
--
Maderios
Publicité
Poster une réponse
Anonyme