Probl

Le
Lucas Levrel
Bonjour,

Le problème soulevé dans mon autre fil récent n'a en fait pas été résolu
par l'ajout de « gfxmode text » dans l'entrée de Grub2 Le problème
semble se manifester de façon aléatoire (mais c'est bien plus souvent KO
que OK, hélas !).

Mon système est un portable HP posé, normalement avec l'écran fermé, sur
une station d'accueil où est connecté un écran externe.

Au cours du boot, il y a trois phases :
1. des messages qui ressemblent au contenu de /var/log/kern.log
défilent en blanc sur noir en 80 colonnes / 25 lignes avec la police du
BIOS (à vue de nez)
2. les messages de /var/log/boot.log défilent, avec les tags [OK] ou
[Failed] en couleur, avec des caractères bien plus petits et la police
qu'on trouve ensuite dans les consoles
3. l'écran graphique du display manager apparaît

La phase 1 est toujours correctement affichée sur l'écran externe (que
l'écran interne soit fermé ou ouvert, auquel cas les messages s'y
affichent aussi).

Le problème se produit lors des phases 2 et 3 : à peu près le quart
inférieur droit de l'image est affiché dans le quart supérieur gauche de
l'écran externe, le reste de l'écran est noir. (Si l'écran interne est
ouvert, il affiche correctement ce à quoi l'on s'attend, c'est-à-dire la
portion supérieure gauche de l'image qui peut « rentrer », compte tenu de
sa résolution inférieure.)

Phase 4 : si je me connecte, le problème persiste.

Comme le problème apparaît à la phase 2, j'en déduis qu'il n'est pas
spécifique à X. Toutefois j'ai trouvé une procédure qui fait
disparaître le problème :
* une fois connecté, je fais : xrandr --output VGA-0 --mode 1024x768 ;
l'image se replace correctement sur tout l'écran
* puis : xrandr --output VGA-0 --mode 1920x1080 ; et je retrouve la
résolution native de mon écran


Je suppose qu'il y a un problème avec le module radeon du noyau ; que
puis-je faire ? (Pas vu de message d'erreur dans kern.log.)


--
LL
Ἕν οἶδα ὅτι οὐδὲν οἶδα (Σωκράτης)
C'est mieux avé les accents (F. Patte)
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
des homonymes
Le #26487396
Le 31/08/18 à 18:07, Lucas Levrel a écrit :
Comme le problème apparaît à la phase 2, j'en déduis qu'il n'est pas
spécifique à X. Toutefois j'ai trouvé une procédure qui fait disparaître
le problème :
* une fois connecté, je fais : xrandr --output VGA-0 --mode 1024x768 ;
l'image se replace correctement sur tout l'écran
* puis : xrandr --output VGA-0 --mode 1920x1080 ; et je retrouve la
résolution native de mon écran
Je suppose qu'il y a un problème avec le module radeon du noyau ; que
puis-je faire ? (Pas vu de message d'erreur dans kern.log.)
--

sinon une simple détection automatique de vos écrans via l'interface
graphique ..
ce truc se produit quand l'ordi perd la trace de l'écran externe, ou
vice-versa*; l'un des deux se reconfigure par défaut, l'autre réagit en
conséquence (ou erratiquement);
*ça se produit quand on ne branche pas systématiquement l'écran externe
pour allumer son portable, y'a comme une détection de signal, de
présence, d'électricité sur la ligne du cable, branché ou pas, et de
l'écran, allumé ou pas, et puis du logiciel de l'écran,
si votre ordi est de la merde votre tv ne pourra pas toujours rattraper
le coup, et inversément, mais au pire une "détection des écrans" doit
suffire, sinon jetez l'ordi et l'écran externe ...
--
Lucas Levrel
Le #26487563
Le 1 septembre 2018, à 19:03, des homonymes a écrit :
Le 31/08/18 à 18:07, Lucas Levrel a écrit :
Comme le problème apparaît à la phase 2, j'en déduis qu'il n'est pas
spécifique à X. Toutefois j'ai trouvé une procédure qui fait disparaître
le problème :
* une fois connecté, je fais : xrandr --output VGA-0 --mode 1024x768 ;
l'image se replace correctement sur tout l'écran
* puis : xrandr --output VGA-0 --mode 1920x1080 ; et je retrouve la
résolution native de mon écran
Je suppose qu'il y a un problème avec le module radeon du noyau ; que
puis-je faire ? (Pas vu de message d'erreur dans kern.log.)

sinon une simple détection automatique de vos écrans via l'interface
graphique ..

Relire la partie coupée de mon message.
ce truc se produit quand l'ordi perd la trace de l'écran externe, ou
vice-versa*; l'un des deux se reconfigure par défaut, l'autre réagit en
conséquence (ou erratiquement);

Ça marchait avec ma distrib antérieure.
*ça se produit quand on ne branche pas systématiquement l'écran externe pour
allumer son portable

C'est bien sûr le cas (sinon je ne verrais pas le menu de grub).
si votre ordi est de la merde

HP
votre tv

Ce n'est pas une TV.
mais au pire une "détection des écrans" doit suffire,

OK. Comment fait-on au niveau du boot ?
sinon jetez l'ordi et l'écran externe ...

J'ai une autre idée mais j'attends de voir si vous avez une réponse à ma
question précédente.
--
LL
Ἕν οἶδα ὅτι οὐδὲν οἶδα (Σωκράτης)
Publicité
Poster une réponse
Anonyme