Problème de souris

Le
Mathias Dufresne
--001a113cfc1e5f893f0554075c91
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Bonjour,

J'ai un souci avec une installation toute fraîche de Debian 9.0.0 net
install. Lorsque je lance X avec "startx" le touchpad et la souris
fonctionnent tous les deux mais lorsque je lance X via system (systemctl
start display-manager) aucun pointeur n'est disponible.

Vous auriez une idée de ce que je rate ?

--001a113cfc1e5f893f0554075c91
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><div><div>Bonjour,<br><br></div>J&#39;ai un souci avec une=
installation toute fraîche de Debian 9.0.0 net install. Lorsque je la=
nce X avec &quot;startx&quot; le touchpad et la souris fonctionnent tous le=
s deux mais lorsque je lance X via system (systemctl start display-manager)=
aucun pointeur n&#39;est disponible.<br><br></div>Vous auriez une idé=
e de ce que je rate ?<br><br><br></div>

--001a113cfc1e5f893f0554075c91--
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bernard.schoenacker
Le #26438016
------=_Part_26144344_1595596180.1499766570750
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
----- Mail original -----
De: "Mathias Dufresne" À:
Envoyé: Mardi 11 Juillet 2017 11:31:14
Objet: Problème de souris
Bonjour,
J'ai un souci avec une installation toute fraîche de Debian 9.0.0 ne t
install. Lorsque je lance X avec "startx" le touchpad et la souris
fonctionnent tous les deux mais lorsque je lance X via system
(systemctl start display-manager) aucun pointeur n'est disponible.
Vous auriez une idée de ce que je rate ?

bonjour,
serait il possible de comparer :
dpkg -l |awk ' /xorg-input/ {print $1" "$2 " "$3}'
ii xserver-xorg-input-all 1:7.7+19
ii xserver-xorg-input-evdev 1:2.10.5-1
ii xserver-xorg-input-kbd 1:1.9.0-1+b1
ii xserver-xorg-input-libinput 0.23.0-2
ii xserver-xorg-input-mouse 1:1.9.2-1+b1
ii xserver-xorg-input-synaptics 1.9.0-1+b1
ii xserver-xorg-input-wacom 0.34.99.1-1
autrement je ne vois rien d'autre (sos marion dufresne) ;)
slt
bernard
------=_Part_26144344_1595596180.1499766570750
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable
------=_Part_26144344_1595596180.1499766570750--
Alexandre Hoïde
Le #26438025
On Tue, Jul 11, 2017 at 11:14:44AM +0100, Mathias Dufresne wrote:
Et c'est là que je suis allé me cacher sous le bureau, pas fier de moi :
au bureau j'ai 3 écrans dont deux n'étaient jusqu'à il y a peu pas allumés.
Ces écrans s'étaient gentiment configurés pour un bureau étendu et la
souris était donc sans doute au milieu de l'écran du milieu qui était
éteind... ce qui faisait que je ne voyais pas de souris dans l'écran de
gauche...
Vraiment pas fier de moi, j'espère qu'au moins j'aurai réussi à vous faire
sourire un peu :)

Oui !
Mais, en passant :
On Tue, Jul 11, 2017 at 10:31:14AM +0100, Mathias Dufresne wrote:
[…] je lance X via system (systemctl start display-manager) […]

Si tu souhaites démarrer, par défaut, en mode « multi-user »
(équivalent ~runlevel 3) puis passer ponctuellement en mode
« graphical » (équivalent ~runlevel 5), il serait plus systemd-orthodoxe
de le faire avec un :
$ systemctl isolate graphical.target
Je ne suis pas certain que cela fasse une différence dans tous les
cas (par rapport à ton $ systemctl start display-manager) mais la
manière « orthodoxe » te garantit (en principe) que les éventuelles
dépendances des deux modes seront traitées comme il se doit.
… pour revenir en « multi-user », même principe :
$ systemctl isolate multi-user.target
… si tu souhaites que les prochaines démarrage se fassent directement
en « graphical » :
$ systemctl enable graphical.target
Au cas où…
o/
--
 ___________________
| $ post_tenebras ↲ | waouh!
| GNU         /    |    
|          -- * --  |     o
| $ who ↲    /     |_-- ~_|
| Alexandre Hoïde   |  _/| |
 -------------------
Randy11
Le #26438647
On 11/07/2017 13:05, Alexandre Hoïde wrote:
On Tue, Jul 11, 2017 at 11:14:44AM +0100, Mathias Dufresne wrote:

[ ...]
On Tue, Jul 11, 2017 at 10:31:14AM +0100, Mathias Dufresne wrote:
[…] je lance X via system (systemctl start display-manager) […]

Si tu souhaites démarrer, par défaut, en mode « multi-user »
(équivalent ~runlevel 3) puis passer ponctuellement en mode
« graphical » (équivalent ~runlevel 5), il serait plus systemd-orthodoxe
de le faire avec un :
$ systemctl isolate graphical.target
Je ne suis pas certain que cela fasse une différence dans tous les
cas (par rapport à ton $ systemctl start display-manager) mais la
manière « orthodoxe » te garantit (en principe) que les éventuelles
dépendances des deux modes seront traitées comme il se doit.
… pour revenir en « multi-user », même principe :
$ systemctl isolate multi-user.target
… si tu souhaites que les prochaines démarrage se fassent directement
en « graphical » :
$ systemctl enable graphical.target
Au cas où…
o/

Merci beaucoup, je cherchais la solution à ce problème avec un Gnome
capricieux.
Le "Au cas où" m'est donc très utile. Merci.
Randy11
Publicité
Poster une réponse
Anonyme