probleme d'acces a la base de donnee avec crystal report

Le
Chris
bonjour,

suite a divers essai pour editer un etat crystal sur un autre ordi que
celui ayant servit au dvlpt, je sais plus quoi faire :(

voici que j'ai fait

Dim MyRpt as crEditionClient

Dim LogInfo as new TableLogInfo
LogInfo = MyRpt.DataBase.Table(0).LogOnInfo()

Dim ConnectionInfo as new ConnectionInfo
ConnectionInfo = MyRpt.DataBase.Table(0).LogOnInfo.ConnectionInfo

ConnectionInfo.ServerName = "MonAutreServeur"
ConnectionInfo.DataBaseName = "LocaGest"

MyRpt.DataBase.Table(0).ApplyLogOnInfo(LogInfo)

MonCrystalViewer.ReportSource = MyRpt

MyRpt.load()

et la qd je le lance il met la fenetre Database Login et il demande de
renseigner le champ Server Name qui est rempli avec le nom du serveur
qui a servi au dvlpt.

Est ce que qq'un serait quoi faire?

Merci
Vos réponses
Trier par : date / pertinence
Zoury
Le #12534821
Salut Chris! :O)

essai les quelques techniques démontrées dans ces messages..
http://groups.google.com/groups?as_q=Crystal%20%2bReport%20%2bchanging%20%2bdatasource%20%2bruntime&as_ugroup=*.dotnet.*&lr=&num0&hl=fr

il se pourrait que tu sois configurer pour employé la sécurité intégrée de
Windows et que cela te cause les problèmes que tu as.. sinon, tu peux passer
un dataset directement à ton rapport (voir 2 ieme discussion, 2ieme message
(par TheExtreme))

--
Cordialement
Yanick
MVP pour Visual Basic
"Chris" news:
bonjour,

suite a divers essai pour editer un etat crystal sur un autre ordi que
celui ayant servit au dvlpt, je sais plus quoi faire :(

voici que j'ai fait

Dim MyRpt as crEditionClient

Dim LogInfo as new TableLogInfo
LogInfo = MyRpt.DataBase.Table(0).LogOnInfo()

Dim ConnectionInfo as new ConnectionInfo
ConnectionInfo = MyRpt.DataBase.Table(0).LogOnInfo.ConnectionInfo

ConnectionInfo.ServerName = "MonAutreServeur"
ConnectionInfo.DataBaseName = "LocaGest"

MyRpt.DataBase.Table(0).ApplyLogOnInfo(LogInfo)

MonCrystalViewer.ReportSource = MyRpt

MyRpt.load()

et la qd je le lance il met la fenetre Database Login et il demande de
renseigner le champ Server Name qui est rempli avec le nom du serveur
qui a servi au dvlpt.

Est ce que qq'un serait quoi faire?

Merci


Chris
Le #12534801
Zoury a écrit :
Salut Chris! :O)

essai les quelques techniques démontrées dans ces messages..
http://groups.google.com/groups?as_q=Crystal%20%2bReport%20%2bchanging%20%2bdatasource%20%2bruntime&as_ugroup=*.dotnet.*&lr=&num0&hl=fr

il se pourrait que tu sois configurer pour employé la sécurité intégrée de
Windows et que cela te cause les problèmes que tu as.. sinon, tu peux passer
un dataset directement à ton rapport (voir 2 ieme discussion, 2ieme message
(par TheExtreme))



que ferais je sans toi zoury :) :)
Chris
Le #12534791
Zoury a écrit :
Salut Chris! :O)

essai les quelques techniques démontrées dans ces messages..
http://groups.google.com/groups?as_q=Crystal%20%2bReport%20%2bchanging%20%2bdatasource%20%2bruntime&as_ugroup=*.dotnet.*&lr=&num0&hl=fr

il se pourrait que tu sois configurer pour employé la sécurité intégrée de
Windows et que cela te cause les problèmes que tu as.. sinon, tu peux passer
un dataset directement à ton rapport (voir 2 ieme discussion, 2ieme message
(par TheExtreme))



a ton avis dans mon etat je dois afficher l'id du client, je créé mon
etat avec l'assistant en passant par ma base car le dataset qui me
servira a remplir l'etat est en local et n'a pas de fichier xsd. Si je
remplis mon dataset avec une requete (SELECT IdCLient FROM Client) et
que je dit MyRpt.SetDataSource(MonDataset)

MonReportViewer.DataSource = MyRpt

a ton avis est ce que il fera la liaison entre le champ idCLient que
j'ai glisser déposé et le IdClient de mon dataset?

merci
Zoury
Le #12534781
C'est ce qui devrais arriver en effet... mais je ne suis pas sûr de la
syntaxe.. :O/

--
Cordialement
Yanick
MVP pour Visual Basic
"Chris" news:
Zoury a écrit :
> Salut Chris! :O)
>
> essai les quelques techniques démontrées dans ces messages..
>


http://groups.google.com/groups?as_q=Crystal%20%2bReport%20%2bchanging%20%2bdatasource%20%2bruntime&as_ugroup=*.dotnet.*&lr=&num0&hl=fr
>
> il se pourrait que tu sois configurer pour employé la sécurité intégrée


de
> Windows et que cela te cause les problèmes que tu as.. sinon, tu peux


passer
> un dataset directement à ton rapport (voir 2 ieme discussion, 2ieme


message
> (par TheExtreme))
>
a ton avis dans mon etat je dois afficher l'id du client, je créé mon
etat avec l'assistant en passant par ma base car le dataset qui me
servira a remplir l'etat est en local et n'a pas de fichier xsd. Si je
remplis mon dataset avec une requete (SELECT IdCLient FROM Client) et
que je dit MyRpt.SetDataSource(MonDataset)

MonReportViewer.DataSource = MyRpt

a ton avis est ce que il fera la liaison entre le champ idCLient que
j'ai glisser déposé et le IdClient de mon dataset?

merci


Chris
Le #12534771
Zoury a écrit :
C'est ce qui devrais arriver en effet... mais je ne suis pas sûr de la
syntaxe.. :O/



je teste et je te dis a+
Publicité
Poster une réponse
Anonyme