probleme affichage champs calculé dans requette

Le
eric
bonjour
j ai une table ACHATS avec entre autre une colonne
prix_total et une colonne nbr_article
j 'ai une requette MOYENNE qui entre autre a une nouvelle
colonne moyenne avec dedans
Moyenne: Format([prix_total]/[nbr_article];"# ###.00")

dans un sous formulaire d'un formulaire client, j'affiche
tous les achats fait.
(office xp en developpement et sur les postes
utilisateurs)
sur 10 ordinateurs win2000 avec derniers service pack,
ca marche tres bien sur 6. Par contre, sur 4 pc, dans la
colonne qui est calcule (moyenne) dans la requette, il y
a #erreur de marqu
si quelqu'un a une ide
merci
Vos réponses
Trier par : date / pertinence
Raymond
Le #4453221
Bonjour.

il faudrait avant tout border ton calcul et voir si ça continue, vérifie
aussi les références sur chaque PC.

pour le sql:
IIf([quantite]=0,"NS",Format([montant]/nz([quantite],1),"#,###.00")) AS
PUMoyen
pour access création graphique:
PUMoyen: VraiFaux([quantite]=0;"NS";Format([montant]/nz([quantite];1);"#
###,00"))
au lieu de:
Moyenne: Format([prix_total]/[nbr_article];"# ###.00
Moyenne est bun mot réservé access, ne pas l'utiliser.
--
@+
Raymond Access MVP.
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/charte.htm pour une meilleure
efficacité de tes interventions sur MPFA.


"eric" news:04b601c39624$639e3e90$
bonjour
j ai une table ACHATS avec entre autre une colonne
prix_total et une colonne nbr_article
j 'ai une requette MOYENNE qui entre autre a une nouvelle
colonne moyenne avec dedans
Moyenne: Format([prix_total]/[nbr_article];"# ###.00")

dans un sous formulaire d'un formulaire client, j'affiche
tous les achats fait.
(office xp en developpement et sur les postes
utilisateurs)
sur 10 ordinateurs win2000 avec derniers service pack,
ca marche tres bien sur 6. Par contre, sur 4 pc, dans la
colonne qui est calculée (moyenne) dans la requette, il y
a #erreur de marqué
si quelqu'un a une idée
merci
eric
Le #4453211
merci mais ...

pour les references il y a les 4 par defaut sur tous les
postes

pour le mot moyenne , c est effectivement une erreur de
ma part, j aurais pas du l'utiliser mais meme en le
changeant, ca change rien au probleme

pour les calculs il n'y a pas de probleme non plus
(si j'affiche la requete, la moyenne est bien calculé,
par contre si j affiche le sous formulaire basé sur la
requete ca marche pas)
(enfin ca marche pas sur 4 postes sur 10 - c est ca qui
est bizarre - meme en reinstallant windows et office)

pour info sur un des postes, il n'affiche meme pas le
sous formulaire (zone blanche a la place)

si une autre idée ....



-----Message d'origine-----
Bonjour.

il faudrait avant tout border ton calcul et voir si ça
continue, vérifie

aussi les références sur chaque PC.

pour le sql:
IIf([quantite]=0,"NS",Format([montant]/nz
([quantite],1),"#,###.00")) AS

PUMoyen
pour access création graphique:
PUMoyen: VraiFaux([quantite]=0;"NS";Format([montant]/nz
([quantite];1);"#

###,00"))
au lieu de:
Moyenne: Format([prix_total]/[nbr_article];"# ###.00
Moyenne est bun mot réservé access, ne pas l'utiliser.
--
@+
Raymond Access MVP.
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/charte.htm pour une meilleure
efficacité de tes interventions sur MPFA.


"eric" news:04b601c39624$639e3e90$
bonjour
j ai une table ACHATS avec entre autre une colonne
prix_total et une colonne nbr_article
j 'ai une requette MOYENNE qui entre autre a une nouvelle
colonne moyenne avec dedans
Moyenne: Format([prix_total]/[nbr_article];"# ###.00")

dans un sous formulaire d'un formulaire client, j'affiche
tous les achats fait.
(office xp en developpement et sur les postes
utilisateurs)
sur 10 ordinateurs win2000 avec derniers service pack,
ca marche tres bien sur 6. Par contre, sur 4 pc, dans la
colonne qui est calculée (moyenne) dans la requette, il y
a #erreur de marqué
si quelqu'un a une idée
merci




.



Publicité
Poster une réponse
Anonyme