Probleme avec la carte reseau 3c3FEM656c

Le
Kevin
Bonjour
j'ai des soucis avec la carte PCMCIA 3c3FEM656c (module 3c59x)
sur un compaq Armada 7800;

Tout va bien, sauf qu'elle stoppe de temps a autre. J'ai fait
quelques recherches sur internet, mais a part le fait que
je n'ai pas ete le seul a avoir le probleme, je n'ai pas
trouve de solution. Il semblerait qu'il y ait un probleme
de rapidite de la carte (?). Actuellement, il suffit d'un
cardctl eject 0
suivi d'une deconnection et reconnection de la carte pour
que tout refonctionne (un moment).
Il semble que le plantage intervient surtout lors de trafic
soutenu: par exemple, un gros transfert ( >10Mo) scp ou ftp
avec un cable croise plante la carte en 1 ou 2s chrono. Un surf
sur internet ne la plante (presque) jamais.

J'ai charge le module avec debug=7 et lors d'un crash de la
carte j'obtiens une premiere erreur:

Receiving packet size 92 status a000805c.
eth0: exiting interrupt, status e000.
eth0: interrupt, status e401, latency 6 ticks.
Receiving packet size 92 status a000805c.
eth0: exiting interrupt, status e000.

qui se repete sur des centaines de lignes.

J'ai egalement eu lors d'un autre test:
eth0: Media selection timer tick happened, MII.
dev->watchdog_timeoP00
eth0: MII transceiver has status 782d.
eth0: Media selection timer finished, MII.

Une idee pour arranger le probleme?

Je lis la doc, je vois que ca parle d'un "Compaq PCI BIOS32 problem"
Comment savoir si j'ai un PCI BIOS32? Le module accepte les
arguments compaq_ioaddr, compaq_irq et compaq_device_id mais sans
donner les valeurs a lui transmettre (?). J'ai essaye en mettant
l'io, l'irq et le numero de socket de la carte PCMCIA, mais ca ne
fonctionne pas, le module ne veut pas se charger. Peut etre que
les problemes ne sont pas lies.

PS: J'ai recupere les mii-diags sur le site de scyld, il n'y a aucune
doc, seulement un Makefile qui ne fonctionne pas (semblerait que
printf n'accepte pas des donnees sur plusieurs lignes genre
printf (" hop
hop
hop
");
Il y aurait une version fonctionnelle ou?

systeme slackware-current, noyau 2.6.5 (le probleme est identique avec
le 2.6.4). J'ai deux cartes PCMCIA 3C3FEM656c et le probleme est
identique avec l'une ou l'autre.

--
Kevin
..et si maintenant j'inverse les nappes des deux controlleurs comme ca..
-+- Les 100 choses que vous n'aimez pas entendre de la part du sysadmin -+-

--
Pour contacter l'équipe de modération : moderateurs-fcolm@efrei.fr
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Antoine Bellot
Le #7143591
Kevin DENIS a écrit :
Bonjour
j'ai des soucis avec la carte PCMCIA 3c3FEM656c (module 3c59x)
sur un compaq Armada 7800;



à vue de nez, ce comportement ressemble à celui d'une carte réseau
travaillant en full-duplex en face d'un équipement travaillant en
half-duplex.

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Kevin
Le #7143501
Le 30 Apr 2004 04:35:14 GMT, Antoine Bellot a ecrit:
|> j'ai des soucis avec la carte PCMCIA 3c3FEM656c (module 3c59x)
|
| à vue de nez, ce comportement ressemble à celui d'une carte réseau
| travaillant en full-duplex en face d'un équipement travaillant en
| half-duplex.
|
La, jelis la doc, je vois qu'il existe une option pour forcer le full
duplex, mais pas pour forcer le half-duplex.
Je me suis egalement rendu compte que slack fournissait mii-tool, mais:
:~# mii-tool --force 100baseTx-HD eth0
SIOCGMIIPHY on 'eth0' failed: Operation not supported

Je continue de tester toute une serie de parametres, j'ai essaye avec
differents hub/switch (pourquoi cette autonegociation echouerait elle?)
mais que dalle ca continue de bloquer: La j'ai voulu copier une image
disque de partimage, et ca a plante a 800Mo sur les 1.2Go (je traverse
tout le reseau, je ne suis pas en prise directe).
--
Kevin
...et la, je fais un 'dd if=/dev/null of=/vmlinuz
-+- Les 100 choses que vous n'aimez pas entendre de la part du sysadmin -+-

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Antoine Bellot
Le #7143481
Kevin DENIS a écrit :

:~# mii-tool --force 100baseTx-HD eth0
SIOCGMIIPHY on 'eth0' failed: Operation not supported




que donne mii-tool -v, ethtool eth0
(http://www.gnu.org/directory/all/ethtool.html), et uname -a ?

--
Pour contacter l'équipe de modération :
ATTENTION: Postez DIRECTEMENT vos articles dans le groupe, PAS dans
la liste de distribution des modérateurs.
Publicité
Poster une réponse
Anonyme