probleme avec skype FreeBSD 5.3

Le
did
Salut

J'ai un probleme avec skype. Quand j'etais sous 5.2.1, ca marchait
niquel. Seulement, avec la 5.3, chez moi, quand je lance skype, ca me
sort l'erreur suivante:

kilkenny% skype
skype_bin: error while loading shared libraries:
/usr/lib/libstdc++.so.5: ELF file OS ABI invalid

Si quelqu'un a une idee de la signification de cette erreur, je suis
preneur :)

merci

did
Vos réponses
Trier par : date / pertinence
Mathieu Arnold
Le #66671
did écrivait:
Salut

J'ai un probleme avec skype. Quand j'etais sous 5.2.1, ca marchait
niquel. Seulement, avec la 5.3, chez moi, quand je lance skype, ca me
sort l'erreur suivante:

kilkenny% skype
skype_bin: error while loading shared libraries:
/usr/lib/libstdc++.so.5: ELF file OS ABI invalid

Si quelqu'un a une idee de la signification de cette erreur, je suis
preneur :)


As tu recomplié skype apres la mise a jour en 5.3 ?

--
Mathieu Arnold

Marwan Burelle
Le #66670
On Wed, 23 Feb 2005 11:11:31 +0100
did
Salut

J'ai un probleme avec skype. Quand j'etais sous 5.2.1, ca marchait
niquel. Seulement, avec la 5.3, chez moi, quand je lance skype, ca me
sort l'erreur suivante:

kilkenny% skype
skype_bin: error while loading shared libraries:
/usr/lib/libstdc++.so.5: ELF file OS ABI invalid

Si quelqu'un a une idee de la signification de cette erreur, je suis
preneur :)


Pour nous guider il nous faut plus d'info, le client Skype pour FreeBSD
fonctionne avec l'émulation linux, il a besoin qu'un certain nombre de
bibliothèques linux soit installées et que la compatibilité linux soit
activée.

Visiblement, skype semble accéder à une bibliothèque de FreeBSD et pas
un bibliothèque fournit pour l'émulation linux.

Avez installé skype par les ports et comment avez vous fait le passage
de 5.2.1 à 5.3 (cvsup + buildworl ou réinstalle ?)

Que donne :

ldd `which skype`

kldstat | grep -i linux

pkg_info | grep -i linux

--
Burelle Marwan,
Equipe Bases de Donnees - LRI
http://www.cduce.org
( | )

did
Le #66669
Marwan Burelle wrote:

Avez installé skype par les ports et comment avez vous fait le passage
de 5.2.1 à 5.3 (cvsup + buildworl ou réinstalle ?)


J'ai fait une reinstalle complete. J'ai installe skype par les ports. Je
met a jour l'arborescence des ports, et je fais un portinstall -v skype,
mais a chaque fois, il me sort cette erreur.

Que donne :

ldd `which skype`

kldstat | grep -i linux

pkg_info | grep -i linux



Voici le resultat de ces commandes :

kilkenny% ldd `which skype`
ldd: /usr/X11R6/bin/skype: not a dynamic executable

kilkenny% kldstat | grep -i linux
6 1 0xc1f28000 1b000 linux.ko

kilkenny% pkg_info | grep -i linux
linux-expat-1.95.5_2 Linux/i386 binary port of Expat XML-parsing library
linux-fontconfig-2.1_2 Linux/i386 binary of Fontconfig
linux-sun-jdk-1.4.2.06_1 Sun Java Development Kit 1.4 for Linux
linux_base-7.1_7 The base set of packages needed in Linux mode
linuxpluginwrapper-20050110 A wrapper allowing use of linux-plugins with
native applica

J'ai cherche un peu dans le handbook, et je suis tombe sur la commande
brandelf. Je tape :

kilkenny% brandelf -t Linux skype

mais il ne se passe rien. Quand je relance skype, ca me met toujours la
meme erreur.

Francois Tigeot
Le #66371
did wrote:
Marwan Burelle wrote:

Avez installé skype par les ports et comment avez vous fait le passage
de 5.2.1 à 5.3 (cvsup + buildworl ou réinstalle ?)


J'ai fait une reinstalle complete. J'ai installe skype par les ports. Je
met a jour l'arborescence des ports, et je fais un portinstall -v skype,
mais a chaque fois, il me sort cette erreur.

J'ai cherche un peu dans le handbook, et je suis tombe sur la commande
brandelf. Je tape :

kilkenny% brandelf -t Linux skype

mais il ne se passe rien. Quand je relance skype, ca me met toujours la
meme erreur.


Si on regarde l'erreur de départ:

skype_bin: error while loading shared libraries:

il est possible que 'skype' ne soit pas un binaire, mais juste un script
qui fait appel au vrai binaire 'skype_bin'

Ca vaudrait le coup de vérifier...

--
Francois Tigeot


did
Le #66057
Francois Tigeot wrote:


Si on regarde l'erreur de départ:

skype_bin: error while loading shared libraries:

il est possible que 'skype' ne soit pas un binaire, mais juste un script
qui fait appel au vrai binaire 'skype_bin'

Ca vaudrait le coup de vérifier...



Ben, voila ce que j'obtiens:

kilkenny% file skype
skype: Bourne shell script text executable

Et puis j'ai fait ça :

kilkenny% sudo brandelf -t Linux skype_bin
kilkenny% skype
skype_bin: error while loading shared libraries:
/usr/lib/libstdc++.so.5: ELF file OS ABI invalid

Je ne sais absolument pas quoi faire... :/

MaXX
Le #66056
did wrote:

Francois Tigeot wrote:


Si on regarde l'erreur de départ:

skype_bin: error while loading shared libraries:

il est possible que 'skype' ne soit pas un binaire, mais juste un script
qui fait appel au vrai binaire 'skype_bin'

Ca vaudrait le coup de vérifier...



Ben, voila ce que j'obtiens:

kilkenny% file skype
skype: Bourne shell script text executable

Et puis j'ai fait ça :

kilkenny% sudo brandelf -t Linux skype_bin
kilkenny% skype
skype_bin: error while loading shared libraries:
/usr/lib/libstdc++.so.5: ELF file OS ABI invalid

Je ne sais absolument pas quoi faire... :/
j'ai un fichier de ce nom dans /usr/compat/linux/usr/lib/ (FreeBSD5.3 à

mettre à jour), c'est pt'être çà le problème...

--
MaXX


Publicité
Poster une réponse
Anonyme