problème calcul avec fonction SI

Le
Pascal Gimenez
bonjour
je voudrai écrire dans une formule de calcul la chose suivante dans B4
si 100-A4= quelque chose alors ce résultat
sinon rien (cellule vide)
j'ai donc fait
=SI((100-A4)>=0;100-A4;" ")

cela fonctionne, mais sur les chiffres négatif dans A, je me retrouve avec
un chiffre faux.
ex:A -150 devrait donné -50 , il me donne 250

deuxième problème
sur une cellule se retrouvant vide

si après je veus faire un calcul entre B et C
soit : C 100*B
sur les cellules C avec un résultat pas de problème
sur les cellules C vide j'obtiens #VALEUR!
il est évident que je ne veus rien, puisque la cellule C est vide

voilà j'espère avoir été clair
merci de vos réponse
Pascal


je voudrai écrire dans une formule de calcul
la chose suivant dans B4:
si 100-A4= quelque chose alors le résultat
sinon rien
j'ai donc utilisé
si onc utilisé
ou
si(100-A4= ; ;;) et je ne sais pas comment l'ordinateur comprend
"quelque
chose

j'ai essayé :
si(100-A4>0;100-A4;;) et cela ne marche pas
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AV
Le #1962691
=SI((100-A4)>=0;100-A4;" ")
cela fonctionne, mais sur les chiffres négatif dans A, je me retrouve avec
un chiffre faux.


=SI(100-ABS(A4)>=0;100-ABS(A4);"")

Pour le reste, c'est pas clair du tout....

AV

Michel BERTRAND
Le #1962690
"Pascal Gimenez" news:420c835f$0$5221$
bonjour
je voudrai écrire dans une formule de calcul la chose suivante dans B4
si 100-A4= quelque chose alors ce résultat
sinon rien (cellule vide)
j'ai donc fait
=SI((100-A4)>=0;100-A4;" ")

cela fonctionne, mais sur les chiffres négatif dans A, je me retrouve avec
un chiffre faux.
ex:A -150 devrait donné -50 , il me donne 250



c'est normal:
100 - a4 avec a4= -150 ça donne
100 - (-150) %0

deuxième problème
sur une cellule se retrouvant vide

si après je veus faire un calcul entre B et C
soit : C 100*B
sur les cellules C avec un résultat pas de problème
sur les cellules C vide j'obtiens #VALEUR!
il est évident que je ne veus rien, puisque la cellule C est vide



on ne peut pas faire directement de calcul sur du texte ou du vide

=CNUM("0"&B)*100

Cordialement

Michel BERTRAND

Daniel
Le #1962689
Bonjour.
Sans être matheux, 100+(-150)=-50 et 100 - --150) = 250.
Cordialement.
Daniel
"Pascal Gimenez" 420c835f$0$5221$
bonjour
je voudrai écrire dans une formule de calcul la chose suivante dans B4
si 100-A4= quelque chose alors ce résultat
sinon rien (cellule vide)
j'ai donc fait
=SI((100-A4)>=0;100-A4;" ")

cela fonctionne, mais sur les chiffres négatif dans A, je me retrouve avec
un chiffre faux.
ex:A -150 devrait donné -50 , il me donne 250

deuxième problème
sur une cellule se retrouvant vide

si après je veus faire un calcul entre B et C
soit : C 100*B
sur les cellules C avec un résultat pas de problème
sur les cellules C vide j'obtiens #VALEUR!
il est évident que je ne veus rien, puisque la cellule C est vide

voilà j'espère avoir été clair
merci de vos réponse
Pascal


je voudrai écrire dans une formule de calcul
la chose suivant dans B4:
si 100-A4= quelque chose alors le résultat
sinon rien
j'ai donc utilisé
si onc utilisé
ou
si(100-A4= ; ;;) et je ne sais pas comment l'ordinateur comprend
"quelque
chose

j'ai essayé :
si(100-A4>0;100-A4;;) et cela ne marche pas




Michel Gaboly
Le #1962688
Bonjour,

100 - -150 = 250 (- par - fait +). Le résultat est donc correct

Quant au #VALEUR!, il est également normal : quand tu écris " ", cela
inscrit une espace dans la cellule : elle n'est donc pas vide mais
contient du texte.

Par ailleurs, pourquoi >= 0 ? si 100 - A4 est négatif, n'est-ce pas
quelque chose, pour reprendre tes termes ?

Il faut donc écrire

=SI(A4 <> 0;100 - A4;0)

ou

=SI(A4 <> 0;100 - A4;)

et éventuellement masquer les valeurs 0 via l'onglet "Affichage" des
préférences (options si Windows).



bonjour
je voudrai écrire dans une formule de calcul la chose suivante dans B4
si 100-A4= quelque chose alors ce résultat
sinon rien (cellule vide)
j'ai donc fait
=SI((100-A4)>=0;100-A4;" ")

cela fonctionne, mais sur les chiffres négatif dans A, je me retrouve avec
un chiffre faux.
ex:A -150 devrait donné -50 , il me donne 250

deuxième problème
sur une cellule se retrouvant vide

si après je veus faire un calcul entre B et C
soit : C 100*B
sur les cellules C avec un résultat pas de problème
sur les cellules C vide j'obtiens #VALEUR!
il est évident que je ne veus rien, puisque la cellule C est vide

voilà j'espère avoir été clair
merci de vos réponse
Pascal


je voudrai écrire dans une formule de calcul
la chose suivant dans B4:
si 100-A4= quelque chose alors le résultat
sinon rien
j'ai donc utilisé
si onc utilisé
ou
si(100-A4= ; ;;) et je ne sais pas comment l'ordinateur comprend
"quelque
chose

j'ai essayé :
si(100-A4>0;100-A4;;) et cela ne marche pas





--
Cordialement,

Michel Gaboly
www.gaboly.com

Publicité
Poster une réponse
Anonyme