problème de clavier (layout)

Le
Frederic Robert
Bonjour Í  la liste,

Comment allez-vous ? J'utilise Debian 9 (stretch) avec Mate. Le clavier
du pc portable Lenovo thinkpad t410 est un qwerty espagnol. J'utilise un
clavier externe Français-Belge. A l'installation, Debian est installé en
Anglais et le clavier choisi est Français-Belge. Je n'utilise que le
clavier externe. Quand cela fonctionne correctement en Français-Belge,
j'ai bien le FR en haut Í  droite près de l'horloge. Quand je clique
dessus, il est bien écrit "French-Belgian". Parfois, il disparait sans
aucunes raisons. Quand cela fonctionne, j'ai les valeurs suivantes dans
les fichiers de config

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="be"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Et dans system, preferences, keyboard, il est bien indiqué Belgian.

Quand cela ne fonctionne plus, et que j'écris ê cela devient par exemple: ^e

J'utilise l'o.s en anglais depuis plusieurs années mais j'ai difficile Í 
écrire en anglais pour expliquer certains problèmes.

Pouvez-vous m'aider ?

Merci d'avance,

--
Frédéric ROBERT
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Frederic Robert
Le #26574578
On 6/4/21 8:20 AM, Bruno Volpi wrote:
salut,
test avec  XKBVARIANT="fr"

Bonjour Bruno et Í  la liste,
Au moment, ou j'ai écris le message et répondu Í  ton message, il
fonctionne correctement. Quand il ne fonctionnera pas correctement je
testerai en changeur la valeur de XKBVARIANT. En ce moment, elle est vide
Bonne journée,
--
Frédéric ROBERT
Frederic Robert
Le #26574579
On 6/4/21 8:20 AM, Bruno Volpi wrote:
salut,
test avec  XKBVARIANT="fr"

J'ai oublié de dire que le problème a lieu uniquement en graphique et au
login graphique. Si au moment du problème, je fais ctrl+alt+f1 et bien ê
ou ë s'affichent correctement dans la console
--
Frédéric ROBERT
Frederic Robert
Le #26574632
On 6/4/21 8:20 AM, Bruno Volpi wrote:
salut,
test avec  XKBVARIANT="fr"

Bonjour,
Au moment, ou j'écris le message. FR est disparu et quand je veux écrire
e avec un accent circonflèxe c'est ^e. Je modifie le fichier
/etc/default/keyboard et j'ajoute la valeur FR. Dois-je redemarrer la
machine ?
Bon week-end,
--
Frédéric ROBERT
Jérôme (haricophile.org)
Le #26574639
Le samedi 05 juin 2021 Í  16:48 +0000, Frederic Robert a écrit :
Bonjour,
Au moment, ou j'écris le message. FR est disparu et quand je veux
écrire
e avec un accent circonflèxe c'est ^e. Je modifie le fichier
machine ?
Bon week-end,

Normalement il n'y a pas besoin de régler manuellement les paramètres
claviers. Dans le "centre de contrÍ´le" de Mate, tu peux régler/ajouter
les disposition clavier, si tu as bien tout ce qu'il faut d'installé et
si tu n'a pas ajouté des réglages personnels par dessus bien sÍ»r.
Toutefois il s'agit uniquement du serveur graphique Xorg, pour la
console, qui est aussi la disposition prise par défaut par les bureaux
si on n'a rien précisé, tu peux faire en ligne de commande par exemple
(en root):
# dpkg-reconfigure keyboard-configuration
Pour X il suffit de redémarrer la session.
Frederic Robert
Le #26574715
On 6/5/21 6:19 PM, JérÍ´me (haricophile.org) wrote:
on week-end,
Normalement il n'y a pas besoin de régler manuellement les paramètres
claviers. Dans le "centre de contrÍ´le" de Mate, tu peux régler/ajouter
les disposition clavier, si tu as bien tout ce qu'il faut d'installé et
si tu n'a pas ajouté des réglages personnels par dessus bien sÍ»r.
Toutefois il s'agit uniquement du serveur graphique Xorg, pour la
console, qui est aussi la disposition prise par défaut par les bureaux
si on n'a rien précisé, tu peux faire en ligne de commande par exemple
(en root):
# dpkg-reconfigure keyboard-configuration
Pour X il suffit de redémarrer la session.


Bonsoir,
Encore une fois le problème... je suis obligé de redemarrer la machine
pour récupérer FR sur le bureau mate :( Ne serais-ce pas un bug ?
Bonne soirée,
--
Frédéric ROBERT
Poster une réponse
Anonyme