Probleme compilation kernel 2.6.14

Le
Burn Debian_ld
Bonjour

Je viens de me lancer dans la compilation du dernier kernel 2.6.14
avec framebuffer
Mais petit probleme ..

1/ Le boot du kernel se fait dans une resolution ultra-basic avec un
decalage de l'ecran vers la gauche.

2/ Si je rajoute vga= dans grub, quelque soit le mode, il y a un
probleme.
Le boot n'apparait plus dans la console, ecran noir jusqu au lancement
auto de X avec gdm.

Donc suis un peu largué ..
Est ce que quelqu un pourrait me dire si je suis passé a coté de =
quelque
chose ??

Ci dessous un petit lspci, et un lien vers le contenu de mon
fichier .config avant compilation.

merci a tous


.config ==> http://spatioport.free.fr/config
lspci

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600
AGP] Host Bridge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
0000:00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 07)
0000:00:0f.1 Input device controller: Creative Labs SB Live! MIDI/Game
Port (rev 07)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB
1.1 Controller (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB
1.1 Controller (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB
1.1 Controller (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102
[Rhine-II] (rev 74)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R350
[Radeon 9800 Pro]
0000:01:00.1 Display controller: ATI Technologies Inc Radeon R350
[Radeon 9800 Pro] (Secondary)

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
FrekoDing
Le #8580671
Burn Debian_ld ecrivait le 28.11.2005 18:34:

Bonjour



Bonsoir

Je viens de me lancer dans la compilation du dernier kernel 2.6.14
avec framebuffer
Mais petit probleme ..



Faut tester et retester jusqu'à trouver la bonne combinaison.
Avant de s'aventurer avec le framebuffer radeon, assure-toi que ca
marche avec le
module vga seulement, ca suffit amplement meme ! ;-)
Les options suivantes suffisent :

CONFIG_FB=y
CONFIG_FB_VESA=y
CONFIG_VGA_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y

Tu ajoutes au boot (grub ou lilo) de ton noyau vga=xxx (791 par exemple
pour du 1024x768x16)

Bon courage. @+


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Burn Debian_ld
Le #8580651
Le lundi 28 novembre 2005 à 19:18 +0100, FrekoDing a écrit :
Burn Debian_ld ecrivait le 28.11.2005 18:34:

> Bonjour

Bonsoir

> Je viens de me lancer dans la compilation du dernier kernel 2.6.14
> avec framebuffer
> Mais petit probleme ..

Faut tester et retester jusqu'à trouver la bonne combinaison.
Avant de s'aventurer avec le framebuffer radeon, assure-toi que ca
marche avec le
module vga seulement, ca suffit amplement meme ! ;-)
Les options suivantes suffisent :

CONFIG_FB=y
CONFIG_FB_VESA=y
CONFIG_VGA_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y

Tu ajoutes au boot (grub ou lilo) de ton noyau vga=xxx (791 par exemple
pour du 1024x768x16)

Bon courage. @+



Merci vais essayer ce soir :-)
Burn Debian_ld
Le #8580621
Le lundi 28 novembre 2005 à 19:18 +0100, FrekoDing a écrit :
Burn Debian_ld ecrivait le 28.11.2005 18:34:

> Bonjour

Bonsoir

> Je viens de me lancer dans la compilation du dernier kernel 2.6.14
> avec framebuffer
> Mais petit probleme ..

Faut tester et retester jusqu'à trouver la bonne combinaison.
Avant de s'aventurer avec le framebuffer radeon, assure-toi que ca
marche avec le
module vga seulement, ca suffit amplement meme ! ;-)
Les options suivantes suffisent :

CONFIG_FB=y
CONFIG_FB_VESA=y
CONFIG_VGA_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y

Tu ajoutes au boot (grub ou lilo) de ton noyau vga=xxx (791 par exemple
pour du 1024x768x16)

Bon courage. @+




C etais bien ça je confirme
merci beaucoup
Bayrouni
Le #8580231
Burn Debian_ld wrote:

Le lundi 28 novembre 2005 à 19:18 +0100, FrekoDing a écrit :


Burn Debian_ld ecrivait le 28.11.2005 18:34:



Bonjour




Bonsoir



Je viens de me lancer dans la compilation du dernier kernel 2.6.14
avec framebuffer
Mais petit probleme ..




Faut tester et retester jusqu'à trouver la bonne combinaison.
Avant de s'aventurer avec le framebuffer radeon, assure-toi que ca
marche avec le
module vga seulement, ca suffit amplement meme ! ;-)
Les options suivantes suffisent :

CONFIG_FB=y
CONFIG_FB_VESA=y
CONFIG_VGA_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y

Tu ajoutes au boot (grub ou lilo) de ton noyau vga=xxx (791 par exemple
pour du 1024x768x16)

Bon courage. @+





Merci vais essayer ce soir :-)






Je viens de compiler un noyau 2.6.14.3 et je suis arrivé à avoir le fb
en utilisant les
options ci-dessus.
Bayrouni


--
Pensez
Poster une réponse
Anonyme