Problème de date

Le
Britannicus
Bonsoir,
J'ai saisi en A13 : ="03/11/2006", en A14 : ="04/11/2006" et ainsi de suite
jusqu'à aujourd'hui. Chaque jour, je saisis la nouvelle date.
La formule ci-dessous me donne bien le total demandé sur chaque ligne pour
chaque jour, A13 puis A14.
=SOMME.SI(récap!$A$2:$A$1000;A13;récap!$D$2:$D$1000)

Maintenant, j'ai une colonne avec 2 valeurs possibles :
Je voudrais tester 2 cellules pour afficher le nombre de chacune de ces 2
valeurs. (ex, pour le 03/11/2006, j'ai 4 "A" et 3 "B".Comment les compter ?)
Quand je commence ma formule par
=ET(récap!$A$2:$A$1000)3
le "pré-résultat" dans la fenêtre m'affiche "FAUX".
Pourquoi le test de date fonctionne t'il avec SOMME.SI et pas avec ET ?

Que faire pour que la date s'ajoute automatiquement dès qu'un nouvel
enregistrement intervient ?

Encore merci

Britannicus
Vos réponses
Trier par : date / pertinence
MichDenis
Le #3928971
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton cas.



"Britannicus" e%
Bonsoir,
J'ai saisi en A13 : ="03/11/2006", en A14 : ="04/11/2006" et ainsi de suite
jusqu'à aujourd'hui. Chaque jour, je saisis la nouvelle date.
La formule ci-dessous me donne bien le total demandé sur chaque ligne pour
chaque jour, A13 puis A14....
=SOMME.SI(récap!$A$2:$A$1000;A13;récap!$D$2:$D$1000)

Maintenant, j'ai une colonne avec 2 valeurs possibles :
Je voudrais tester 2 cellules pour afficher le nombre de chacune de ces 2
valeurs. (ex, pour le 03/11/2006, j'ai 4 "A" et 3 "B".Comment les compter ?)
Quand je commence ma formule par
=ET(récap!$A$2:$A$1000)¡3
le "pré-résultat" dans la fenêtre m'affiche "FAUX".
Pourquoi le test de date fonctionne t'il avec SOMME.SI et pas avec ET ?

Que faire pour que la date s'ajoute automatiquement dès qu'un nouvel
enregistrement intervient ?

Encore merci...

Britannicus
Britannicus
Le #3928931
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.




MichDenis
Le #3928901
Essaie ceci :
=SOMMEPROD((A1:A15="03/11/2006"*1)*(B1:B15={"a"."b"}))

Le séparateur (point) de {"a"."b"}peut être différent sur ton système selon ta configuration.


"Britannicus" uMQ0E%
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.




Britannicus
Le #3928801
Même adaptée, ça ne va pas. Est ce que {"a"."b"}est une matrice ? Somment la
valider sans que toute la formule ne devienne une matrice ?
Je ne cherche pas un produit, mais un comptage de valeurs.

"MichDenis" %

Essaie ceci :
=SOMMEPROD((A1:A15="03/11/2006"*1)*(B1:B15={"a"."b"}))

Le séparateur (point) de {"a"."b"}peut être différent sur ton système
selon ta configuration.


"Britannicus" uMQ0E%
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je
recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.









MichDenis
Le #3928781
Un petit truc pour déterminer quel est le séparateur des arguments de la matrice {"a"."b}

a) inscrit dans une cellule par exemple : = Somme(A1:A3)
b) dans la barre de formule, tu sélectionnes le texte A1:A3
c) tu appuis sur la touche F9, l'adresse des cellules va être
remplacé par les valeurs des cellules de la plage et entre
les éléments du tableau, tu pourras voir le séparateur d'arguments
de la matrice. (ceci est vrai pour une matrice verticale)
Pour une matrice horizontale, tu dois utiliser = Somme(A1:C1)
(un tableau en ligne)



"Britannicus" %
Même adaptée, ça ne va pas. Est ce que {"a"."b"}est une matrice ? Somment la
valider sans que toute la formule ne devienne une matrice ?
Je ne cherche pas un produit, mais un comptage de valeurs.

"MichDenis" %

Essaie ceci :
=SOMMEPROD((A1:A15="03/11/2006"*1)*(B1:B15={"a"."b"}))

Le séparateur (point) de {"a"."b"}peut être différent sur ton système
selon ta configuration.


"Britannicus" uMQ0E%
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je
recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.









Britannicus
Le #3928761
=SI(récap!$A$2:$A$1000¡3*1;NB.SI((récap!$J$2:$J$1000);8,5);NB.SI((récap!$J$2:$J$1000);23))

Avec cette formule, j'ai le bon total général mais le 1er SI n'est pas pris
en compte (=SI(récap!$A$2:$A$1000¡3*1)
Mais ça peut donner une idée plus précise de ce que je recherche.

(merci pour le "petit truc").

"MichDenis"
Un petit truc pour déterminer quel est le séparateur des arguments de la
matrice {"a"."b}

a) inscrit dans une cellule par exemple : = Somme(A1:A3)
b) dans la barre de formule, tu sélectionnes le texte A1:A3
c) tu appuis sur la touche F9, l'adresse des cellules va être
remplacé par les valeurs des cellules de la plage et entre
les éléments du tableau, tu pourras voir le séparateur d'arguments
de la matrice. (ceci est vrai pour une matrice verticale)
Pour une matrice horizontale, tu dois utiliser = Somme(A1:C1)
(un tableau en ligne)



"Britannicus" %
Même adaptée, ça ne va pas. Est ce que {"a"."b"}est une matrice ? Somment
la
valider sans que toute la formule ne devienne une matrice ?
Je ne cherche pas un produit, mais un comptage de valeurs.

"MichDenis" %

Essaie ceci :
=SOMMEPROD((A1:A15="03/11/2006"*1)*(B1:B15={"a"."b"}))

Le séparateur (point) de {"a"."b"}peut être différent sur ton système
selon ta configuration.


"Britannicus" uMQ0E%
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je
recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher
à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.














MichDenis
Le #3928741
Une dernière tentative :

=SOMMEPROD((récap!$A$2:$A$1000¡3*1)*(récap!$J$2:$J$1000={8,5.23}))
Pour déterminer le séparateur dans {8,5.23}, il y a le "petit truc"
tu n'as pas besoin de guillemets si tes valeurs à compter sont numériques.




"Britannicus" %
=SI(récap!$A$2:$A$1000¡3*1;NB.SI((récap!$J$2:$J$1000);8,5);NB.SI((récap!$J$2:$J$1000);23))

Avec cette formule, j'ai le bon total général mais le 1er SI n'est pas pris
en compte (=SI(récap!$A$2:$A$1000¡3*1)
Mais ça peut donner une idée plus précise de ce que je recherche.

(merci pour le "petit truc").

"MichDenis"
Un petit truc pour déterminer quel est le séparateur des arguments de la
matrice {"a"."b}

a) inscrit dans une cellule par exemple : = Somme(A1:A3)
b) dans la barre de formule, tu sélectionnes le texte A1:A3
c) tu appuis sur la touche F9, l'adresse des cellules va être
remplacé par les valeurs des cellules de la plage et entre
les éléments du tableau, tu pourras voir le séparateur d'arguments
de la matrice. (ceci est vrai pour une matrice verticale)
Pour une matrice horizontale, tu dois utiliser = Somme(A1:C1)
(un tableau en ligne)



"Britannicus" %
Même adaptée, ça ne va pas. Est ce que {"a"."b"}est une matrice ? Somment
la
valider sans que toute la formule ne devienne une matrice ?
Je ne cherche pas un produit, mais un comptage de valeurs.

"MichDenis" %

Essaie ceci :
=SOMMEPROD((A1:A15="03/11/2006"*1)*(B1:B15={"a"."b"}))

Le séparateur (point) de {"a"."b"}peut être différent sur ton système
selon ta configuration.


"Britannicus" uMQ0E%
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je
recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher
à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.














Britannicus
Le #3928721
SUPER ! La dernère était la bonne ! MichDenis, t'es un chef !

Merci ...et bonne nuit !

Britannicus

"MichDenis"
Une dernière tentative :

=SOMMEPROD((récap!$A$2:$A$1000¡3*1)*(récap!$J$2:$J$1000={8,5.23}))
Pour déterminer le séparateur dans {8,5.23}, il y a le "petit truc"
tu n'as pas besoin de guillemets si tes valeurs à compter sont numériques.




"Britannicus" %
=SI(récap!$A$2:$A$1000¡3*1;NB.SI((récap!$J$2:$J$1000);8,5);NB.SI((récap!$J$2:$J$1000);23))

Avec cette formule, j'ai le bon total général mais le 1er SI n'est pas
pris
en compte (=SI(récap!$A$2:$A$1000¡3*1)
Mais ça peut donner une idée plus précise de ce que je recherche.

(merci pour le "petit truc").

"MichDenis"
Un petit truc pour déterminer quel est le séparateur des arguments de la
matrice {"a"."b}

a) inscrit dans une cellule par exemple : = Somme(A1:A3)
b) dans la barre de formule, tu sélectionnes le texte A1:A3
c) tu appuis sur la touche F9, l'adresse des cellules va être
remplacé par les valeurs des cellules de la plage et entre
les éléments du tableau, tu pourras voir le séparateur d'arguments
de la matrice. (ceci est vrai pour une matrice verticale)
Pour une matrice horizontale, tu dois utiliser = Somme(A1:C1)
(un tableau en ligne)



"Britannicus" %
Même adaptée, ça ne va pas. Est ce que {"a"."b"}est une matrice ? Somment
la
valider sans que toute la formule ne devienne une matrice ?
Je ne cherche pas un produit, mais un comptage de valeurs.

"MichDenis" %

Essaie ceci :
=SOMMEPROD((A1:A15="03/11/2006"*1)*(B1:B15={"a"."b"}))

Le séparateur (point) de {"a"."b"}peut être différent sur ton système
selon ta configuration.


"Britannicus" news:
uMQ0E%
Bonsoir MichDenis,

Je suis parfois un peu compliqué, désolé. Ce n'est pas ce que je
recherche.

Feuille 1
Colonne A Colonne B
Dates Type
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 A
03/11/2006 B
03/11/2006 A
03/11/2006 B
04/11/2006 A
..etc

Combien ai je de A et combien ai je de B pour le 03/11/2006 ?
idem pour les jours suivants. les résultats sur la feuille 2

Feuille 2
Dates Type A Type B
03/11/2006 4 3
04/11/2006...............

et c'est sur cette feuille 2 que je souhaiterais voir la date s'afficher
à
la suite dès qu'elle existe sur la feuille 1


Britannicus

"MichDenis"
Un petit exemple si j'ai compris
=SOMMEPROD((F1:F15="14/11/2006"*1)*((G1:G15)+(H1:H15)))
F1:F15 -> colonne des dates

Si F1:F15 = 14/11/2006 tu additionnes 2 colonnes : G1:G15 et H1:H15

Si c'est ceci que tu cherches, il ne te reste plus qu'à l'adapter à ton
cas.



















Publicité
Poster une réponse
Anonyme