problème de clavier suite au passage à xorg 7.0.0

Le
Tom
Salut,

D'après ce que j'ai compris, la unstable de Debian est passée à xorg
7.0.0. Vu que j'ai du ATI et que les drivers mettent toujours un petit
temps à arriver et qu'à cause des dépendances ça foire je ne voulais pas
y passer. Mais sans le vouloir j'ai installé quelques paquets. Au
démarrage suivant j'ai remarqué que la touche shift ne marchait plus. Je
me dis "au diable les drivers ATI", je passe à xorg 7.0.0 et puis fini.

Et là c'était pire finalement. J'ai du mettre le driver "ati" à la place
de "fglrx" dans xorg.conf sinon le serveur x ne se lançait tout
simplement pas. Première fois que je voie ça avec les drivers ATI. Mais
en plus le clavier ne marche pas mieux. Au lancement de la session,
gnome m'affiche une jolie fenêtre :

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
70000000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

les commandes ci-dessus me donnent :
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "base", "pc101", "us", "", ""

et

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = []
model =
overrideSettings = false
options = [compose compose:rwin]

pas très rassurant quoi.

voici ma partie sur le clavier dans xorg.conf :

> Section "InputDevice"
> Identifier "Generic Keyboard"
> Driver "kbd"
> Option "CoreKeyboard"
> Option "XkbRules" "xorg"
> Option "XkbModel" "pc105"
> Option "XkbLayout" "fr"
> Option "XkbOptions" "compose:rwin"
> EndSection

J'avais "keyboard" comme driver, et j'ai changé en kbd, mais ça ne va
pas mieux. Pour info je n'avais strictement aucun problème avec cette
config avant.

Dans /var/log/Xorg.0.log j'ai ça :

(II) XINPUT: Adding extended input device "Generic Keyboard" (type:
KEYBOARD)
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap

Ca explique des choses quoi, mais ça ne résoud rien. En fait ça ne m'a
pas permi de trouver une solution sur google ou autre. :-(

Bref si quelqu'un a une piste, ça m'aidrait beaucoup :-)


ps : je remercie le copier:coller qui me permet d'accéder aux caractères
uniquement accessible avec shift ou alt.

--
Tom
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Damien Wyart
Le #1755048
apt-get install xkb-data

--
DW
Tom
Le #1755047
Damien Wyart wrote:
apt-get install xkb-data


C'est parfait, ça a l'air de marcher. Merci beaucoup.

--
Tom

Publicité
Poster une réponse
Anonyme