Problème de consommation mémoire avec IIS 5.0

Le
Julien Sambourg
Bonjour,

J'administre un serveur web dédié qui héberge un site accueillant chaque
jour plusieurs milliers de visiteurs. C'est un serveur sous Windows 2000
Serveur SP4 avec IIS 5.0, tous les patchs et 1 Go de mémoire vive.
J'ai depuis plusieurs mois quelques problèmes de performances liés à une
consommation "abusive" (je pense) de la mémoire vive.
En effet, à charge normal, environ 500 Mo de la mémoire vive sont utilisés,
toutes applications confondues. Mais au bout de quelques jours le processus
inetinfo.exe "s'emballe" et grossi petit à petit jusqu'à ce qu'il consomme
plusieurs centaines de Mo à lui tout seul. Je trouverai ça normal vu la
charge et le nombre de visiteurs mais le problème c'est que même la nuit par
exemple il continue d'utiliser toute la RAM alors que la charge est
minimale. En gros les processus IIS ne se recyclent pas visiblement.

J'utilisai un temps l'utilitaire IIS5Recycle.exe mais le service refuse
désormais de démarrer sans que je sache ce qu'il s'est passé, l'installation
d'un patch de Win2K en est probablement la cause. De toute façon, cette
solution ne me convenait pas énormément vu que le serveur était indisponible
pendant plusieurs secondes le temps que le service se relance.
J'ai également modifié quelques variables de la base de registre notamment
pour réduire la taille du cache (variable MemCacheSize) mais cela ne marche
guère mieux. J'ai aussi modifié PoolThreadLimit, ListenBackLog etc. pour les
performances.

Pour info, j'utilise le mode de protection isolé obligatoire pour la
stabilité du site.

Si quelque'un a une idée pour mettre fin à cette consommation de RAM
inopinée! Je pense que IIS 6.0 pourrait résoudres mes problèmes, non? Mais
ça ne m'arrange pas de migrer tout ça sur un serveur qui est à l'autre bout
de la France

Merci beaucoup.

--
Julien
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
jbongran
Le #11282221
Julien Sambourg wrote:
Bonjour,

J'administre un serveur web dédié qui héberge un site accueillant
chaque jour plusieurs milliers de visiteurs. C'est un serveur sous
Windows 2000 Serveur SP4 avec IIS 5.0, tous les patchs et 1 Go de
mémoire vive.
J'ai depuis plusieurs mois quelques problèmes de performances liés à
une consommation "abusive" (je pense) de la mémoire vive.


http://www.microsoft.com/downloads/details.aspx?FamilyIDc4f89d-cc68-42ba-98d2-0c580437efcf&DisplayLang=en
Poster une réponse
Anonyme