Probleme gestion impression Samba - cups

Le
informatique
Bonjour,
Le groupe linux.samba étant en lecture seule pour raison
administrative
je poste donc sur ce groupe.
J'ai un serveur Debian 3.0 avec tous les paquetages cups installés
(version 1.1.14-5)
J'ai installé samba 3 en compilant les sources avec l'otpion
--enable-cups.
Le log de la compilation montre que l'option a bien été prise en
compte.
La cde ldd `which smbd{ également (licups.so.2=>/usr/lib/libcups.so.2)

Extrait du smb.conf :
[global]
workgroup = MAIRIE
log level = 2
log file = /usr/local/samba/var/log.%m
printcap name = cups
printing = cups
load printers = Yes
domain logons = Yes
preferred master =Yes
domain master = Yes
wins support = Yes
admin users = @informatique
[NRG445]
# Imprimante production
path = /var/spool/samba/NRG445
printer admin = @informatique
printable = Yes
print command = /usr/bin/lpr -U %U -P%p -o raw %s
lpq command = /usr/bin/lpstat -p %p -o %p
lprm command = /usr/bin/cancel %p-%j
lppause command = /usr/bin/lp -i %p-%j -H hold
lpresume command = /usr/bin/lp -i %p-%j -H resume
printer name NGR455
use client driver = Yes
- fin extrait smb.conf -
A partir du gestionnaire d'impression windows :
1)Un utilisateur authentifié du groupe informatique mets la file
d'attente NRG445 en pause : OK
2)il imprime une page de test : OK sauf que le nom du fichier dans la
file windows, ce n'est pas le "page de test" habituel mais "Wed Jun
16"
3)il essaie d'annuler le document, réponse : Vous n'avez pas le droit
de modifier le travail d'impression
4)il essaie de suspendre l'impression du doc, même réponse

Dans le fichier log de samba :
pour 3) cancel : cancel-job failed : client-error-not-found
pour le 4) lp: set-job-attributes failed : client-error-not-found
après récupération dans un fichier des paramètres transmis par samba
aux commandes (%p %j etc), je me suis aperçu que %j contenait la
taille du fichier (15360) au lieu du numéro du job (7)

Résultat de la commande lpstat -o NRG455 :
NRG455-7 aussillous 15360 Wed Jun 16 11:09:51 2004


Depuis plus d'un mois, je cherche dans la documentation, les bouquins,
les forums et le web. Je n'ai rien trouvé. j'ai effectué toutes sortes
de tests. le problème est identique avec des clients win9x win2k et
winXP.

Pouvez-vous m'aider à résoudre ces problèmes (2, 3 et 4) ou au moins
me donner des pistes pour le résoudre ?

Merci. Toute aide est la bienvenue.


Christian Aussillous
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
informatique
Le #1488835
J'ai résolu le problème par l'installation de samba 3.04

Merci à tous ceux qui ont essayé de m'aider

Christian Aussillous
Poster une réponse
Anonyme