[Probleme install sarge]

Le
Norbert Bottlaender-Prier
En installant sarge, j'ai rencontr plusieurs problmes qui me paraisse=
nt insuffisamment traits par la documentation, ou par l'installateur (qu=
e chacun qui se sente concern(e) se coltine le paquet) et mon rapport d'=
installation n'a pas (encore) trouv de rponse. Je n'ai pourtant pas d=
e matriel trs exotique d'autant plus qu'il a dja fonctionn s=
ous une version prcdente de debian (except le disque dur que j'ai =
d remplacer suite un probleme "mcanique", et qui n'a trouv de =
remplacement quivalent, l'offre disponible en achat de matriel neuf a=
yant volu)
Passons au "charbon":
1) Malgre la prsence de 19 CD d'installation, je n'ai pas russi d'ins=
taller le web convenablement. En dpannage, malgr tous ses inconvni=
ents, je me connecte avec mon ancien ordinatour sous Win98 via le "Speedtou=
ch"-Modem qui a au moins le mrite de fonctionner, me donnant ainsi la po=
ssibilit de vous contacter (autrement je serais littralement coup =
du monde) comme j'ai pu graver les CD-ROM
Mais comme le problme "Speedtouch" parat (selon plusieurs DWN) dj=
rsolu depuis plus d'un an, les CD ne refltent visiblement pas cet=
te solution, ni la documentation au moins pas celle que j'ai trouve..=
. La seule rponse tangible est pendant l'installation apparat brievem=
ent "un module s'appelant "speedtch" manquant dans le kernel", mais aucune =
indication sur comment l'obtenir
2) La souris (PS2) ne s'installe pas (non plus) et l, pas l'ombre d'une =
solution. quand je fais "apt-get install gpm" j'obtiens: "gpm: Dpend ucf=
(>0.20) mais il n'est pas installable" mais comment le trouver s'il n'e=
st pas installable? et pourquoi? Avant, gpm a toujours fonctionn tout se=
ul (mais avant, c'tait aussi une souris sur com1: et comme elle n'tai=
t pas optique, l'ge l'avait rendue un peu trop fatigue pour encore ro=
uler sa boule)

Merci pour creuser vos mninges, en esprant que quelqu'un trouve une i=
de plus ou moins lumineuse

@+
Norbert
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yvan Martzluff
Le #9483301
Le vendredi 29 décembre 2006 11:25, Norbert Bottlaender-Prier a écrit  :
En installant sarge, j'ai rencontré plusieurs problèmes qui me parais sent
insuffisamment traités par la documentation, ou par l'installateur (que
chacun qui se sente concerné(e) se coltine le paquet) et mon rapport
d'installation n'a pas (encore) trouvé de réponse. Je n'ai pourtant p as de
matériel très exotique... d'autant plus qu'il a déja fonctionné s ous une
version précédente de debian (excepté le disque dur que j'ai dû r emplacer
suite à un probleme "mécanique", et qui n'a trouvé de remplacement
équivalent, l'offre disponible en achat de matériel neuf ayant évol ué)
Passons au "charbon":
1) Malgre la présence de 19 CD d'installation, je n'ai pas réussi
d'installer le web convenablement. En dépannage, malgré tous ses
inconvénients, je me connecte avec mon ancien ordinatour sous Win98 via le
"Speedtouch"-Modem qui a au moins le mérite de fonctionner, me donnant
ainsi la possibilité de vous contacter (autrement je serais littérale ment
coupé du monde) comme j'ai pu graver les CD-ROM... Mais comme le probl ème
"Speedtouch" paraît (selon plusieurs DWN) déjà résolu depuis plus d'un an,
les CD ne reflétent visiblement pas cette solution, ni la documentation ...
au moins pas celle que j'ai trouvée... La seule réponse tangible est
pendant l'installation apparaît brievement "un module s'appelant "speed tch"
manquant dans le kernel", mais aucune indication sur comment l'obtenir...
2) La souris (PS2) ne s'installe pas (non plus) et là, pas l'ombre d'une
solution. quand je fais "apt-get install gpm" j'obtiens: "gpm: Dépend u cf
(>0.20) mais il n'est pas installable"... mais comment le trouver s'il
n'est pas installable? et pourquoi? Avant, gpm a toujours fonctionné to ut
seul (mais avant, c'était aussi une souris sur com1: et comme elle n' était
pas optique, l'äge l'avait rendue un peu trop fatiguée pour encore ro uler
sa boule...)

Merci pour creuser vos méninges, en espérant que quelqu'un trouve une idée
plus ou moins lumineuse

@+
Norbert



Question bête :
au boot du cd d'install est-ce que tu as passé l'option pour passer sur l e
noyau 2.6 ?
(style linux26 ou expert26 par ex)
Sinon il y a un très bon tuto pour l'install de sarge, en espérant que celà
puisse t'aider :
http://www.coagul.org/article.php3?id_article37

Bonne install :-)
Norbert Bottlaender-Prier
Le #9483021
On Fri, 29 Dec 2006 17:08:49 +0100
Yvan Martzluff
[des conseils intéressants mais 'cause hardware trop microsoftienne diffi cilement réalisables (surtout le fabricant - Hercules, pour ne pas le nom mer - a annoncé qu'il cesserait da fournir des pilotes à partir du kern el 2.6.) C'est pas le bon moment... ou un mauvais moment à passer - pour lui : j'acheterais autre chose - ou rien du tout. Est-ce j'ai vraiment beso in d'une nouvelle carte graphique super-accélérée mais handicapée p ar un système d'exploitation peu adapté? :-)]
...
> > Sinon il y a un très bon tuto pour l'install de sarge, en espéran t que
> > celà
> > puisse t'aider :
> > http://www.coagul.org/article.php3?id_article37


Cela m'a aidé bien au départ, puis les idées commençaient à diver ger...
et les CD d'installation à avoir des difficultés de lisibilité. Apres trois essais, j'ai finalement réussi à avoir tout installé - à l'e xception d'un paquet (ou est-ce un bogue en aptitude ou dans un des paquets ... il n'arrête pas d'afficher qu'il manque qqch., mais impossible de tro uver quoi)

Finalement, une ultime question: Ayant apparemment tout installé , le ker nel module speedtch, pppoe et pppd evec leurs docs respectifs etc. et j'ai encore le disque d'install du modem... pardon, le disque d'installation d'i nternet sous winows, ce qui n'est pas la même chose... mais je n'arrive p as à me débarrrasser de l'impression qu' il manque quelque chose d'esse ntiel: comment mettre le firmware-blob dans le modem qui ne fonctionne pas sans? A l'origine, c'était une option -f dans pppoe (ou était-ce pppoa?)
bolobblobblob...

@+
Norbert
Norbert Bottlaender-Prier
Le #9482041
On Sat, 30 Dec 2006 10:34:24 +0100
Yvan Martzluff
Bonjour (et accesoirement aussi bonne année, en fait, pendant qqs jours, j'étais complètement privé d'internet qui paraissait avoir subi une p anne générale, mais je suis finalement tombé sur une collaboratrice d 'orange assez compétente... à qui les failles du système windows ne f aisaient pas peur...

En fait, je crois la carte graphique Hercules Prophet 4000 XT peut attendre , ce n'est pas une priorité...

C'est quoi comme carte graphique ?
De tt façon si les drivers sont supportés par le 2.4, ils le seront par le
2.6...



Alors je peux patienter... Actuellement, c'est une Rage 3D intégrée dan s la carte mère...

Note l'erreur.
Lors du boot du noyau ? lors du démarrage de X ? lors du démarrage du
desktop ?



Rien de tout ça. Ce se manifestait par des incohérences de ce que je tr ouvais d'affiché dans aptitude (mais je ne connais pas aptitude sufisamme nt pour pouvoir détailler exactement ce qui me semblait clocher) en tout, le résultat global était probablement correct (je ne suis pas encore a rrivé dans l'affichage graphique) Ce qui m'importe en premier lieu, c'est mon propre serveur httpd, pour remplacer l'hebergement qui dépend d'autr es que moi, et fonctionnait déjà sous kernel 2.4.18 avec le même mode m, surtout que l'hébergeur allemand n'a pas configuré son serveur corre ctement: l'URL www.agp.org ne peut afficher que l'index.html, mais pas de p ages intermédiaires, tandis que mon serveur (http://tmtm.homelinux.org/ww w.agp.org/) peut (en prévision) fournir toutes les pages... et encore plu s) Et j'aurais même gardé la configuration comme précédemment, si m on hdb (qui contenait /home/www avec des symlinks appropriés sur /var/www ) ne s'était pas fait la malle...

> j'ai encore le disque d'install du modem... pardon, le disque
> d'installation d'internet sous winows, ce qui n'est pas la même chose ...
> mais je n'arrive pas à me débarrrasser de l'impression qu' il manque
> quelque chose d'essentiel: comment mettre le firmware-blob dans le modem


Je ne me suis pas explicité correctement, paraît-il. Le problème vien t du mode de stockage des fichiers qui font functionner le modem Speedtouch qui en fait, n'est une coquille vide et ne devient un modem que par le bia is d'un logiciel firmware qui lui parvient par le port USB et ensuite ce po rt se transforme en ethernet (ou autre chose) par une émulation... et une décompression d'un fichier CAB, et ce qui se fait là, ne semble pas cl air. est-ce à travers pppoa ou par pppoe? A l'installation d'origine, ce paraît être pppoa, mais le nouvau kernel semble indiquer pppoe... cela induit une confusion certaine, je ne l'ai pas encore réussi tirer au clai r. Un How-to serait le bienvenu... éventuellement à écrire moi-même ...

@+
Norbert

Attends c'est un speedtouch USB ou ethernet ?
pppoe => ethernet
pppoa => usb

Je comprend pas le rapport GNU/linux et le cd de ton FAI pour indows...



Justement: actuellement, j'utilise l'installation proposée pour Win98 ( évidemment, ce n'est que provisoire pour avoir un minimum d'internet, et ce n'est pas le même ordinateur que j'ai prévu d'équiper avec Debian (et là, ce sera aussi le "Modem" Speedtouch: je n'ai qu'une ligne tél. Ce sont deux machines distinctes, seulement (éventuellement) reliés par ethernet... ce qui n'est pas obligé...

fais une liste de ton matériel


En tout, pour l'instant le seul matériel un peu special et je dois impé rativement faire fonctionner sous Debian kernel 2.6, c'est justement le spe edtouch modem. tout le reste peut attendre resp. fonctionne déjà mieux que sous winxx... p.ex. la carte son pci3000 sous alsa...

ps : lorsque tu pense que tes questions sont claires (liste du matos, sor tie
console de tes erreurs) et valent la peine d'être posées, n'hésite pas à
poster sur la liste ta question, ça peut aider d'autres personnes.

tcho :-)


Publicité
Poster une réponse
Anonyme