Problème de rafraichissement de Firfox avec Gnome 3.36

Le
Sébastien Dinot
Bonjour à tous,

Je rencontre le même problème avec Firefox sur 2 PC en Debian testing
(Bullseye), dont bizarrement, je ne trouve aucun signalement dans le
bugtracker de Debian (peut-être que je n'utilise pas les bons mots-clés
ou que je ne recherche pas au bon endroit).

Ce problème est apparu lorsque je suis passé de Gnome 3.34 à Gnome 3.36.
Aucune mise à jour de Firefox n'a eu lieu à cette occasion. Je rencontre
le problème tant avec la version ESR (68.7.0esr-1) qu'avec la dernière
version stable proposée par Debian (75.0-2) et je n'ai identifié ce
problème sur aucune des autres applications que j'utilise.

Lorsque je clique sur le bouton « + » à droite de la barre d'onglets
pour faire apparaitre un nouvel onglet ou lorsque je clique sur un
onglet existant, Firefox ne se rafraichit pas immédiatement :

* le nouvel onglet n'apparait pas tout de suite, il apparait parfois
après une seconde, souvent après un délai bien plus long (il m'est
arrivé d'attendre jusqu'à une minutes sans toucher le clavier),
quelques rares fois, l'apparition est immédiate mai j'ai parfois
l'impression que rien ne se passera tant que je ne changerai pas de
fenêtre.

* idem pour l'onglet sur lequel je clique. Il peut apparaite après
quelques dixièmes de secondes seulement, mais en général, il apparait
après « d'interminables » secondes (si, si, je vous jure, quand on
attend et pour peu que l'on soit pressé, les secondes s'étirent
jusqu'à devenir interminables).

Dans les deux cas, si je switche de fenêtre pour passer à une autre
application, cela déclenche le rafraichissement immédiat de Firefox.
C'est assez déroutant !

J'ai essayé de démarrer les deux versions de Firefox avec l'option
« --safe-mode » pour désactiver toutes les extensions, mais cela ne
change rien à l'affaire.

J'utilise le système Wayland et le gestionnaire de fenêtres Mutter.

Je pense qu'un rétropédalage (retour à Gnome 3.34) serait compliqué tant
il y a de dépendances et j'aimerais autant ne pas avoir à faire, surtout
qu'il occulterait simplement le problème au lieu de le résoudre.

Auriez-vous des pistes de recherche à me proposer ?

Et question subsidiaire : suis-je le seul à rencontrer ce problème ou
à utiliser encore Firefox ?

Je vous remercie par avance pour vos lumières,

Sébastien

--
Sébastien Dinot, sebastien.dinot@free.fr
http://www.palabritudes.net/
Ne goûtez pas au logiciel libre, vous ne pourriez plus vous en passer !
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Sébastien Dinot
Le #26545061
Sébastien Dinot a écrit :
Et question subsidiaire : suis-je le seul à rencontrer ce problème ou
à utiliser encore Firefox ?

À défaut de solution, s'il y a sur cette liste des utilisateurs de
Debian testing (Bulleyes) et de Firefox ayant basculé sur Gnome 3.36, je
serais heureux de savoir s'ils rencontrent le même problème.
En effet, je suis vraiment surpris de ne trouver aucune trace de ce
problème fort pénible sur le net et comme mes machines sont en testing
et actualisées chaque jour depuis plusieurs années, je me demande si le
problème ne serait pas imputable à l'accumulation de « scories »,
désormais obsolètes, mais perturbant le bon fonctionnement du système.
Je vous en remercie par avance,
Sébastien
--
Sébastien Dinot,
http://www.palabritudes.net/
Ne goûtez pas au logiciel libre, vous ne pourriez plus vous en passer !
Sébastien Dinot
Le #26546972
Bonjour à tous,
Sébastien Dinot a écrit :
À défaut de solution, s'il y a sur cette liste des utilisateurs de
Debian testing (Bulleyes) et de Firefox ayant basculé sur Gnome 3.36,
je serais heureux de savoir s'ils rencontrent le même problème.

Petit retour d'expérience après un silence assez long. Le problème
persistant malgré les mises à jour quotidiennes du système et de vains
essais visant à identifier la cause des problèmes rencontrés avec
Firefox (démarrage avec un nouveau profil, sans activer les extensions,
etc.), de guerre lasse, j'ai « réinitialisé » l'environnement des
utilisateurs en créant des répertoires /home/<user> vides (après avoir
bien entendu renommé les répertoires existants pour ne pas perdre les
données).
Et le problème a disparu !
Les comptes sur ces deux machines existant depuis des années, force est
de constater que s'y sont accumulées des scories que je n'ai pas réussi
à identifier, et qui ont produit avec Gnome 3.36 une alchimie que je ne
m'explique absolument pas, mais particulièrement toxique pour Firefox.
Sébastien
--
Sébastien Dinot,
http://www.palabritudes.net/
Ne goûtez pas au logiciel libre, vous ne pourriez plus vous en passer !
Poster une réponse
Anonyme