Proxmox - ip publique - resolv.conf

Le
Frederic Robert
Bonjour à la liste,

Comment allez-vous? Qui utilise Proxmox ? J'ai installé debian dans une
machine virtuelle sans configurer le réseau parce que c'est une machine
qui aura une adresse ip publique et il parait qu'il faut faire comme ça
quand on veut configurer une adresse ip publique lors de l'installation.

Tout fonctionne correctement mais après l'installation je vois que
/etc/resolv.conf n'existe pas. Je le crée et utilise les serveurs de
noms de FDN :) nameserver 80.67.169.12 et nameserver 80.67.169.40 et
configure l'interface réseau au redémarrage de la machine. Quand je veux
pinger un nom de domaine cela ne fonctionne pas. C'est ok si je ping une
ip. Est-ce que quelqu'un peut m'aider?

D'avance merci, très bonne journée,

--
Frédéric ROBERT
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Sébastien NOBILI
Le #26545386
Bonjour,
Le 2020-05-01 15:07, Frederic Robert a écrit :
Comment allez-vous? Qui utilise Proxmox ? J'ai installé debian dans
une machine virtuelle sans configurer le réseau parce que c'est une
machine qui aura une adresse ip publique et il parait qu'il faut faire
comme ça quand on veut configurer une adresse ip publique lors de
l'installation.

Étrange, ne pas configurer le réseau pour une machine dont la finalité
est justement d'être joignable sur le réseau ? Je ne comprends pas bien
la logique…
Il est assez rare de "brancher" directement une machine sur le réseau
public, en général il y a une passerelle qui permet de faire le lien.
Tout fonctionne correctement mais après l'installation je vois que
/etc/resolv.conf n'existe pas. Je le crée et utilise les serveurs de
noms de FDN :) nameserver 80.67.169.12 et nameserver 80.67.169.40 et
configure l'interface réseau au redémarrage de la machine. Quand je
veux pinger un nom de domaine cela ne fonctionne pas. C'est ok si je
ping une ip. Est-ce que quelqu'un peut m'aider?

Je réinstallerais avec configuration du réseau. Visiblement ton système
est incomplet et identifier tout ce qui lui manque risque de demander
beaucoup plus d'énergie que la réinstallation.
Sébastien
Frederic Robert
Le #26545389
On 5/4/20 8:13 AM, Sébastien NOBILI wrote:
Étrange, ne pas configurer le réseau pour une machine dont la finalité
est justement d'être joignable sur le réseau ? Je ne comprends pas bien
la logique…
Il est assez rare de "brancher" directement une machine sur le réseau
public, en général il y a une passerelle qui permet de faire le lien.
Je réinstallerais avec configuration du réseau. Visiblement ton système
est incomplet et identifier tout ce qui lui manque risque de demander
beaucoup plus d'énergie que la réinstallation.
Sébastien


Bonjour Sébastien et à la liste,
Concernant resolv.conf, la cause était le pare-feu matériel qui se
trouve avant le serveur. Concernant la configuration de l'interface
réseau, j'ai lu sur internet que c'était parce que la passerelle était
une ip différente de l'adressage. Résolution: execute shell et
configurer l'adresse ip à la main pour ensuite continué l'installation.
Après l'installation, tu configures ton interface réseau avec ton ip
publique et tu ajoutes deux serveurs de noms dans le fichier resolv.conf
et cela fonctionne. J'ai aussi dû désactivé le pare-feu matériel
Très bonne journée,
--
Frédéric ROBERT
Frederic Robert
Le #26550484
On 7/2/20 5:54 AM, Dethegeek wrote:
Bonjour,
J'utilise proxmox depuis la version 2 je crois.
Ta VM est probablement derrière un routeur, lui même situé entre
internet et ton LAN, n'est ce pas ?
Ta VM est elle une VM (avec KVM) ou un conteneur (LXC) ?

Bonjour,
Le problème avec resolv.conf c'était le parefeu hardware qui bloquait.
Depuis, j'ai trouvé la solution. Merci quand même pour l'aide :)
La vm est kvm
Très bonne journée,
--
Frédéric ROBERT
Poster une réponse
Anonyme