Pulseaudio qui ne d=c3=a9marre pas

Le
BERTRAND Jo=c3=abl
Bonjour à tous,

J'utilise un player diskless qui tourne sous debian/stable. Pour je ne
sais plus quelle raison (sans doute un codec qui ne fonctionnait pas
correctement), j'ai fait un apt dist-upgrade. kde est passé de la
version 4 à la version 5 (j'utilise KDE sur cette machine car c'est le
seul qui est capable de gérer correctement la sortie son HDMI en étant
'Michu compliant'). kdm n'étant plus supporté, j'ai installé et
configuré sddm à la place (franchement, quelle idée d'avoir les logins
disponibles sur la page de connexion).

Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur). Si
j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
l'ordre.

L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
kde sur cette machine, pulseaudio soit bien démarré.

Une idée ?

Bien cordialement,

JKB
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bureau LxVx
Le #26528246
Bonjour à tous,
Un de nos adhérents Linux Ventoux a eu le même problème : le passage au
nouveau noyau ...
Bien librement,
Sylvie
Le 14/10/2019 à 14:32, BERTRAND Joël a écrit :
Bonjour à tous,
J'utilise un player diskless qui tourne sous debian/stable. Pour je ne
sais plus quelle raison (sans doute un codec qui ne fonctionnait pas
correctement), j'ai fait un apt dist-upgrade. kde est passé de la
version 4 à la version 5 (j'utilise KDE sur cette machine car c'est le
seul qui est capable de gérer correctement la sortie son HDMI en étant
'Michu compliant'). kdm n'étant plus supporté, j'ai installé et
configuré sddm à la place (franchement, quelle idée d'avoir les logins
disponibles sur la page de connexion...).
Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur). Si
j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
l'ordre.
L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
kde sur cette machine, pulseaudio soit bien démarré.
Une idée ?
Bien cordialement,
JKB
BERTRAND Jo=c3=abl
Le #26528255
Bureau LxVx a écrit :
Bonjour à tous,
Un de nos adhérents Linux Ventoux a eu le même problème : le passage au
nouveau noyau ...

Je ne vois pas bien le rapport. Si c'était un problème de noyau, je ne
pourrais pas le lancer dans un terminal. Pour moi, ça vient plutôt d'un
problème quelque part dans la grouille KDE.
Bien cordialement,
JKB
raphael.poitevin
Le #26528271
Bonsoir,
BERTRAND Joël
Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur) . Si
j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
l'ordre.
L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
kde sur cette machine, pulseaudio soit bien démarré.

Avant de lancer pulse idiot à la main, voir si déjà une inst ance est en
mémoire :
ps aux | grep pulseaudio
Est-ce que dans /etc/pulse/client.conf :
autospawn = yes
/etc/pulse/daemon.conf :
system-instance = no
--
Raphaël
BERTRAND Jo=c3=abl
Le #26528273
Raphaël POITEVIN a écrit :
Bonsoir,
BERTRAND Joël
Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur). Si
j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
l'ordre.
L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
kde sur cette machine, pulseaudio soit bien démarré.

Avant de lancer pulse idiot à la main, voir si déjà une instance est en
mémoire :
ps aux | grep pulseaudio
Est-ce que dans /etc/pulse/client.conf :
autospawn = yes

Non, la ligne est commentée (j'ai la configuration par défaut, je n'ai
jamais touché à ce fichier).
/etc/pulse/daemon.conf :
system-instance = no

Pareil, ligne commentée.
Je vais donc tester en modifiant ces deux fichiers.
Merci pour l'indication.
JKB
BERTRAND Jo=c3=abl
Le #26528350
BERTRAND Joël a écrit :
Raphaël POITEVIN a écrit :
Bonsoir,
BERTRAND Joël
Depuis, pulseaudio refuse de démarrer (quel que soit l'utilisateur). Si
j'ouvre un xterm et que je tape pulseaudio --start, tout rentre dans
l'ordre.
L'ennui, dans le bazar kde, c'est que je ne vois pas qui doit lancer
pulseaudio et j'aimerais assez éviter une rustine consistant à modifier
les fichiers de conf de chaque utilisateur pour qu'en cas de connexion à
kde sur cette machine, pulseaudio soit bien démarré.

Avant de lancer pulse idiot à la main, voir si déjà une instance est en
mémoire :
ps aux | grep pulseaudio
Est-ce que dans /etc/pulse/client.conf :
autospawn = yes

Non, la ligne est commentée (j'ai la configuration par défaut, je n'ai
jamais touché à ce fichier).
/etc/pulse/daemon.conf :
system-instance = no

Pareil, ligne commentée.
Je vais donc tester en modifiant ces deux fichiers.
Merci pour l'indication.
JKB


Testé. Rien à faire, puseaudio ne démarre pas...
JKB
Sébastien NOBILI
Le #26528729
Bonjour,
15 octobre 2019 18:35 "BERTRAND Joël"
Testé. Rien à faire, puseaudio ne démarre pas...

Chez moi, PulseAudio est démarré v ia Systemd en mode utilisateur (/usr/lib/systemd/user/pulseaudio.service) .
N'aurais-tu pas un autre système d'init actif à la place de Systemd ou désactivé l'unité pulseaudio.service ?
Sébastien
Publicité
Poster une réponse
Anonyme