Qt Designer pour Qt 5 et PyQt5

Le
Benoit B
Bonjour

Quels sont les paquets à installer pour avoir Qt Designer avec Qt5
plutôt que QT4 par défaut ?

Merci d'avance
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bruno volpi
Le #26466251
salut,
pour  debian 9 de base :
libqt5core5a,
libqt5designer5,libqt5designercomponents5,pyqt5-dev,python-pyqt5,python3-pyqt5
+ toutes les dépendances.
le mieux est de passer par Synaptic et de voir quel sont les autres
éléments qui pourrai te servir (sql, quick, scintilla , webKit , doc,
qml, opengl , etc .... ).
si tu as les 2 versions de python 2.7 et 3.5 faire attention dans les
scripts à bien switcher sur la bonne version

Le 02/03/2018 à 22:19, Benoit B a écrit :
Bonjour
Quels sont les paquets à installer pour avoir Qt Designer avec Qt5
plutôt que QT4 par défaut ?
Merci d'avance
bruno volpi
Le #26466911
salut,
comme j’utilise rarement designer ( je n'aime pas trop la manière de
transformer de QT vers pyqt je préfères utiliser des canevas que j'ai
créé ) je ne comprends pas trop l'intérêt de faire cohabiter les Qt
designer sauf à vouloir continuer à développer en QT4 et encore !!
je supposes que tu peux reprendre les feuilles QT4 dans designer QT5 les
différences entre les deux étant très faible.
Bruno
Le 10/03/2018 à 09:39, Benoit B a écrit :
Bonjour
Merci pour ta réponse ça fonctionne parfaitement.
Quel serait la meilleur façon de faire cohabiter Qt 5 et Qt 4 dans Designer ?
Je pourrais ré-installer Qt4 Designer, mais ça fait deux logiciels
installés est-ce bien nécessaire ?
Merci d'avance,
Benoit
Le 3 mars 2018 à 09:09, bruno volpi
salut,
pour debian 9 de base :
libqt5core5a,
libqt5designer5,libqt5designercomponents5,pyqt5-dev,python-pyqt5,python3-pyqt5
+ toutes les dépendances.
le mieux est de passer par Synaptic et de voir quel sont les autres éléments
qui pourrai te servir (sql, quick, scintilla , webKit , doc, qml, opengl ,
etc .... ).
si tu as les 2 versions de python 2.7 et 3.5 faire attention dans les
scripts à bien switcher sur la bonne version

Le 02/03/2018 à 22:19, Benoit B a écrit :
Bonjour
Quels sont les paquets à installer pour avoir Qt Designer avec Qt5
plutôt que QT4 par défaut ?
Merci d'avance



Publicité
Poster une réponse
Anonyme