quel fonction

Le
marie
Bonjour

Avec un fichier excel sur rseau qui contient des produits
avec leur dsignation et leur prix.
Lorsque l'on cre un document faisant appel ce fichier :
quelle formule doit-on mettre afin que lorsque l'on tape
le dbut de la rfrence : une liste droulante affiche ce
fichier partir des donnes commenant par les premires
lettres tapes et que je puisse prendre celle qui
m'intresse pour que la dsignation s'affiche dans la
colonne suivante et le prix dans la colonne d'aprs.
Cordialement
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric KERGRESSE
Le #360924
Bonsoir,

Une piste, pas forcément performante mais ça marche. Je l'utilise
quelquefois.

Sur ta nouvelle feuille, tu copies la liste des références du fichier en
réseau et tu colles cette liste dans une colonne quelconque (de préférence
de façon à ce qu'elle n'apparaisse pas sur ton écran) .

Dans la 1ère cellule de la colonne où tu veux saisir tes références
(admettons A2), utilise dans le menu Données, le sous menu Validation. Tu
choisis Liste.
Tu mets en référence la liste que tu viens de coller dans ta feuille. A
partir de ce moment, tu ne peux plus saisir en A2 que des enregistrements
appartenant à cette liste de références.

Tu peux dupliquer la cellule A2 que tu viens de mettre en forme sur les
cellules du dessous, elles feront toutes référence à la liste de validation.
.

Pour ce qui est de la désignation et du coût, il faut utiliser la fonction
RechercheV (attention ton tableau en référence sur le fichier réseau doit
être classé dans l'ordre alphabétique de la 1ère colonne : celle contenant
justement les références ).

La formule pourrait être la suivante :
=RECHERCHEV($A2;TableauReference;2;Faux)
où : -A2 est la cellule que tu as choisi de mettre ta 1ère référence, (nb le
$ te permet de copier à droite sans modifier ta formule)
-TableauReference est le nom de ton tableau dans ton fichier en
réseau. Ce tableau peut contenir le nombre de colonnes qu tu veux mais la
1ère colonne doit être tes références.
-2 est la colonne de ton tableau de référence où est placée la
désignation (par exemple),
- faux pour ne sélectionner que la valeur exacte.

Tu répétes cette formule sur la 3ème colonne pour obtenir le coût
=RECHERCHEV($A2;TableauReference;3;Faux)
en supposant que la colonne 3 est celle où est placé le coût de
l'article(par exemple).

Logiquement, pour chaque article que tu choisis dans ta nouvelle feuille, tu
dois voir apparaître sa désignation et son coût.

Il ne reste plus qu'a copier ces formules dans les cellules d'en dessous.


Pour rendre plus agréable la présentation, n'oublie pas de mettre tes
formules avec des Si;

ex =Si($A2=""; =RECHERCHEV($A2;TableauReference;2;Faux);"")
cela te permettra d'avoir des cellules vides si tu n'as sélectionné
d'articles.

NB : Avec une liste de validation, il ne me semble pas que l'on puisse taper
les premiers caractères de la référence pour que le pointeur se positionne
automatiquement dessus.







"marie" news: 1f8401c3ffa4$2901d050$
Bonjour

Avec un fichier excel sur réseau qui contient des produits
avec leur désignation et leur prix.
Lorsque l'on crée un document faisant appel à ce fichier :
quelle formule doit-on mettre afin que lorsque l'on tape
le début de la référence : une liste déroulante affiche ce
fichier à partir des données commençant par les premières
lettres tapées et que je puisse prendre celle qui
m'intéresse pour que la désignation s'affiche dans la
colonne suivante et le prix dans la colonne d'après.
Cordialement
Publicité
Poster une réponse
Anonyme