Re: asrock dual sata 2 + sid = pas de dma disque

Le
noniin_debian
Pourquoi tu utilises le noyau 2.6.16-k7-smp ? moi j'utilise
linux-image-2.6.16-1-686 (2.6.16-12) et je n'ai aucun problème, même
avec les noyaux antérieurs, les dma de mes disques durs sont tous activés.

djellel

* wrote:


> >> J'ai récemment mis à jour mon PC avec une carte
> >>mère asrock dual sata 2/amd64. Tout marche impec, si ce n'est
> >> que le dma n'est pas activé pour mon disque dur.
> >>
> >> hdparm -d 1 /dev/hda
> >>
> >> /dev/hda:
> >> setting using_dma to 1 (on)
> >> HDIO_SET_DMA failed: Operation not permitted
> >> using_dma = 0 (off)
> >>
> >> Et pas moyen de l'activer. Quelqu'un saurait-il comment
> >> procéder pour résoudre le problème? Merci!
> >>
> >> Pascal
>
> >Pascal, fais un petit tour dans ton bios, tu trouveras ta
> solution! ;)
> >
> >ps: j'ai la même CM que toi. :)
>
> Bonjour,
>
> J'ai fait un tour dans le bios, les disques étaient en
> autodétection. J'ai mis en UDMA2 pour forcer le
> DMA : marche pas, même résultat :-(
>
> Après un google j'ai vu que le problème semble
> lié au fait que le driver spécifique du chipset (ALI
> dans mon cas) n'est pas chargé dans le bon ordre
> par rapport au driver ide générique. Il est donc
> lié à la version du kernel (2.6.16-k7-smp dans mon cas)
> et à la façon dont le initrd a été généré
>
> Pas encore trouvé de solution, hélas.
>
> Pascal
>
>
> ALICE SECURITE ENFANTS
> Protégez vos enfants des dangers d'Internet en installant Sécurité
Enfants, le contrôle parental d'Alice.
> http://www.aliceadsl.fr/securitepc/default_copa.asp


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Ognibene
Le #9171171
Le lundi 05 juin 2006 à 15:38 +0200, noniin_debian a écrit :
Pourquoi tu utilises le noyau 2.6.16-k7-smp ? ... moi j'utilise
linux-image-2.6.16-1-686 (2.6.16-12) ... et je n'ai aucun problème, même
avec les noyaux antérieurs, les dma de mes disques durs sont tous activés.

djellel



Parce que j'ai un athlon 64x2, ça serait dommage
de ne pas profiter du deuxième core ;-)

Mais j'ai fini par résoudre mon problème en recompilant
mon noyau avec le pilote ide dma (uli je crois) en dur
en lieu de le mettre en module. Il y avait la solution de
reconstruire l'initrd avec le module, mais de toute
manière les headers du kernel 2.6.16-k7-smp semblaient
avoir un problème (pas moyen de réinstaller vmware avec).

Pascal


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme