Re: Wacom Graphire 3 / Mandrake 9.2

Le
gryken
Hubert wrote:

> Bonjour
>
> Je tente d'installer une tablette Wacom Graphire 3 usb sur une Mandrake
> 9.2. J'ai vérifié le chargements des modules nécessaires présents (hid,
> mousedev, input).
> J'ai ajouté les modules 'wacom' et 'evdev' dans /etc/modules pour les
> charger automatiquement au lancement de Linux avec la commande modprobe.
>
> J'ai dézippé 'wacom_drv.o' et je l'ai copié dans
> /usr/X11/lib/modules/input.
>
> J'ai ajouté dans /etc/X11/XF86Config-4 les éléments suivants :
> Section "Module"
> Load "wacom"
> EndSection
>
> Section "InputDevice"
> Identifier "stylus"
> Driver "wacom"
> Option "Device" "/dev/input/event0"
> Option "Type" "stylus"
> Option "Mode" "absolute"
> Option "USB" "on"
> Option "AlwaysCore" "on"
> EndSection
>
> Section "InputDevice"
> Identifier "eraser"
> Driver "wacom"
> Option "Device" "/dev/input/event0"
> Option "Type" "eraser"
> Option "Mode" "absolute"
> Option "USB" "on"
> Option "AlwaysCore" "on"
> EndSection
>
> Section "InputDevice"
> Identifier "cursor"
> Driver "wacom"
> Option "Device" "/dev/input/event0"
> Option "Type" "cursor"
> Option "Mode" "absolute"
> Option "USB" "on"
> Option "AlwaysCore" "on"
> EndSection
>
> Section "ServerLayout"
> InputDevice "stylus" "Alwayscore"
> InputDevice "eraser" "Alwayscore"
> InputDevice "cursor" "Alwayscore"
> EndSection
>
> Après avoir relancé une session graphique la tablette n'a aucune
> réaction ni avec sa souris, ni avec son stylet.
>
> Dans GIMP j'obtiens bien l'affichage d'une fenêtre des périphériques
> d'entrée avec cursor, stylus et eraser. Dans la fenêtre 'État du
> périphérique', seul 'Core Pointer' accepte un changement d'outil ; les
> trois outils de la tablettes sont figés.
>
> Je ne vois pas où ça coince.
>
> Pour complément d'information je vous soumet le résultat d'une recherche
> de 'wacom' dans dmesg et dans log/XFree86.0.log
>
> grep -i wacom /var/log/dmesg
> usb.c: registered new driver wacom
> wacom.c: v1.21.3 Vojtech Pavlik <vojtech@suse.cz>
> wacom.c: USB Wacom Graphire and Wacom Intuos tablet driver
> input,hiddev0: USB HID v1.00 Mouse [WACOM CTE-430-UV3.1-4] on usb1:3.0
>
> # grep -i wacom /var/log/XFree86.0.log
> (II) LoadModule: "wacom"
> (II) Loading /usr/X11R6/lib/modules/input/wacom_drv.o
> (II) Module wacom: vendor="The XFree86 Project"
> (II) Wacom driver level: 26 $
> (II) LoadModule: "wacom"
> (II) Reloading /usr/X11R6/lib/modules/input/wacom_drv.o
> (II) Wacom driver level: 26 $
> (II) XINPUT: Adding extended input device "cursor" (type: Wacom Cursor)
> (II) XINPUT: Adding extended input device "eraser" (type: Wacom Eraser)
> (II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
> (==) Wacom Kernel Input device name: "WACOM CTE-430-UV3.1-4"
> (==) Wacom tablet maximum X=0 maximum Y=0 X resolution=0 Y resolution=0
> suppress=0
> (==) Wacom tablet top X=0 top Y=0 bottom X=0 bottom Y=0
> (==) Wacom tablet top X=0 top Y=0 bottom X=0 bottom Y=0
> (==) Wacom tablet top X=0 top Y=0 bottom X=0 bottom Y=0
>
> Mes connaisances sont trop limités pour résoudre le problème et
> j'espère une aide bienveillante.
>
> Merci
>
> Hubert

Bonjour,

Je sais pas si ça peut aider, mais bon.
J'ai une Graphire2 et une mdk 9.2.
Dans le XF86Config-4, j'ai juste 2 différences :

InputDevice "stylus" ""
InputDevice "eraser" ""

Je ne peux pas en dire plus

A+
Gryken
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Hubert
Le #1435053
On Thu, 26 Aug 2004 19:32:54 +0200, gryken wrote:

J'ai une Graphire2 et une mdk 9.2.
Dans le XF86Config-4, j'ai juste 2 différences :

InputDevice "stylus" ""
InputDevice "eraser" ""

Merci pour ta réponse.

L'option "Alwayscore" n'a pas d'incidence facheuse dans le
fonctionnement de la tablette graphique. D'après la doc publiée sur le
site Léa, cette option a son importance pour utiliser l'outil en
permanence ; avec un champ vide "", on ne peut utiliser la tablette
qu'avec des applications comm Gimp. On a donc le choix de mettre
"Alwayscore" ou non.
J'ai d'ailleurs fait un essai avec les deux possibilités, sans résultat.
Retour à la case départ.

Hubert

Hubert
Le #1148796
On Thu, 26 Aug 2004 19:32:54 +0200, gryken wrote:

Section "ServerLayout"
InputDevice "stylus" "Alwayscore"
InputDevice "eraser" "Alwayscore"
InputDevice "cursor" "Alwayscore"
EndSection

Dans GIMP j'obtiens bien l'affichage d'une fenêtre des périphériques
d'entrée avec cursor, stylus et eraser. Dans la fenêtre 'État du
périphérique', seul 'Core Pointer' accepte un changement d'outil ; les
trois outils de la tablettes sont figés.


Je sais pas si ça peut aider, mais bon.
J'ai une Graphire2 et une mdk 9.2.
Dans le XF86Config-4, j'ai juste 2 différences :

InputDevice "stylus" ""
InputDevice "eraser" ""


Je crois savoir que les guillements vides apès InputDevice "stylus" ""
et InputDevice "eraser" "" signifies que l'utilisation du stylet et de la
gomme ne se font que dans une application spécifiques (comme Gimp).

Puisque ta tablette semble fonctionner, peut tu me dire si les outils dans
la fenêtre 'État du périphérique' sont tous accessibles ?

Dans la 'fenêtre des périphériques d'entrée' il y a un onglet 'clefs'
avec 32 lignes marquées 'désactivé'. Que doivent contenir ces lignes ?
Je n'ai trouvé aucune documentation sur l'utilisation de ces deux
fenêtres dans Gimp.

merci
Hubert


Poster une réponse
Anonyme