recherche dans une liste

Le
Erico
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci
Vos réponses
Trier par : date / pertinence
Daniel
Le #4214751
Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1Ñ;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci



Elliac
Le #4214681
Bonjour,

Attention à la référence :
=SI(A1=$D$1;B1;"")

Camille

"Daniel" wrote:

Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1Ñ;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci








Erico
Le #4365361
Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la première couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci


"Daniel"
Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1Ñ;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci







anonymousA
Le #4365351
Précise ta demande. Ce que te propose Daniel fait exactement ce que tu
dis. Mais comme ce n'est pas ce que tu souhaites, c'est ce que tu
demandes qui n'est pas précis.

A+

Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la première couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci


"Daniel"
Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1Ñ;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci










JB
Le #4365341
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Le code cherché est en G2 (Pomme)

code uil1!$A$2:$A$8
couleurs uil1!$B$2:$B$8

-Sélectionner D2:D8
=SI(ESTTEXTE(INDEX(couleurs;PETITE.VALEUR(SI(code=$G
$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code))))));
INDEX(couleurs;PETITE.VALEUR(SI(code=$G$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code)))));"")
Valider avec Maj+Ctrl+Entrée


JB

On 23 fév, 03:09, "Erico"
Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la première c ouleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci

"Daniel"



Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




jpthillard
Le #4365261
On 23 fév, 07:16, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Le code cherché est en G2 (Pomme)

code uil1!$A$2:$A$8
couleurs uil1!$B$2:$B$8

-Sélectionner D2:D8
=SI(ESTTEXTE(INDEX(couleurs;PETITE.VALEUR(SI(code=$G
$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code))))));
INDEX(couleurs;PETITE.VALEUR(SI(code=$G$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code)))));"")
Valider avec Maj+Ctrl+Entrée

JB

On 23 fév, 03:09, "Erico"


Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la première couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci

"Daniel"

Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -


JB,
Je m'immisce à l'échange en espérant que ce n'est pas déplacé.
Ce travail là m'intéresse, mais je voudrai faire apparaitre le
résultat dans une liste déroulante ( données/validation).
Est-ce possible?
Merci de ta réponse
JP




JB
Le #4365191
Bonjour,


http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Si la liste d'origine est triée:

CALER($B$2;EQUIV(G2;code;0)-1;;NB.SI(code;G2))

Si la liste d'origine n'est pas triée:

CALER($D$2;;;NB.SI($D$2:$D$8;"<>."))

JB

On 23 fév, 09:05, wrote:
On 23 fév, 07:16, "JB"




Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Le code cherché est en G2 (Pomme)

code uil1!$A$2:$A$8
couleurs uil1!$B$2:$B$8

-Sélectionner D2:D8
=SI(ESTTEXTE(INDEX(couleurs;PETITE.VALEUR(SI(code=$G
$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code))))));
INDEX(couleurs;PETITE.VALEUR(SI(code=$G$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code)))));"")
Valider avec Maj+Ctrl+Entrée

JB

On 23 fév, 03:09, "Erico"
Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la premiè re couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci

"Daniel"

Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte d es messages précédents -


- Afficher le texte des messages précédents -


JB,
Je m'immisce à l'échange en espérant que ce n'est pas déplacé.
Ce travail là m'intéresse, mais je voudrai faire apparaitre le
résultat dans une liste déroulante ( données/validation).
Est-ce possible?
Merci de ta réponse
JP- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -






jpthillard
Le #4365161
On 23 fév, 10:33, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Si la liste d'origine est triée:

CALER($B$2;EQUIV(G2;code;0)-1;;NB.SI(code;G2))

Si la liste d'origine n'est pas triée:

CALER($D$2;;;NB.SI($D$2:$D$8;"<>."))

JB

On 23 fév, 09:05, wrote:



On 23 fév, 07:16, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Le code cherché est en G2 (Pomme)

code uil1!$A$2:$A$8
couleurs uil1!$B$2:$B$8

-Sélectionner D2:D8
=SI(ESTTEXTE(INDEX(couleurs;PETITE.VALEUR(SI(code=$G
$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code))))));
INDEX(couleurs;PETITE.VALEUR(SI(code=$G$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code)))));"")
Valider avec Maj+Ctrl+Entrée

JB

On 23 fév, 03:09, "Erico"
Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la premi ère couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci

"Daniel"

Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -


JB,
Je m'immisce à l'échange en espérant que ce n'est pas déplacé.
Ce travail là m'intéresse, mais je voudrai faire apparaitre le
résultat dans une liste déroulante ( données/validation).
Est-ce possible?
Merci de ta réponse
JP- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -


Génial, je sens que je vais retoucher certaines de mes feuilles.
Encore merci
JP






Erico
Le #4362391
La matrice semble fonctionner seulement un en dessous de l'autre.

Mes cellules pour placer ces valeurs sont séparées à part comme dans B15,
B26, B27, B46, P15 etc....

Ma valeur choisit est dans O2 (ex. quel fruit)
Ma liste détaillé est de AI50 à AJ213 (des fruits dans AI et les couleurs
dans AJ)




On 23 fév, 10:33, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Si la liste d'origine est triée:

ÞCALER($B$2;EQUIV(G2;code;0)-1;;NB.SI(code;G2))

Si la liste d'origine n'est pas triée:

ÞCALER($D$2;;;NB.SI($D$2:$D$8;"<>."))

JB

On 23 fév, 09:05, wrote:



On 23 fév, 07:16, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Le code cherché est en G2 (Pomme)

code þuil1!$A$2:$A$8
couleurs þuil1!$B$2:$B$8

-Sélectionner D2:D8
=SI(ESTTEXTE(INDEX(couleurs;PETITE.VALEUR(SI(code=$G
$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code))))));
INDEX(couleurs;PETITE.VALEUR(SI(code=$G$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code)))));"")
Valider avec Maj+Ctrl+Entrée

JB

On 23 fév, 03:09, "Erico"
Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la première
couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci

"Daniel"

Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1Ñ;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -


JB,
Je m'immisce à l'échange en espérant que ce n'est pas déplacé.
Ce travail là m'intéresse, mais je voudrai faire apparaitre le
résultat dans une liste déroulante ( données/validation).
Est-ce possible?
Merci de ta réponse
JP- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -


Génial, je sens que je vais retoucher certaines de mes feuilles.
Encore merci
JP






Erico
Le #4361881
Bonjour a tous,

J'ai finalement trouver celle-ci qui semble bien fonctionné.

Par contre, quand je n'Ai plus rien dans la liste, il affiche un message
d'Erreur "#NOMBRE!­­"#NOMBRE!
Comment je peux l'éliminer?

Merci

=SI(ESTTEXTE(INDEX(Couleurs;PETITE.VALEUR(SI(Code=$O$2;EQUIV(Couleurs;Couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(Code))))));INDEX(Couleurs;PETITE.VALEUR(SI(Code=$O$2;EQUIV(Couleurs;Couleurs;0);"");LIGNE(INDIRECT("1:"&LIGNES(Code)))));"")




"Erico"
La matrice semble fonctionner seulement un en dessous de l'autre.

Mes cellules pour placer ces valeurs sont séparées à part comme dans B15,
B26, B27, B46, P15 etc....

Ma valeur choisit est dans O2 (ex. quel fruit)
Ma liste détaillé est de AI50 à AJ213 (des fruits dans AI et les couleurs
dans AJ)




On 23 fév, 10:33, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Si la liste d'origine est triée:

ÞCALER($B$2;EQUIV(G2;code;0)-1;;NB.SI(code;G2))

Si la liste d'origine n'est pas triée:

ÞCALER($D$2;;;NB.SI($D$2:$D$8;"<>."))

JB

On 23 fév, 09:05, wrote:



On 23 fév, 07:16, "JB"
Bonjour,

http://boisgontierj.free.fr/fichiers/Matriciel/RechercheTousCode.xls

Le code cherché est en G2 (Pomme)

code þuil1!$A$2:$A$8
couleurs þuil1!$B$2:$B$8

-Sélectionner D2:D8
=SI(ESTTEXTE(INDEX(couleurs;PETITE.VALEUR(SI(code=$G
$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code))))));
INDEX(couleurs;PETITE.VALEUR(SI(code=$G$2;EQUIV(couleurs;couleurs;
0);"");LIGNE(INDIRECT("1:"&LIGNES(code)))));"")
Valider avec Maj+Ctrl+Entrée

JB

On 23 fév, 03:09, "Erico"
Je ne pense pas que ce soit le bon.

Je veux que dans ma première cellule, me faire afficher la première
couleur
de la pomme
le deuxième, me faire afficher la deuxième couleur de pomme
le troisième, me faire afficher la troisieme couleur de la pomme
Le quatrieme, s'il y n'y a pas de couleur, rien afficher.
Ainsi de suite....

Merci

"Daniel"

Bonjour.
Si tes données sont en colonne A et B, et "pomme" en D1 :
=SI(A1Ñ;B1;"")
à recopier vers le bas.
Cordialement.
Daniel
"Erico" Oz$
Bonjour,

J'aimerais avoir une fonction suivant avec une liste comme-ci:

pomme rouge
pomme verte
pomme jaune
piment vert
piment jaune
piment orange
banane jaune

j'ai une cellule qui dit "pomme"

et j'aimerais faire apparaitre tous les couleur de pomme
rouge
verte
jaune
vide
vide
vide

Merci- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -


JB,
Je m'immisce à l'échange en espérant que ce n'est pas déplacé.
Ce travail là m'intéresse, mais je voudrai faire apparaitre le
résultat dans une liste déroulante ( données/validation).
Est-ce possible?
Merci de ta réponse
JP- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -


Génial, je sens que je vais retoucher certaines de mes feuilles.
Encore merci
JP










Publicité
Poster une réponse
Anonyme