recherche dans tableau

Le
Manu
Bonjour tous,

Je cherche 2 choses dans Excel
1. le moyen d'obtenir partir d'une valeur donne quel
numro de ligne on retrouve cette valeur dans un tableau
donn
2. le moyen de vrifier si une valeur donne apparait dans
un tableau ou non

Exemple pour 1.
Soit un tableau tout simple sous la forme d'une colonne
qui contient les valeurs suivantes
julien / sbastien / marcel / francis / emmanuel
Je souhaite que Excel puisse me dire que le N de ligne
pour la valeur "marcel" dans le tableau est 3
et qu'il me renvoie "#NA" pour la valeur "daniel"

Exemple pour 2.
Soit le tableau dans l'exemple prcdent
Je souhaite que la valeur "marcel" renvoie VRAI
et que la valeur "daniel" renvoie FAUX

Merci par avance toute personne qui me fournirait la
solution

Manu
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Ellimac
Le #119982
Bonjour,

1) =LIGNE(INDEX(plage;EQUIV(B1;plage;0)))
2) =SI(ESTNA(RECHERCHEV(B1;plage;1;0));FAUX;VRAI)

Camille

-----Message d'origine-----
Bonjour à tous,

Je cherche 2 choses dans Excel
1. le moyen d'obtenir à partir d'une valeur donnée à quel
numéro de ligne on retrouve cette valeur dans un tableau
donné
2. le moyen de vérifier si une valeur donnée apparait
dans

un tableau ou non

Exemple pour 1.
Soit un tableau tout simple sous la forme d'une colonne
qui contient les valeurs suivantes
julien / sébastien / marcel / francis / emmanuel
Je souhaite que Excel puisse me dire que le N° de ligne
pour la valeur "marcel" dans le tableau est 3
et qu'il me renvoie "#NA" pour la valeur "daniel"

Exemple pour 2.
Soit le tableau dans l'exemple précédent
Je souhaite que la valeur "marcel" renvoie VRAI
et que la valeur "daniel" renvoie FAUX

Merci par avance à toute personne qui me fournirait la
solution

Manu
.



bibliote offline Hors ligne
Le #24611531
Le jeudi 17 Juillet 2003 à 17:50 par Manu :
Bonjour tous,

Je cherche 2 choses dans Excel
1. le moyen d'obtenir partir d'une valeur donne quel
numro de ligne on retrouve cette valeur dans un tableau
donn
2. le moyen de vrifier si une valeur donne apparait dans
un tableau ou non

Exemple pour 1.
Soit un tableau tout simple sous la forme d'une colonne
qui contient les valeurs suivantes
julien / sbastien / marcel / francis / emmanuel
Je souhaite que Excel puisse me dire que le N de ligne
pour la valeur "marcel" dans le tableau est 3
et qu'il me renvoie "#NA" pour la valeur "daniel"

Exemple pour 2.
Soit le tableau dans l'exemple prcdent
Je souhaite que la valeur "marcel" renvoie VRAI
et que la valeur "daniel" renvoie FAUX

Merci par avance toute personne qui me fournirait la
solution

Manu


Bonjour,

J'ai un tableau sur une feuille 1 contenant la liste de tous mes contacts (dans une colonne A) et sur une feuille 2, un tableau contenant certains contacts ayant un mail (col A) et leurs mails dans la colonne B. Je souhaite que dans mon premier tableau le mail des contacts qui ont un mail soit repporté dans la colonne B.

ça fait un bout de temps que je planche là dessus... vous m'aideriez beaucoup!

Merci.
Poster une réponse
Anonyme