Recherche valeur dans un tableau

Le
FREDSCOPE
Bonsoir à tous.

Je suis à la recherche d’une formule permettant de chercher un=
e valeur dans un tableau à double entrée. La feuille est aliment=
ée régulièrement sans que le nombre de sections analytiques =
soit fixe. Le nombre de ligne est fixe.

En lignes : les comptes comptables
En colonnes : les sections analytiques. Le nombre de section est variable e=
n fonction de chaque extraction.
A l’intersection des lignes et des colonnes la valeur correspondant=
à la valeur affectée à chaque compte pour une section donn=
ée.

Dans une autre feuille, on saisit en B1 le compte comptable et en B2, la se=
ction analytique.

Je souhaite renvoyer en B3 la valeur renvoyée à l’interse=
ction des lignes et colonnes en critères.

J’ai essayé de travailler avec les fonctions ÉQUIV et IND=
EX mais je n’arrive pas à retrouver la position de la colonne =
de la section analytique.

Je sèche complètement. Je souhaite utiliser une fonction Excel sa=
ns VBA.

Si quelqu’un pouvait me donner une piste sur les fonctions Excel =
à utiliser.

Merci d’avance.

Fred
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #26545727
Bonjour,
En supposant que j'ai compris la question...
Fichier exemple : https://www.cjoint.com/c/JEhxaX8PkSj
MichD
FREDSCOPE
Le #26545728
Bonjour MichD,
Ca fonctionne à merveille. Merci beaucoup. Ca semble si simple quand o n voit le résultat.
Pour mon info personnelle, à quoi sert le signe @ devant la fonction d écaler dans la formule ?
Encore merci pour votre aide
Fred
MichD
Le #26545729
Le 07/05/20 à 21:27, FREDSCOPE a écrit :
à quoi sert le signe @ devant la fonction décaler dans la formule

Tu dois avoir une version Office 365...
Sur une installation avec DVD d'installation, ce "@" n'existe pas, ce
n'est pas moi qui l'ai inséré. Je ne me suis jamais demandé à quoi
servait ce symbole qu'ajoutait Microsoft Office 365.
Un début d'explication ici :
https://www.quora.com/What-does-mean-in-an-Excel-formula
MichD
FREDSCOPE
Le #26545741
Bonjour MichD,
J’ai pu constaté qu’en enlevant le @ de la formule, ça fonctionnait aussi.
J’ai lu le lien. Je suis trop novice pour tout comprendre mais je v ois à peut près à quoi ca sert.
Merci encore pour ton aide
Bonne journée
Fred
Michel__D
Le #26545751
Bonjour,
Si je peux me permettre on peut utiliser la formule ci-dessous (plus besoin d'adapter le nombre de
ligne/colonne) :
=SIERREUR(DECALER(Feuil1!$A$1;EQUIV($B$1;Feuil1!A:A;0)-1;EQUIV($B$2;Feuil1!1:1;0)-1;1;1);"")
Péhemme
Le #26545755
Bonjour Fred,
Tu vois, ici des gourous prennent soin de toi... en français.
;-)
Michel
"FREDSCOPE" a écrit dans le message de groupe de discussion :

Bonsoir à tous.
Je suis à la recherche d’une formule permettant de chercher une valeur dans
un tableau à double entrée. La feuille est alimentée régulièrement sans que
le nombre de sections analytiques soit fixe. Le nombre de ligne est fixe.
En lignes : les comptes comptables
En colonnes : les sections analytiques. Le nombre de section est variable en
fonction de chaque extraction.
A l’intersection des lignes et des colonnes la valeur correspondant à la
valeur affectée à chaque compte pour une section donnée.
Dans une autre feuille, on saisit en B1 le compte comptable et en B2, la
section analytique.
Je souhaite renvoyer en B3 la valeur renvoyée à l’intersection des lignes et
colonnes en critères.
J’ai essayé de travailler avec les fonctions ÉQUIV et INDEX mais je n’arrive
pas à retrouver la position de la colonne de la section analytique.
Je sèche complètement. Je souhaite utiliser une fonction Excel sans VBA.
Si quelqu’un pouvait me donner une piste sur les fonctions Excel à utiliser.
Merci d’avance.
Fred
FREDSCOPE
Le #26545767
J’ai vu. Et avec quelle efficacité. Merci à tous pour vot re aide précieuse.
FREDSCOPE
Le #26545766
Cette optimisation va bien au-delà de mes attentes. Merci
FREDSCOPE
Le #26546474
Bonjour,
La formule proposée par Michel fonctionne à merveille. Les utilis ateurs utilisent cette nouvelle fonction tous les jours ou presque mais ils en veulent toujours plus ;) Ils me demandent s’il serait possible d’adapter la formule afin qu’en saisissant la section analy tique 78* dans le critère de sélection que la formule renvoie la somme de toutes les sections 78* pour le compte saisi en deuxième crit ère.
J’ai essayé de modifier la formule en insérant un somme.s i mais ca ne fonctionne pas.
Merci pour votre aide, si vous avez une piste.
MichD
Le #26546496
Le 14/05/20 à 22:16, FREDSCOPE a écrit :
Bonjour,
La formule proposée par Michel fonctionne à merveille. Les utilisateurs utilisent cette nouvelle fonction tous les jours ou presque mais ils en veulent toujours plus ;) Ils me demandent s’il serait possible d’adapter la formule afin qu’en saisissant la section analytique 78* dans le critère de sélection que la formule renvoie la somme de toutes les sections 78* pour le compte saisi en deuxième critère.
J’ai essayé de modifier la formule en insérant un somme.si mais ca ne fonctionne pas.
Merci pour votre aide, si vous avez une piste.


Essaie ceci :
=SIERREUR(SOMME(DECALER(Feuil1!$A$1;;EQUIV($A$1;Feuil1!1:1;0)-1;NBVAL(Feuil1!A:A)));"")
MichD
Publicité
Poster une réponse
Anonyme