Redémarrage de Samba impossible.

Le
pascal
Salut,

Si je veut redémarrer mon serveur SAMBA (avec 2.2 ou 3.0), celui-ci
m'indique bien qu'il à démarrer, mais dés que je veut y acceder, les
messages d'erreur pleuvent, comme quoi on ne peut joindre le serveur !

smbd et nmbd sont bien présent en mémoire.

Je doit rebooter le serveur, et en pleine journée cela fait désorder !

J'ai une Mdk 8.0 plutôt LFS maintenant, à jour pratiquement partout.

Avez vous une piste ?
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Khanh-Dang
Le #1524152
Si je veut redémarrer mon serveur SAMBA (avec 2.2 ou 3.0), celui-ci
m'indique bien qu'il à démarrer, mais dés que je veut y acceder, les
messages d'erreur pleuvent, comme quoi on ne peut joindre le serveur !


Avez vous une piste ?


Bin, pour avoir une piste, il faudrait des indices. En l'occurence, il
serait évidemment interressant d'avoir un petit aperçu des messages
d'erreur. Nous aussi on veut une pluie de messages ! ;)

pascal
Le #1049917

Si je veut redémarrer mon serveur SAMBA (avec 2.2 ou 3.0), celui-ci
m'indique bien qu'il à démarrer, mais dés que je veut y acceder, les
messages d'erreur pleuvent, comme quoi on ne peut joindre le serveur !


Avez vous une piste ?



Bin, pour avoir une piste, il faudrait des indices. En l'occurence, il
serait évidemment interressant d'avoir un petit aperçu des messages
d'erreur. Nous aussi on veut une pluie de messages ! ;)


Impossible de redémarrer en production, donc hier soir par ssh,
/etc/rc.d/init.d/smb stop, puis /etc/rc.d/init.d/smb start.

Avec Samba, tout semble Ok.

Ce matin, les postes 2000 ont démarrés sur le domaine, les partages Ok.
Dans les propriété des fichiers, pour les sécurité, pas de nom de
groupe, mais un numéro SID (ou RID).

Les poste NT4 n'ont pas trouver le domaine, et le serveur.
Il répondent que le serveur n'est pas configurer pour les transactions.

Dans les log des postes ont peut lire sur plusieurs ligne :
[2004/04/21 08:04:47, 0] smbd/service.c:make_connection_snum(670)
'/root/tmp' does not exist or is not a directory, when connecting to
[IPC$]


g.patel
Le #1049729
On Wed, 21 Apr 2004 09:05:47 +0200, pascal
Dans les log des postes ont peut lire sur plusieurs ligne :
[2004/04/21 08:04:47, 0] smbd/service.c:make_connection_snum(670)
'/root/tmp' does not exist or is not a directory, when connecting to
[IPC$]


le script de démarrage de Samba doit positionner TMPDIR
sur un répertoire accessible, comme ceci (extrait du script
courant de la Mandrake) :

start() {
# If CUPS is used as printing system, reload smb after a 1
minute delay
# to allow the printers to appear properly as samba shares.
if killall -0 cupsd 2>/dev/null; then
( sleep 60 && killproc smbd -HUP 1>/dev/null) &
fi
export TMPDIR="/var/tmp"
gprintf "Starting SMB services: "
daemon smbd -D


Gérard Patel

pascal
Le #1049350
On Wed, 21 Apr 2004 09:05:47 +0200, pascal

Dans les log des postes ont peut lire sur plusieurs ligne :
[2004/04/21 08:04:47, 0] smbd/service.c:make_connection_snum(670)
'/root/tmp' does not exist or is not a directory, when connecting to
[IPC$]



le script de démarrage de Samba doit positionner TMPDIR
sur un répertoire accessible, comme ceci (extrait du script
courant de la Mandrake) :

start() {
# If CUPS is used as printing system, reload smb after a 1
minute delay
# to allow the printers to appear properly as samba shares.
if killall -0 cupsd 2>/dev/null; then
( sleep 60 && killproc smbd -HUP 1>/dev/null) &
fi
export TMPDIR="/var/tmp"
gprintf "Starting SMB services: "
daemon smbd -D


Gérard Patel


Donc TMPDIR est déclarer uniquement au boot.
Il pointe en effet sur /root/tmp actuellement.


g.patel
Le #1524119
On Wed, 21 Apr 2004 13:32:22 +0200, pascal
Donc TMPDIR est déclarer uniquement au boot.


?

Il pointe en effet sur /root/tmp actuellement.


oui, c'est probablement le problème.

Gérard Patel

Publicité
Poster une réponse
Anonyme