Référence à un tableau

Le
bobj
Bonjour,

soit les colonnes A et B (fruit, prix) contenant
Pomme 10
Poire 12
Banane 6
Fraise 18

Soit la colonne D (panier) contenant
Pomme
Pomme
Pomme
Fraise
Poire
Pomme

Comment faire la somme des prix du panier sans colonne intermédiaire
(résultat attendu = 70 (10+10+10+18+12+10)
j'avais pensé à
{=SOMME(DECALER(B1;EQUIV(D1:D6;A1:A4;0)-1;))}
mais cela ne fonctionne pas (Decaler fonctionne t-il avec les formules
matricielles ?)

Aucun problème pour le faire avec une colonne intermédiaire, mais je
souhaite savoir s'il est possible de le faire sans.

Merci

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Jacquouille
Le #25429252
Bonjour
Col A1:Ax = liste des fruits et en B, leur prix
Tu baptises B1=prixPomme
B2 = prixPoire
etc
D1 à D100 est baptisé panier

- Quelque part
=(NB.SI(panier;a1)*prixPomme)+(NB.SI(panier;a2)*prixPoire)+.....
ce qui revient à compter le nombre de fois que le mot "pomme" est présent
dans la colonne panier et à le multiplier par le prix des pommes.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"bobj" a écrit dans le message de groupe de discussion :
51a09719$0$3739$

Bonjour,

soit les colonnes A et B (fruit, prix) contenant
Pomme 10
Poire 12
Banane 6
Fraise 18

Soit la colonne D (panier) contenant
Pomme
Pomme
Pomme
Fraise
Poire
Pomme

Comment faire la somme des prix du panier sans colonne intermédiaire
(résultat attendu = 70 (10+10+10+18+12+10)
j'avais pensé à
{=SOMME(DECALER(B1;EQUIV(D1:D6;A1:A4;0)-1;))}
mais cela ne fonctionne pas (Decaler fonctionne t-il avec les formules
matricielles ?)

Aucun problème pour le faire avec une colonne intermédiaire, mais je
souhaite savoir s'il est possible de le faire sans.

Merci
bobj
Le #25429262
Merci pour cette solution mais on m'a proposé celle ci qui me convient
parfaitement :

=sommeprod(nb.si(Panier;Fruits)*Prix)

bobj

Le 25/05/2013 21:04, Jacquouille a écrit :
Bonjour
Col A1:Ax = liste des fruits et en B, leur prix
Tu baptises B1=prixPomme
B2 = prixPoire
etc
D1 à D100 est baptisé panier

- Quelque part
=(NB.SI(panier;a1)*prixPomme)+(NB.SI(panier;a2)*prixPoire)+.....
ce qui revient à compter le nombre de fois que le mot "pomme" est
présent dans la colonne panier et à le multiplier par le prix des pommes.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"bobj" a écrit dans le message de groupe de discussion :
51a09719$0$3739$

Bonjour,

soit les colonnes A et B (fruit, prix) contenant
Pomme 10
Poire 12
Banane 6
Fraise 18

Soit la colonne D (panier) contenant
Pomme
Pomme
Pomme
Fraise
Poire
Pomme

Comment faire la somme des prix du panier sans colonne intermédiaire
(résultat attendu = 70 (10+10+10+18+12+10)
j'avais pensé à
{=SOMME(DECALER(B1;EQUIV(D1:D6;A1:A4;0)-1;))}
mais cela ne fonctionne pas (Decaler fonctionne t-il avec les formules
matricielles ?)

Aucun problème pour le faire avec une colonne intermédiaire, mais je
souhaite savoir s'il est possible de le faire sans.

Merci
Jacquouille
Le #25429372
Bonsoir
Le but de ce forum est de rendre le demandeur heureux, pas d'imposer sa
vision des choses ou sa formule....
Si Tarzan est heureux, alors ça va. -))



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"bobj" a écrit dans le message de groupe de discussion :
51a10faf$0$2106$

Merci pour cette solution mais on m'a proposé celle ci qui me convient
parfaitement :

=sommeprod(nb.si(Panier;Fruits)*Prix)

bobj

Le 25/05/2013 21:04, Jacquouille a écrit :
Bonjour
Col A1:Ax = liste des fruits et en B, leur prix
Tu baptises B1=prixPomme
B2 = prixPoire
etc
D1 à D100 est baptisé panier

- Quelque part
=(NB.SI(panier;a1)*prixPomme)+(NB.SI(panier;a2)*prixPoire)+.....
ce qui revient à compter le nombre de fois que le mot "pomme" est
présent dans la colonne panier et à le multiplier par le prix des pommes.
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"bobj" a écrit dans le message de groupe de discussion :
51a09719$0$3739$

Bonjour,

soit les colonnes A et B (fruit, prix) contenant
Pomme 10
Poire 12
Banane 6
Fraise 18

Soit la colonne D (panier) contenant
Pomme
Pomme
Pomme
Fraise
Poire
Pomme

Comment faire la somme des prix du panier sans colonne intermédiaire
(résultat attendu = 70 (10+10+10+18+12+10)
j'avais pensé à
{=SOMME(DECALER(B1;EQUIV(D1:D6;A1:A4;0)-1;))}
mais cela ne fonctionne pas (Decaler fonctionne t-il avec les formules
matricielles ?)

Aucun problème pour le faire avec une colonne intermédiaire, mais je
souhaite savoir s'il est possible de le faire sans.

Merci
Poster une réponse
Anonyme