Remplacer un pilote de disque dur sous Windows NT4

Le
Le Gaulois
Bonjour,

j'ai une machine équipée uniquement de disques durs SCSI et
fonctionnant sous Windows NT4 server.
J'ai remplacé la carte contrôleur SCSI équipée d'un chip 53C895
par une autre équipée d'un chip 53C896 qui est la version double
canal du précédent.
Au redémarrage j'ai un splendide écran bleu "inaccessible boot device"
et on me conseille de contacter l'administrateur système.
J'ai tenté de démarrer en mode VGA, mais ça ne change rien.
J'ai tenté de démarrer sur le Windows de secours (installation
minimale), même résultat.

Y a-t-il un moyen de remplacer le pilote de la carte contrôleur
autrement qu'en réinstallant Windows + tout les pilotes, tous
les patches, toutes les applications ?

Celui qui me dit "Va dans le panneau de configuration "
je lui botte le c.. . Si on ne peut pas booter on ne risque
pas d'aller dans le panneau de configuration.

Le Windows de secours est installé sur une partition FAT16,
je peux éventuellement y accéder depuis MS-DOS.

Merci.
Vos réponses
Trier par : date / pertinence
Dominique Ottello
Le #14003261
Le Gaulois
J'ai remplacé la carte contrôleur SCSI équipée d'un chip 53C895
par une autre équipée d'un chip 53C896 qui est la version double
canal du précédent.



Ayant été confronté à un problème similaire (Remplacement de carte
Adaptec 2940UW2 par Adaptec 29160N), la seule solution que j'avais alors
trouvé pour ne pas être obligé de tout réinstaller était :

- Remettre carte d'origine et vérifier que tout fonctionne.
- Installer *en plus* la nouvelle carte dans un autre connecteur
- Relancer la machine pour installer les pilotes de la nouvelle carte
- Redémarrer pour vérifier que tout fonctionne
- Arrêt machine
- Enlever l'ancienne carte et connecter les disques sur la nouvelle
sans la changer de connecteur
- Redémarrer
et .... ça avait fonctionné parfaitement.

--
Aujourd'hui, l'idéal du progrès est remplacé par l'idéal de l'innovation :
il ne s'agit pas que ce soit mieux, il s'agit seulement que ce soit nouveau,
même si c'est pire qu'avant et cela de toute évidence. Montherlant
Technologie aéronautique : http://aviatechno.free.fr
Le Gaulois
Le #14003181
Dominique Ottello a écrit :

> J'ai remplacé la carte contrôleur SCSI équipée d'un chip 53C895
> par une autre équipée d'un chip 53C896 qui est la version double
> canal du précédent.

Ayant été confronté à un problème similaire (Remplacement de carte
Adaptec 2940UW2 par Adaptec 29160N), la seule solution que j'avais alors
trouvé pour ne pas être obligé de tout réinstaller était :

- Remettre carte d'origine et vérifier que tout fonctionne.
- Installer *en plus* la nouvelle carte dans un autre connecteur
- Relancer la machine pour installer les pilotes de la nouvelle carte
- Redémarrer pour vérifier que tout fonctionne
- Arrêt machine
- Enlever l'ancienne carte et connecter les disques sur la nouvelle
sans la changer de connecteur
- Redémarrer
et .... ça avait fonctionné parfaitement.



J'y ai pensé après avoir posé la question.
C'est ce que j'ai fait et ça fonctionne, mais je me demande
comment je m'en serai sorti si le changement de carte avait
été dû à une panne de l'ancienne. Il faut vraiment trouver
exactement le même modèle en remplacement. Windows n'est pas
capable de discerner que 53C895 ou 53C896 c'est kif kif et
ça pourrait parfaitement fonctionner avec les mêmes pilotes
comme c'est la cas sous DOS ou Linux.

Merci.
Ascadix
Le #14003161
Entre la chaise et le clavier de Le Gaulois, viennent de surgir les mots que
voici:


Dominique Ottello a écrit :

J'ai remplacé la carte contrôleur SCSI équipée d'un chip 53C895
par une autre équipée d'un chip 53C896 qui est la version double
canal du précédent.



Ayant été confronté à un problème similaire (Remplacement de carte
Adaptec 2940UW2 par Adaptec 29160N), la seule solution que j'avais
alors trouvé pour ne pas être obligé de tout réinstaller était :

- Remettre carte d'origine et vérifier que tout fonctionne.
- Installer *en plus* la nouvelle carte dans un autre connecteur
- Relancer la machine pour installer les pilotes de la nouvelle carte
- Redémarrer pour vérifier que tout fonctionne
- Arrêt machine
- Enlever l'ancienne carte et connecter les disques sur la nouvelle
sans la changer de connecteur
- Redémarrer
et .... ça avait fonctionné parfaitement.



J'y ai pensé après avoir posé la question.
C'est ce que j'ai fait et ça fonctionne, mais je me demande
comment je m'en serai sorti si le changement de carte avait
été dû à une panne de l'ancienne. Il faut vraiment trouver
exactement le même modèle en remplacement. Windows n'est pas
capable de discerner que 53C895 ou 53C896 c'est kif kif et
ça pourrait parfaitement fonctionner avec les mêmes pilotes
comme c'est la cas sous DOS ou Linux.



Avec certains controleur, j'ai utilisé avec "succés" une méthode "bourin".

- tu te débrouille comme tu peut pour accéder au disque ( genre démonter /
mettre en esclave d'une autre machine
- tu répére le .SYS de l'ancien driver
- tu le met de coté
- tu renome le driver du nouveau controleur avec le nom de l'ancien
- tu remplace le fichier
- tu reboot avec

ça marche pas à 100 % mais assez souvent quand même

il faut finir la manip une fois booté en effectuant la manip de mise à jour
/ remplacement proprement


--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça arrive.
tu re
Nina Popravka
Le #14003131
On Sat, 30 Sep 2006 20:03:29 +0200, Le Gaulois wrote:

C'est ce que j'ai fait et ça fonctionne, mais je me demande
comment je m'en serai sorti si le changement de carte avait
été dû à une panne de l'ancienne.


Disquette de boot...
ntdetect.com, ntldr, boot.ini (qui normalement est pareil), et driver
carte scsi, renommé ntbootdd.sys
--
Nina
Publicité
Poster une réponse
Anonyme