Réponse à SLD concernant la WB et les différences d'exposition

Le
René
Bon, j'ai fait une première série de photos du mur où j'ai p=
lacé une feuille
blanche avec une rectangle noir. Tout ajustement d'éclairage et d'apn =
sur
manuel et constant. Et la balance des blancs constante sur 6000.

A l'oeil toutes les photos semblent identiques. Je positionne un point
de contrôle dans le rectangle hum au verso de la feuille il y =
a du
texte qui parait peut-être en transparence

Seconde série avec une carte bien opaque imprimée de motifs color=
és qui
permettrons de positionner mes points de contrôle sur une zone blanche=
.

Sur la dizaine de photos les points de contrôle positionnés dans =
la même
région qui semble bien unie révèlent des variations de 6 uni=
tés (sur 255)
pour chacune des 3 couleurs.

Je ne suis probablement pas sur le même pixel. Un agrandissement maxim=
um à
1600 montre les pixels et confirme bien qu'il y a des différences infi=
mes
mais bien réelles.

La recharge des flashes prends environ 1 seconde. Mon temps de pose est
sur 1/160. J'augment le temps à 1/30 pour une nouvelle série de 5=
photos
à toute les 2 secondes environ et de 5 autres photos pour lesquelles
je laisse un temps de recharge d'environ 10 secondes.

Ce nouveau lot de photos ne fait pas de différences. Les moyennes des=

variations sont entre 5 et 6.

Dans PS les parties d'une photo placées sur une photo de réf=
rence
montre bien ces variations de nuances. Il s'agit de coupe droite alors
qu'habituellement il est normal d'adoucir et de rendre transparent les
bords d'une superposition d'images. Dans le travail à l'origine de ces=

tests les coupent étant parallèles un adoucissement aurait cr=
é un effet
de vagues.

J'en conclu que cet ensemble flashes et apn donne une précision des co=
uleurs
de + ou - 3 sur 255. Moins de 2,5 %.

Tests faits avec mon D700. Un jour je recommencerai avec le Z6.

Je vous dispense du 1.43 Go de fichiers au final sans intérêt.

René
Vos réponses
Trier par : date / pertinence
efji
Le #26547994
Le 03/06/2020 à 06:53, René a écrit :
Sur la dizaine de photos les points de contrôle positionnés dans la même
région qui semble bien unie révèlent des variations de 6 unités (sur 255)
pour chacune des 3 couleurs.

Et sur la même photo, quelle est la variabilité dans cette région ?
C'est le premier test à faire. Normalement la pipette sur un pixel n'est
pas une bonne idée. Il vaut mieux prendre la moyenne sur quelques pixels
contigus.
--
F.J.
efji
Le #26548007
Le 03/06/2020 à 11:19, René a écrit :
Le mercredi 3 juin 2020 02:22:04 UTC-4, efji a écrit :
Le 03/06/2020 à 06:53, René a écrit :
Sur la dizaine de photos les points de contrôle positionnés dans la même
région qui semble bien unie révèlent des variations de 6 unités (sur 255)
pour chacune des 3 couleurs.

Et sur la même photo, quelle est la variabilité dans cette région ?
C'est le premier test à faire. Normalement la pipette sur un pixel n'est
pas une bonne idée. Il vaut mieux prendre la moyenne sur quelques pixels
contigus.
--
F.J.

En réalité le problème n'a rien à voir avec le point de contrôle.
J'ai fait une copie d'écran PNG du montage de 4 NEF dans Nikon Capture NX2.
Aucune opération de modification. C'est le Lien 1
https://www.cjoint.com/doc/20_06/JFdiDRrZrFE_2020-06-03-04-00-32-une-R%C3%A8gle-pour-Windows.png
Les fenêtres des 4 photos sont réduites sur le contour du point de
contrôle et chacune agrandie au maximum.
Les points de contrôle apparaissent seulement lorsque le curseur est sur
l'image, donc non visibles sur l'image fournie. La position était juste
au dessus du 1200 de la règle, idem à chaque cas.

C'est complètement tordu de faire ça.
Il faut une image unie sinon tu mesures n'importe quoi.
En plus ce sont des NEF. Sont-ils traduits de façon identique ?
N'y a-t-il pas un réglage "Auto WB" caché quelque part dans le logiciel
qui traite le raw ?
Si tu veux en avoir le coeur vraiment net, fais la même chose en
photographiant une feuille blanche avec WB fixe et exposition manuelle.
Ensuite tu mesures la moyenne des rvb sur une zone d'une dizaine de
pixels. Si tu as toujours des variations aussi grandes c'est qu'il y a
un vrai problème.
Attention quand même : il faut retrancher les variations d'exposition
car un excellent obturateur n'a pas une précision meilleure que 5%,
voire 10%. Donc si tu as une image avec 100 100 100 et une autre avec
105 105 105 c'est tout à fait normal. En revanche 100 100 100 et 95 105
100 c'est plus problématique.
Qu'importe le point, il est bien visible que les photos ont des nuances
différentes l'une l'autre et par le crénelage et par les nuances précises
des pixels aux même positions.
Mon problème est bien visible dans la photo du Lien 2.
https://www.cjoint.com/doc/20_06/JFdiFgHkTrE_2020-06-03-04-24-24-une-R%C3%A8gle-pour-Windows.png

Ce sont des variations de densité plus que de colorimétrie. Hugin prend
tout ça en charge de façon parfaite en principe.
Copie d'écran PNG du montage fait dans PS à partir des TIFF 16 bits.
Cette photo est composée d'une photo référence au fond et de 3 découpes
verticales disjointes tirées des 3 autres photos et posées sur la première.
Le première découpe est identique à la photo référence, non visible, elle
est à gauche et se termine au 0 de la règle. La seconde découpe va de 80 à 260. Elle est visiblement plus pâle. La découpe 3 va de 291 à 519 est sa
couleur se situe entre celle du fond et celle de la découpe 2.
Si je place ces 4 photos chacune sur un quart de l'écran elle ont l'air
identiques.... pour presque tous les yeux. Mais ce n'est pas le cas.
Mon D700 date et le logiciel aussi. Je verrai avec le Z6.
René



--
F.J.
Publicité
Poster une réponse
Anonyme