Retour d'expérience portage application windows vers ubuntu/debian

Le
jean-michel bain-cornu
Bonjour,
J'ai eu à le faire cette semaine.
-pas de pb particulier avec python
-sous debian, obligé de compiler pour avoir la 2.4 :-(
-sous ubuntu, la 2.4 est fournie; cherrypy semble aussi fourni, mais
incomplet (!?), l'install classique fonctionnant bien (python setup.py
install).
-cherryPy fonctionne de la même manière que sous windows :-)
-adodb/mysql ne semble pas fonctionner; obligé de migrer vers le driver
natif mysql :-(
Si quelqu'un a déjà utilisé cherrypy en prod avec un rythme soutenu de
requêtes, ça m'intéresse d'avoir une idée des pbs (éventuellement)
rencontrés.
A+
jm
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
William Dode
Le #521133
On 03-03-2006, jean-michel bain-cornu wrote:
Bonjour,
J'ai eu à le faire cette semaine.
-pas de pb particulier avec python
-sous debian, obligé de compiler pour avoir la 2.4 :-(


Quelle debian ? la version 2.4 est dispo sur la stable (sarge).

--
William Dodé - http://flibuste.net

Jerome
Le #521132
William Dode wrote:
On 03-03-2006, jean-michel bain-cornu wrote:

Bonjour,
J'ai eu à le faire cette semaine.
-pas de pb particulier avec python
-sous debian, obligé de compiler pour avoir la 2.4 :-(



Quelle debian ? la version 2.4 est dispo sur la stable (sarge).



effectivement

http://packages.debian.org/stable/python/python2.4
http://packages.debian.org/stable/web/cherrypy


loufoque
Le #521131

-adodb/mysql ne semble pas fonctionner; obligé de migrer vers le driver
natif mysql :-(


A priori adodb utilise le pilote natif de mysql.
Bien sûr, si tu lui fais utiliser ODBC, ça risque pas de marcher.

jean-michel bain-cornu
Le #520898
William Dode wrote:
On 03-03-2006, jean-michel bain-cornu wrote:

Bonjour,
J'ai eu à le faire cette semaine.
-pas de pb particulier avec python
-sous debian, obligé de compiler pour avoir la 2.4 :-(



Quelle debian ? la version 2.4 est dispo sur la stable (sarge).

Effectivement, c'est la version d'avant. Je note l'info pour la

prochaine fois.
Merci.
jm


jean-michel bain-cornu
Le #520897
loufoque wrote:

-adodb/mysql ne semble pas fonctionner; obligé de migrer vers le driver
natif mysql :-(



A priori adodb utilise le pilote natif de mysql.
Bien sûr, si tu lui fais utiliser ODBC, ça risque pas de marcher.
ça c'est sûr ! (quoique odbc existe aussi sous unix).

A priori mon problème était un bug (un plantage je ne sais plus où).
Malheureusement, je n'ai pas eu le temps de creuser. Je donnerai l'info
si j'ai l'occasion de trouver la solution.
A+
jm


Publicité
Poster une réponse
Anonyme