Routeur WRT54GS + Livebox

Le
trewan
Salut,

J'ai des difficultés à configurer mon accés internet avec le routeur et
la livebox :

Livebox en 192.168.1.1
Routeur en 192.168.1.2

Le routeur est en IP dynamique coté WAN et statique coté LAN
J'ai désactivé le DHCP de la livebox.

Les PC's en 192.168.1.101-102,


J'ai fait le test suivant : tous les PC la LB et le routeur sur un
switch : internet fonctionne sur tous les PCs et j'accède au routeur et
à la LB.

Par contre lorsque je déconnecte la LB du switch et que je la mets sur
le port WAN du routeur , internet ne fonctionne plus.

1. Je me demande si je dois désactiver le NAT de la LB ou celui du routeur

2. Ca me semble pas clair de mettre le port LAN de la LB sur le port WAN
du routeur, puisque de ce coté la LB est en 192.168.1.1 elle ne va pas
donner d'IP dynamique au routeur?

Bref, je patauge un peu là si vous pouviez m'éclairer ;)

Merci

Eric

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Herm
Le #723726
"trewan" 4318af4a$0$17243$
Salut,

J'ai des difficultés à configurer mon accés internet avec le routeur et la
livebox :

Livebox en 192.168.1.1
Routeur en 192.168.1.2


Bonsoir,

Vous vous lancez dans la joie d'un chaînage de routeurs...

A moins que ce routeur ne vous fournisse des fonctions avancées, il me
paraîtrait plus sage de ne se reposer que sur un module de routage, comme
par exemple, celui de la livebox... Mais bon, mettons que l'on essaye de
faire fonctionner quand même ce shéma :

Tel
|
|
LiveBox
|
| Sous-réseau A
|
Routeur
|
| Sous-réseau B
|
|--- PC1
|--- PC2
...


Le routeur est en IP dynamique coté WAN et statique coté LAN


En outre, regardez si vous n'avez pas configuré le routeur en mode
PPPoE... La livebox se chargeant de fournir directement du TCP/IP over
Ethernet sur le sous-réseau A, le routeur doit être mis en mode IP simple.

J'ai désactivé le DHCP de la livebox.


Sous-réseau A: Si vous mettez le routeur en IP dynamique côté WAN, alors
ne coupez pas le serveur DHCP de son prédécésseur ! Vous vous retrouvez
ainsi dans un lien de sous-réseau (constitué juste du câble entre routeurs)
sans aucun module de nommage IP !

Ayant déjà vu la Livebox à l'oeuvre lors de ses mises à jour de firmware,
je vous conseille très vivement de laisser le serveur DHCP de cette dernière
acif, et de mettre le port WAN du routeur en IP dynamique. Ainsi, que la
livebox fournisse du réseau sur sa prise Ethernet en 192.168.5.x ou en
192.168.1.x (ou autre chose dans une prochaine mise à jour...ils sont
taquins chez FT), ça marchera aussi...

Les PC's en 192.168.1.101-102,


Sous-réseau B : Ah, ceci est gênant...

La mouture actuelle des livebox, aux dernières nouvelles, c'est aussi du
192.168.1.x . Rien de tel pour perturber le routeur que de lui demander de
router d'un sous réseau à l'autre ... alors qu'ils ont le même nom ...

Que diriez-vous de nommer le réseau des PC en 10.0.0.x , masque 255.0.0.0 ?
Cela enlèverait tout ambiguité pour le routeur. Il saura que 10.x.x.x, c'est
du dialogue local à ne pas router, et que tout autre accès, Intrenet, est à
router via le port Wan, sur l'adresse que lui aura fournit la Livebox.

Il faudra changer l'adresse LAN du routeur, et aussi celle des PC (si vous
n'utilisez pas le module DHCP du routeur).

Pas de souci côté Internet, les adresses 10.x.x.x comme celles en
192.168.x.x sont réservées à un usage local ...

J'ai fait le test suivant : tous les PC la LB et le routeur sur un switch
: internet fonctionne sur tous les PCs et j'accède au routeur et à la LB.


Ok, ceci vous permet d'accéder aux pages de configuration, temporairement.

Par contre lorsque je déconnecte la LB du switch et que je la mets sur le
port WAN du routeur , internet ne fonctionne plus.


Quelques causes possibles sont expliquées plus haut dans ce message...

1. Je me demande si je dois désactiver le NAT de la LB ou celui du routeur


Ou vous passer simplement du routeur ?

2. Ca me semble pas clair de mettre le port LAN de la LB sur le port WAN
du routeur, puisque de ce coté la LB est en 192.168.1.1 elle ne va pas
donner d'IP dynamique au routeur?


Sans le module DHCP de la Livebox, ça risque de pas trop le faire :-)

Avec, ça ira nettement mieux.

Bref, je patauge un peu là si vous pouviez m'éclairer ;)


Une fois les réglages faits, si Internet ne fonctionne toujours pas, donnez
le résultat d'une commande traceroute comme celle-ci (à taper dans une boite
Dos) :

tracert 66.249.87.104

Vu votre configuration, ça devrait donner :^

1er hop : le routeur en 10.x.x.x
2nd hop : la Livebox en 192.168.1(/5).1
3ème hop et suivants : Le FAI, le réseau et ... le serveur contacté
(www.google.fr)

Si, déjà, ceci fonctionne, ça sera une bonne partie de gagnée !

--
Herm
(Cf étymologie de Hergé) B-)

balibalo
Le #723445
Salut,
Je comprend pas pourquoi tu veux ajouter un routeur ?
tu connectes le switch sur la LB avec un cable eternet droit ou croisé
(la LB se démerde) et tu branche les PC sur le Switsh ou par Wifi.!!!

Le pare-feux de la LB est parfait teste le ici
http://security1.norton.com/ssc/home.asp?langid=fr

Si tu veux tous les Tuto pour la Livebox
http://livebox.forumactif.com/index.forum
et ici
http://voyageurcorail.site.voila.fr/sommaire.htm

Cordialement



Le Fri, 02 Sep 2005 21:59:57 +0200, trewan
Salut,

J'ai des difficultés à configurer mon accés internet avec le routeur et
la livebox :

Livebox en 192.168.1.1
Routeur en 192.168.1.2

Le routeur est en IP dynamique coté WAN et statique coté LAN
J'ai désactivé le DHCP de la livebox.

Les PC's en 192.168.1.101-102,


J'ai fait le test suivant : tous les PC la LB et le routeur sur un
switch : internet fonctionne sur tous les PCs et j'accède au routeur et
à la LB.

Par contre lorsque je déconnecte la LB du switch et que je la mets sur
le port WAN du routeur , internet ne fonctionne plus.

1. Je me demande si je dois désactiver le NAT de la LB ou celui du routeur

2. Ca me semble pas clair de mettre le port LAN de la LB sur le port WAN
du routeur, puisque de ce coté la LB est en 192.168.1.1 elle ne va pas
donner d'IP dynamique au routeur?

Bref, je patauge un peu là si vous pouviez m'éclairer ;)

Merci

Eric


trewan
Le #733932
balibalo wrote:
Salut,
Je comprend pas pourquoi tu veux ajouter un routeur ?
tu connectes le switch sur la LB avec un cable eternet droit ou croisé
(la LB se démerde) et tu branche les PC sur le Switsh ou par Wifi.!!!


Parce que le routage est bien mieux sur le routeur que sur la LB .

Eric

trewan
Le #733931
Herm wrote:

Que diriez-vous de nommer le réseau des PC en 10.0.0.x , masque 255.0.0.0 ?
Cela enlèverait tout ambiguité pour le routeur. Il saura que 10.x.x.x, c'est
du dialogue local à ne pas router, et que tout autre accès, Intrenet, est à
router via le port Wan, sur l'adresse que lui aura fournit la Livebox.


Mes excuses pour cette réponse tardive, mais si les PC sont en 10.0.0.x
et la LB en 192.168.1.1, depuis les PC je ne peux plus administrer la
LB?, ou il me faut une 2eme carte reseau?

Merci

Eric

Pascal
Le #734201
Salut,

Herm wrote:

Que diriez-vous de nommer le réseau des PC en 10.0.0.x , masque
255.0.0.0 ? Cela enlèverait tout ambiguité pour le routeur. Il saura
que 10.x.x.x, c'est du dialogue local à ne pas router, et que tout
autre accès, Intrenet, est à router via le port Wan, sur l'adresse que
lui aura fournit la Livebox.


Mes excuses pour cette réponse tardive, mais si les PC sont en 10.0.0.x
et la LB en 192.168.1.1, depuis les PC je ne peux plus administrer la
LB?


Pourquoi ne serait-ce plus possible ?
Internet est constitué de machines qui sont dans une multitude de
sous-réseaux différents et qui arrivent très bien à communiquer
ensemble. C'est à ça que sert le routage IP, à faire communiquer les
sous-réseaux entre eux, et justement, le rôle d'un routeur est de faire
du routage.

ou il me faut une 2eme carte reseau?


Pourquoi faire ?


Poster une réponse
Anonyme