samba configuration

Le
ben durand
--0-1392379701-1157554815=:60271
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

bonjour,

voilà, je débute sur linux et debian.
j'essaie de configurer un serveur avec samba pour y adjoindre des clients windows.

j'ai installé la version sarge.
puis installé samba :
# apt-get install samba

puis j'ai recopier un script de démarrage nommé samba dans /etc/init.d
puis j'ai configuré le fichier smb.conf en voici une copie :

[global]
netbios name = SIGNY
workgroup = WORKGROUP
server string = Debian GNU/Linux
guest account = invite
log file =/var/log/samba/log.%U
username map =/etc/smbusers
security = user
socket options = TCP_NODELAY
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*%n *Re*%n *pa*
domain master = yes
local master = yes
wins support = yes
logon script = logon.bat
logon home = \SIGNY%U

[netlogon]
path = /home/netlogon/%g
locking = no
writeable = no
public = yes
browseable = no

[home]
comment = Repertoire personnel de %U
browseable = no
path = %H
writeable = yes

[pdg]
browseable = no
valid users = @pdg
path = /home/partage/pdg
writeable = yes

[commerciaux]
browseable = no
path = /home/partage/commerciaux
valid users = @pdg @commerciaux
read list = @pdg
write list = @commerciaux
create mask = 0775
directory mask = 0775

[commerce]
browseable = no
path = /home/partage/commerce
valid users = @pdg @commerciaux
read list = @commerciaux
write list = @pdg
create mask = 0775
directory mask = 0775

[public]
path = /home/partage/public
browseable = no
valid users = @pdg @commerciaux @employes
read list = @commerciaux @employes
write list = @pdg
create mask = 0775
directory mask = 0775

.
puis enfin, j'ai créé les répertoires avec les users.
ainsi que les fichiers logon.bat dans chaque répertoire.

sur le client winxp:
j'ai modifié la base de registre pour remettre la valeur 0

lorsque je redémarre le tout, dans le voisinage réseau sur winxp, je ne vois rien.

Ai-je oublié une manip sur le poste client winxp ?
Qu'ai-je oublié de faire entre le serveur samba et le client winxp ?

en vous remerciant de votre aide.
Ben.






Yahoo! Mail réinvente le mail ! Découvrez le nouveau Yahoo! Mail et son interface révolutionnaire.
--0-1392379701-1157554815=:60271
Content-Type: text/html; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

bonjour, <br><br>voilà, je débute sur linux et debian.<br>j'essaie de configurer un serveur avec samba pour y adjoindre des clients windows.<br><br>j'ai installé la version sarge. <br>puis installé samba : <br># apt-get install samba<br><br>puis j'ai recopier un script de démarrage nommé samba dans /etc/init.d<br>puis j'ai configuré le fichier smb.conf en voici une copie : <br><br>[global]<br>netbios name = SIGNY <br>workgroup = WORKGROUP<br>server string = Debian GNU/Linux<br>guest account = invite<br>log file =/var/log/samba/log.%U<br>username map =/etc/smbusers<br>security = user <br>socket options = TCP_NODELAY<br>encrypt passwords = yes<br>smb passwd file = /etc/smbpasswd<br>unix password sync = yes<br>passwd program = /usr/bin/passwd %u<br>passwd chat = *New*%n *Re*%n *pa*<br>domain master = yes<br>local master = yes<br>wins support = yes<br>logon script = logon.bat<br>logon home = \SIGNY%U<br><br>[netlogon]<br>path = /home/netlogon/%g<br>locking =
no<br>writeable = no<br>public = yes<br>browseable = no<br><br>[home]<br>comment = Repertoire personnel de %U<br>browseable = no<br>path = %H<br>writeable = yes<br><br>[pdg]<br>browseable = no<br>valid users = @pdg<br>path = /home/partage/pdg<br>writeable = yes<br><br>[commerciaux]<br>browseable = no<br>path = /home/partage/commerciaux<br>valid users = @pdg @commerciaux<br>read list = @pdg<br>write list = @commerciaux<br>create mask = 0775<br>directory mask = 0775<br><br>[commerce]<br>browseable = no<br>path = /home/partage/commerce<br>valid users = @pdg @commerciaux<br>read list = @commerciaux <br>write list = @pdg<br>create mask = 0775<br>directory mask = 0775<br><br>[public]<br>path = /home/partage/public<br>browseable = no<br>valid users = @pdg @commerciaux @employes<br>read list = @commerciaux @employes<br>write list = @pdg<br>create mask = 0775<br>directory mask = 0775 <br><br>.<br>puis enfin, j'ai créé les répertoires avec les users. <br>ainsi que les fichiers
logon.bat dans chaque répertoire. <br><br>sur le client winxp: <br>j'ai modifié la base de registre pour remettre la valeur 0 <br><br>lorsque je redémarre le tout, dans le voisinage réseau sur winxp, je ne vois rien. <br><br>Ai-je oublié une manip sur le poste client winxp ? <br>Qu'ai-je oublié de faire entre le serveur samba et le client winxp ?<br><br>en vous remerciant de votre aide.<br>Ben. <br><br><br><br><p>&#32;
<hr size="1">
<b>Yahoo! Mail réinvente le mail !</b> Découvrez le <a href="http://fr.rd.yahoo.com/evt@577/*http://fr.promotions.yahoo.com/mail/nouveaumail.html
">nouveau Yahoo! Mail</a> et son interface révolutionnaire.

--0-1392379701-1157554815=:60271--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas Folin
Le #9381681
ben durand wrote:
bonjour,

voilà, je débute sur linux et debian.
j'essaie de configurer un serveur avec samba pour y adjoindre des
clients windows.

j'ai installé la version sarge.
puis installé samba :
# apt-get install samba

puis j'ai recopier un script de démarrage nommé samba dans /etc/init.d
puis j'ai configuré le fichier smb.conf en voici une copie :

[global]
netbios name = SIGNY
workgroup = WORKGROUP
server string = Debian GNU/Linux
guest account = invite
log file =/var/log/samba/log.%U
username map =/etc/smbusers
security = user
socket options = TCP_NODELAY
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*%n n *Re*%n n *pa*
domain master = yes
local master = yes
wins support = yes
logon script = logon.bat
logon home = \SIGNY%U

[netlogon]
path = /home/netlogon/%g
locking = no
writeable = no
public = yes
browseable = no

[home]
comment = Repertoire personnel de %U
browseable = no
path = %H
writeable = yes

[pdg]
browseable = no
valid users = @pdg
path = /home/partage/pdg
writeable = yes

[commerciaux]
browseable = no
path = /home/partage/commerciaux
valid users = @pdg @commerciaux
read list = @pdg
write list = @commerciaux
create mask = 0775
directory mask = 0775

[commerce]
browseable = no
path = /home/partage/commerce
valid users = @pdg @commerciaux
read list = @commerciaux
write list = @pdg
create mask = 0775
directory mask = 0775

[public]
path = /home/partage/public
browseable = no
valid users = @pdg @commerciaux @employes
read list = @commerciaux @employes
write list = @pdg
create mask = 0775
directory mask = 0775

....
puis enfin, j'ai créé les répertoires avec les users.
ainsi que les fichiers logon.bat dans chaque répertoire.

sur le client winxp:
j'ai modifié la base de registre pour remettre la valeur 0 ...

lorsque je redémarre le tout, dans le voisinage réseau sur winxp, je
ne vois rien.

Ai-je oublié une manip sur le poste client winxp ?
Qu'ai-je oublié de faire entre le serveur samba et le client winxp ?

en vous remerciant de votre aide.
Ben.



------------------------------------------------------------------------
*Yahoo! Mail réinvente le mail !* Découvrez le nouveau Yahoo! Mail
et son interface révolutionnaire.



Je ne suis pas sur, mais il me semble que j'ai du définir les mots de
passe de mes utilisateurs sous linux avec smbpasswd,
du genre:
si toto, utilisateur sous linux, à son mot de passe qui est "poilo" ET
le meme toto,
utilisateur sous windows, à son mot de passe qui est "dos", il faut faire:
su toto
smb passwrd [répondre poilo]

Comme cela, depuis windows, l'utilisateur est reconnu par le serveur
samba...

Et sinon, tu as bien relancé samba après avoir modiifer le fichier de
conf ? (/etc/init.d/samba restart)
Nicolas Folin


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Bernard Dubois
Le #9381621
ben durand wrote:
bonjour,

voilà, je débute sur linux et debian.
j'essaie de configurer un serveur avec samba pour y adjoindre des
clients windows.

j'ai installé la version sarge.
puis installé samba :
# apt-get install samba

puis j'ai recopier un script de démarrage nommé samba dans /etc/init.d
puis j'ai configuré le fichier smb.conf en voici une copie :

[global]
netbios name = SIGNY
workgroup = WORKGROUP
server string = Debian GNU/Linux
guest account = invite
log file =/var/log/samba/log.%U
username map =/etc/smbusers
security = user
socket options = TCP_NODELAY
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*%n n *Re*%n n *pa*
domain master = yes
local master = yes
wins support = yes
logon script = logon.bat
logon home = \SIGNY%U

[netlogon]
path = /home/netlogon/%g
locking = no
writeable = no
public = yes
browseable = no

[home]
comment = Repertoire personnel de %U
browseable = no
path = %H
writeable = yes

[pdg]
browseable = no
valid users = @pdg
path = /home/partage/pdg
writeable = yes

[commerciaux]
browseable = no
path = /home/partage/commerciaux
valid users = @pdg @commerciaux
read list = @pdg
write list = @commerciaux
create mask = 0775
directory mask = 0775

[commerce]
browseable = no
path = /home/partage/commerce
valid users = @pdg @commerciaux
read list = @commerciaux
write list = @pdg
create mask = 0775
directory mask = 0775

[public]
path = /home/partage/public
browseable = no
valid users = @pdg @commerciaux @employes
read list = @commerciaux @employes
write list = @pdg
create mask = 0775
directory mask = 0775

....
puis enfin, j'ai créé les répertoires avec les users.
ainsi que les fichiers logon.bat dans chaque répertoire.

sur le client winxp:
j'ai modifié la base de registre pour remettre la valeur 0 ...

lorsque je redémarre le tout, dans le voisinage réseau sur winxp, je ne
vois rien.



l'option
browseable = no
signifie qu'ils ne doivent pas être vus dans le voisinage réseau.
mais \SIGNYpublic doit par contre fonctionner dans le navigateur XP


Ai-je oublié une manip sur le poste client winxp ?
Qu'ai-je oublié de faire entre le serveur samba et le client winxp ?

en vous remerciant de votre aide.
Ben.



------------------------------------------------------------------------
*Yahoo! Mail réinvente le mail !* Découvrez le nouveau Yahoo! Mail
<http://fr.rd.yahoo.com//*http://fr.promotions.yahoo.com/mail/nouveaumail.html
> et son interface révolutionnaire.




--
Cordialement
Jean-Bernard Dubois
Gaïa Converter


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme