Sane-backends 1.0.28

Le
Geo Cherchetout
Bonjour,

Je viens d'acheter un scanner Canon LIDE 300 dont l'utilisation requiert
cette version de sane-backends que ne fournit pas ma distribution Mageia 7.
J'ai donc téléchargé l'archive proposée ici :
https://gitlab.com/sane-project/backends/-/releases et réalisé
l'installation apparemment sans bavure. Que dois-je faire de plus pour que
ce nouveau scanner devienne utilisable ?
Dois-je par exemple désinstaller le paquet rpm sane-backends-1.0.27 ? Je
pose la question parce que cela impliquerait normalement la suppression de 7
autres paquets dont certains me semblent bien utiles, xsane-gimp, drakconf
et hardrake-ui notamment.
Merci pour votre aide.

  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
dyrmak
Le #26529392
En 13 lignes Geo Cherchetout a écrit
dans news:qocfo1$2hqo$
le vendredi, 18 octobre 2019 à 15:46:41 :
Bonjour,
Je viens d'acheter un scanner Canon LIDE 300 dont l'utilisation requiert
cette version de sane-backends que ne fournit pas ma distribution Mageia 7.
J'ai donc téléchargé l'archive proposée ici :
https://gitlab.com/sane-project/backends/-/releases et réalisé
l'installation apparemment sans bavure. Que dois-je faire de plus pour que
ce nouveau scanner devienne utilisable ?
Dois-je par exemple désinstaller le paquet rpm sane-backends-1.0.27 ? Je
pose la question parce que cela impliquerait normalement la suppression de 7
autres paquets dont certains me semblent bien utiles, xsane-gimp, drakconf
et hardrake-ui notamment.
Merci pour votre aide.

Est-ce que les vérifications habituelles donnent des résultats?
Il me semble qu'au minimum il devrait être listé dans
/etc/sane.d/genesys
Peut-être les commandes xsane localhost:genesys
xsane net:localhost:genesys
xsane
En principe, je ne toucherais pas au rpm, en compilant
on ne met pas les résultats sur les mêmes chemins,
ça vaut mieux d'ailleurs...
dyrmak
--
Para por si acaso
++++ --- ++++
Linux operating system
++++ --- ++++
Geo Cherchetout
Le #26529440
Le 24/10/2019 11:03, *dyrmak* a écrit :
En 13 lignes Geo Cherchetout a écrit
dans news:qocfo1$2hqo$
le vendredi, 18 octobre 2019 à 15:46:41 :
Bonjour,
Je viens d'acheter un scanner Canon LIDE 300 dont l'utilisation requiert
cette version de sane-backends que ne fournit pas ma distribution Mageia 7.
J'ai donc téléchargé l'archive proposée ici :
https://gitlab.com/sane-project/backends/-/releases et réalisé
l'installation apparemment sans bavure. Que dois-je faire de plus pour que
ce nouveau scanner devienne utilisable ?
Dois-je par exemple désinstaller le paquet rpm sane-backends-1.0.27 ? Je
pose la question parce que cela impliquerait normalement la suppression de 7
autres paquets dont certains me semblent bien utiles, xsane-gimp, drakconf
et hardrake-ui notamment.
Merci pour votre aide.

Est-ce que les vérifications habituelles donnent des résultats?
Il me semble qu'au minimum il devrait être listé dans
/etc/sane.d/genesys
Peut-être les commandes xsane localhost:genesys
xsane net:localhost:genesys
xsane
En principe, je ne toucherais pas au rpm, en compilant
on ne met pas les résultats sur les mêmes chemins,
ça vaut mieux d'ailleurs...

C'est ce que j'ai pensé aussi, mais le problème est résolu grâce à un
aimable packager qui a bien voulu compiler la version 1.0.28 et mettre le
paquet résultant dans les dépôts backports. Aujourd'hui je scanne à tour de
bras. :-)
Mais le LiDE 300 n'est toujours pas considéré comme supporté dans
/etc/sane.d/genesis.
Max
Le #26531393
Le 18/10/2019 à 15:46, Geo Cherchetout a écrit :
Bonjour,
Je viens d'acheter un scanner Canon LIDE 300 dont l'utilisation requiert
cette version de sane-backends que ne fournit pas ma distribution Mageia
7. J'ai donc téléchargé l'archive proposée ici :
https://gitlab.com/sane-project/backends/-/releases et réalisé
l'installation apparemment sans bavure. Que dois-je faire de plus pour
que ce nouveau scanner devienne utilisable ?
Dois-je par exemple désinstaller le paquet rpm sane-backends-1.0.27 ? Je
pose la question parce que cela impliquerait normalement la suppression
de 7 autres paquets dont certains me semblent bien utiles, xsane-gimp,
drakconf et hardrake-ui notamment.

Bonsoir,
As-tu essayé VueScan ?
Il se passe de sane.
@+
--
Il devint aussi méfiant qu'un chat à longue queue dans un magasin de
rocking-chair...
Terry Pratchett
Geo Cherchetout
Le #26531396
Le 20/11/2019 21:07, *Max* a écrit :
Le 18/10/2019 à 15:46, Geo Cherchetout a écrit :
Bonjour,
Je viens d'acheter un scanner Canon LIDE 300 dont l'utilisation requiert
cette version de sane-backends que ne fournit pas ma distribution Mageia
7. J'ai donc téléchargé l'archive proposée ici :
https://gitlab.com/sane-project/backends/-/releases et réalisé
l'installation apparemment sans bavure. Que dois-je faire de plus pour
que ce nouveau scanner devienne utilisable ?
Dois-je par exemple désinstaller le paquet rpm sane-backends-1.0.27 ? Je
pose la question parce que cela impliquerait normalement la suppression
de 7 autres paquets dont certains me semblent bien utiles, xsane-gimp,
drakconf et hardrake-ui notamment.

Bonsoir,
As-tu essayé VueScan ?
Il se passe de sane.

Merci pour le tuyau. Bien que le problème de sane-backends doit résolu, je
vais donner un coup d'œil à VueScan, ça peut toujours servir.
yamo'
Le #26531408
Salut,
Geo Cherchetout a tapoté le 20/11/2019 22:27:
Le 20/11/2019 21:07, *Max* a écrit :
Le 18/10/2019 à 15:46, Geo Cherchetout a écrit :
Bonjour,
Je viens d'acheter un scanner Canon LIDE 300 dont l'utilisation requiert
cette version de sane-backends que ne fournit pas ma distribution Mageia
7. J'ai donc téléchargé l'archive proposée ici :
https://gitlab.com/sane-project/backends/-/releases et réalisé
l'installation apparemment sans bavure. Que dois-je faire de plus pour
que ce nouveau scanner devienne utilisable ?
Dois-je par exemple désinstaller le paquet rpm sane-backends-1.0.27 ? Je
pose la question parce que cela impliquerait normalement la suppression
de 7 autres paquets dont certains me semblent bien utiles, xsane-gimp,
drakconf et hardrake-ui notamment.

Bonsoir,
As-tu essayé VueScan ?
Il se passe de sane.

Merci pour le tuyau. Bien que le problème de sane-backends doit résolu, je
vais donner un coup d'œil à VueScan, ça peut toujours servir.


Et simple-scan?
--
Stéphane
Geo Cherchetout
Le #26531420
Le 21/11/2019 11:16, *yamo'* a écrit :
Et simple-scan?

Ne dépend pas de sane-backends ? Comment le savoir sur ma distribution Mageia ?
yamo'
Le #26531429
Geo Cherchetout a tapoté le 21/11/2019 16:06:
Le 21/11/2019 11:16, *yamo'* a écrit :
Et simple-scan?

Ne dépend pas de sane-backends ? Comment le savoir sur ma distribution Mageia ?


Sur Debian, tu peux voir la liste des dépendances ici :
Je ne connais pas mageia, sauf de nom.
D'après urpmq -i simple-scan
--
Stéphane
yamo'
Le #26531430
Geo Cherchetout a tapoté le 21/11/2019 16:06:
Le 21/11/2019 11:16, *yamo'* a écrit :
Et simple-scan?

Ne dépend pas de sane-backends ? Comment le savoir sur ma distribution Mageia ?


Sur Debian, tu peux voir la liste des dépendances ici :
Je ne connais pas Mageia, sauf de nom.
D'après urpmq --requires simple-scan
--
Stéphane
Geo Cherchetout
Le #26531432
Le 21/11/2019 20:22, *yamo'* a écrit :
urpmq --requires simple-scan

C'est ce que j'ai essayé cet après-midi mais je ne sais pas interpréter la
réponse :
$ urpmq --requires simple-scan
--requires behaviour changed, use --requires-recursive to get the old behaviour
adwaita-icon-theme
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libcairo.so.2()(64bit)
libcolord.so.2()(64bit)
libgdk-3.so.0()(64bit)
libgdk_pixbuf-2.0.so.0()(64bit)
libgio-2.0.so.0()(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgtk-3.so.0()(64bit)
libgusb.so.2()(64bit)
libgusb.so.2(LIBGUSB_0.1.0)(64bit)
libgusb.so.2(LIBGUSB_0.2.2)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libpackagekit-glib2.so.18()(64bit)
libsane.so.1()(64bit)
libwebp.so.7()(64bit)
libwebpmux.so.3()(64bit)
libz.so.1()(64bit)
xdg-utils
yelp
$ urpmq --requires -recursive simple-scan
--requires behaviour changed, use --requires-recursive to get the old behaviour
Unknown option: e
Unknown option: e
getting lock on rpm
getting lock on urpmi
using mirror http://ftp.free.fr/mirrors/mageia.org/distrib/7/x86_64
examen de la liste de synthèse [/var/lib/urpmi/Core Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree
Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree
Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted
Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted
Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core 32bit
Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree 32bit
Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree 32bit
Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted 32bit
Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted 32bit
Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core Release
(distrib1)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core Updates
(distrib3)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree Release
(distrib11)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree Updates
(distrib13)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted Release
(distrib21)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted Updates
(distrib23)/synthesis.hdlist.cz]
Pas de paquetage nommé simple-scan
unlocking urpmi database
unlocking rpm database
Et je manque de motivation pour fouiller plus avant parce que sane-backends
me satisfait pleinement dans sa nouvelle version. Me permet de scanner
confortablement depuis Gimp comme j'en ai l'habitude depuis des années.
J'essaierai quand-même simple-scan par curiosité, qui est installé depuis
longtemps.
Christophe PEREZ
Le #26531446
Le Thu, 21 Nov 2019 20:53:26 +0100, Geo Cherchetout a écrit :
$ urpmq --requires -recursive simple-scan --requires behaviour changed,
use --requires-recursive to get the old behaviour

Il indique le paramètre "--requires-recursive" pas 2 paramètres --requires
ET -recursive
Il y a un espace de trop entre les 2 dans ta ligne.
Publicité
Poster une réponse
Anonyme