Service d'accès à distance au registre constamment désactivé sous W2000

Le
Nico
Bonjour à tous,

Je possède un W2000 Server avec ISA server et le service de routage et accès
distant.
J'ai un problème pour voir ma console de routage et accès distant. J'ai
remarqué que pour la visualiser, j'ai besoin d'activer le service d'accès à
distance au registre.
Le problème est que même en mode automatique, le service repasse en
désactivé au bout de quelques minutes!
Je n'avais pas ce problème avant la réinstallation du serveur. Aurais-je
fait une mauvaise manipulation? Est-il normal que ce service se désactive
automatiquement ?

Merci d'avance

Nicolas
Vos réponses
Trier par : date / pertinence
Jean-Claude BELLAMY
Le #458966
Dans le message :%,
Nico <nico> a pris la peine d'écrire ce qui suit :
Bonjour à tous,

Je possède un W2000 Server avec ISA server et le service de routage
et accès distant.
J'ai un problème pour voir ma console de routage et accès distant.
J'ai remarqué que pour la visualiser, j'ai besoin d'activer le
service d'accès à distance au registre.
Le problème est que même en mode automatique, le service repasse en
désactivé au bout de quelques minutes!
Je n'avais pas ce problème avant la réinstallation du serveur.
Aurais-je fait une mauvaise manipulation? Est-il normal que ce
service se désactive automatiquement ?


NON !

J'ai consulté le MSDN (6 articles consacrés à "RemoteRegistry" - son nom
court) :
Par défaut, ce service est configuré en auto (et donc doit se retrouver
démarré lors du démarrage de Windows) sous W2K et XP.

Ce n'est que sous W2K3 qu'il est désactivé par défaut.
(l'admin qui l'ignore et qui veut téléadministrer son serveur W2K3 aura des
problèmes sérieux!)

Au fait, est-ce bien "désactivé" l'état pris par RemoteRegistry chez toi, et
non pas "stoppé" ?

Pour info, le mode de démarrage (Boot, System, Auto, Manual, Disabled) est
stocké dans
HKLMSYSTEMCurrentControlSetServicesRemoteRegistryStart
et vaut :
0x00
= Boot
= Chargé par le loader (NTLDR)
0x01
= System
= Chargé lors de l'initialisation du noyau
0x02
= Auto (valeur la plus courante)
= Chargé et démarré automatiquement
lors du démarrage du système
0x03
= Manual
= Démarré par l'utilisateur ou par un autre processus
0x04
= Disabled
= Jamais démarré.
Une exception : les drivers de système de fichiers
sont chargés même avec start=4

J'ai vu que RemoteRegistry dépendait de RPCSS (Appel de procédure distante)
Peut-être que le pb vient de ce service ?
Mais ce serait étonnant, car lorsque RPCSS "tombe" c'est tout Windows qui se
plante ...
(plus de cinquante services dépendent de RPCSS !)

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr

Anonyme
Le #458965
Bonjour,
Quels sont les ID des evenements journalier ?

--
Anonyme
Anonyme
.

"Nico" <nico> wrote in message
news:%
Bonjour à tous,

Je possède un W2000 Server avec ISA server et le service de routage et
accès distant.
J'ai un problème pour voir ma console de routage et accès distant. J'ai
remarqué que pour la visualiser, j'ai besoin d'activer le service d'accès
à distance au registre.
Le problème est que même en mode automatique, le service repasse en
désactivé au bout de quelques minutes!
Je n'avais pas ce problème avant la réinstallation du serveur. Aurais-je
fait une mauvaise manipulation? Est-il normal que ce service se désactive
automatiquement ?

Merci d'avance

Nicolas



Nico
Le #458837
Re,

Il se trouve que mon service se retrouve bien désactivé!! je suis obligé de
le repasser en mode automatique(ou manuel, le résultat est le même), faire
appliquer et ensuite de le démarrer.
Ce que je ne comprends pas, c'est qu'il se désactive tout seul, sans
évenements dans le journal du même nom.
J'ai regardé la clé de registre, elle est à 0x02 donc telle que je le veux.

Il y a une question que je me pose: RemoteRegistry est-il indispensable pour
voir ma console de routage accès distant (je la regarde en local sur la
machine)?
Pour ce qui est du service RPC, il fontionne correctement car malgré ce
problème de console qui ne s'affiche pas (qd le service se désactive en
fait), les clients VPN restent connectés, le proxy ISA fonctionne
correctement....

Je me demande aussi s'il n'y a pas une mise à jour vicieuse de W2000 qui le
désactiverait comme c'est le cas dans le 2003 ou XP. En effet, j'ai
réinstallé mon serveur et je l'ai patché au maximum.

Merci pour vos réponses.

Nico

"Jean-Claude BELLAMY" message de news:
Dans le message :%,
Nico <nico> a pris la peine d'écrire ce qui suit :
Bonjour à tous,

Je possède un W2000 Server avec ISA server et le service de routage
et accès distant.
J'ai un problème pour voir ma console de routage et accès distant.
J'ai remarqué que pour la visualiser, j'ai besoin d'activer le
service d'accès à distance au registre.
Le problème est que même en mode automatique, le service repasse en
désactivé au bout de quelques minutes!
Je n'avais pas ce problème avant la réinstallation du serveur.
Aurais-je fait une mauvaise manipulation? Est-il normal que ce
service se désactive automatiquement ?


NON !

J'ai consulté le MSDN (6 articles consacrés à "RemoteRegistry" - son nom
court) :
Par défaut, ce service est configuré en auto (et donc doit se retrouver
démarré lors du démarrage de Windows) sous W2K et XP.

Ce n'est que sous W2K3 qu'il est désactivé par défaut.
(l'admin qui l'ignore et qui veut téléadministrer son serveur W2K3 aura
des problèmes sérieux!)

Au fait, est-ce bien "désactivé" l'état pris par RemoteRegistry chez toi,
et non pas "stoppé" ?

Pour info, le mode de démarrage (Boot, System, Auto, Manual, Disabled) est
stocké dans
HKLMSYSTEMCurrentControlSetServicesRemoteRegistryStart
et vaut :
0x00
= Boot
= Chargé par le loader (NTLDR)
0x01
= System
= Chargé lors de l'initialisation du noyau
0x02
= Auto (valeur la plus courante)
= Chargé et démarré automatiquement
lors du démarrage du système
0x03
= Manual
= Démarré par l'utilisateur ou par un autre processus
0x04
= Disabled
= Jamais démarré.
Une exception : les drivers de système de fichiers
sont chargés même avec start=4

J'ai vu que RemoteRegistry dépendait de RPCSS (Appel de procédure
distante)
Peut-être que le pb vient de ce service ?
Mais ce serait étonnant, car lorsque RPCSS "tombe" c'est tout Windows qui
se plante ...
(plus de cinquante services dépendent de RPCSS !)

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr




Jean-Claude BELLAMY
Le #458835
Dans le message :,
Nico <nico> a pris la peine d'écrire ce qui suit :
Re,

Il se trouve que mon service se retrouve bien désactivé!! je suis
obligé de le repasser en mode automatique(ou manuel, le résultat est
le même), faire appliquer et ensuite de le démarrer.
Vraiment bizarre !!!


Ce que je ne comprends pas, c'est qu'il se désactive tout seul, sans
évenements dans le journal du même nom.
J'ai regardé la clé de registre, elle est à 0x02 donc telle que je le
veux.
Il y a une question que je me pose: RemoteRegistry est-il
indispensable pour voir ma console de routage accès distant (je la
regarde en local sur la machine)?
Ce service, comme son nom l'indique, permet l'accès à la BDR d'uen machine

distante (aussi bien pour lire que pour écrire)
Or dès que l'on fait de la téléadministration, on est fatalement amené (au
pif dans 99% des cas) à accéder à la BDR de la machine distante.
P.ex. dans mon outil SUPEREXEC, je dois accéder aux BDR distantes, et pour
cela je teste au préalable si RemoteRegistry est démarré sur les machines
distantes. Si ce n'est pas le cas, je démarre à distance ce service
(évidemment, il faut le faire sous un compte admin de la machine distante).


Pour ce qui est du service RPC, il fontionne correctement car malgré
ce problème de console qui ne s'affiche pas (qd le service se
désactive en fait), les clients VPN restent connectés, le proxy ISA
fonctionne correctement....
Cela ne me surprend pas.

Comme je te l'ai dit, si RPC était planté, ce serait tout Windows qui le
serait.

Je me demande aussi s'il n'y a pas une mise à jour vicieuse de W2000
qui le désactiverait comme c'est le cas dans le 2003 ou XP. En effet,
j'ai réinstallé mon serveur et je l'ai patché au maximum.
Ce n'est pas impossible ...


Le module binaire qui gère ce service sous W2K est :
%SystemRoot%system32regsvc.exe

(Pour info, sous XP, c'est une DLL : %SystemRoot%system32regsvc.dll)

Il a été remis à jour dans le SP4 (fichier x:i386regsvc.ex_)

Donc, au cas où il aurait été corrompu, je te suggère une réinstallation du
SP4.
Cela ne peut pas faire de mal de toute façon...


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr

Nico
Le #458832
Re,


J'ai réinstallé le SP4, ce qui n'a rien changé.
J'ai refait un test ce matin et j'ai constaté sur mon serveur l'erreur
suivante au moment où le service s'est désactivé::

Type de l'événement : Avertissement
Source de l'événement : BROWSER
Catégorie de l'événement : Aucun
ID de l'événement : 8021
Date : 23/03/2006
Heure : 09:25:52
Utilisateur : N/A
Ordinateur : ISA2
Description :
L'explorateur n'a pas pu retrouver la liste des serveurs du maître
explorateur \LISA sur le réseau
DeviceNetBT_Tcpip_{35B0B175-4A80-4C6C-8943-9950677F3DFD}. La donnée est le
code d'erreur.
Données :
0000: 35 00 00 00 5...

Je ping bien mon serveur LISA(qui est le DNS). Au niveau des paramètres
avancés des connexions réseaux, j'ai bien mis mon LAN en première position
pour les ordres d'accès DNS. Le réseau
DeviceNetBT_Tcpip_{35B0B175-4A80-4C6C-8943-9950677F3DFD correspond bien à
ma carte LAN interne.
Je pense que cette erreur n'est pas innocente quant à la désactivation de
mon service .

Merci pour vos réponses.

Nico


"Jean-Claude BELLAMY" message de news:
Dans le message :,
Nico <nico> a pris la peine d'écrire ce qui suit :
Re,

Il se trouve que mon service se retrouve bien désactivé!! je suis
obligé de le repasser en mode automatique(ou manuel, le résultat est
le même), faire appliquer et ensuite de le démarrer.
Vraiment bizarre !!!


Ce que je ne comprends pas, c'est qu'il se désactive tout seul, sans
évenements dans le journal du même nom.
J'ai regardé la clé de registre, elle est à 0x02 donc telle que je le
veux.
Il y a une question que je me pose: RemoteRegistry est-il
indispensable pour voir ma console de routage accès distant (je la
regarde en local sur la machine)?
Ce service, comme son nom l'indique, permet l'accès à la BDR d'uen machine

distante (aussi bien pour lire que pour écrire)
Or dès que l'on fait de la téléadministration, on est fatalement amené (au
pif dans 99% des cas) à accéder à la BDR de la machine distante.
P.ex. dans mon outil SUPEREXEC, je dois accéder aux BDR distantes, et
pour cela je teste au préalable si RemoteRegistry est démarré sur les
machines distantes. Si ce n'est pas le cas, je démarre à distance ce
service (évidemment, il faut le faire sous un compte admin de la machine
distante).


Pour ce qui est du service RPC, il fontionne correctement car malgré
ce problème de console qui ne s'affiche pas (qd le service se
désactive en fait), les clients VPN restent connectés, le proxy ISA
fonctionne correctement....
Cela ne me surprend pas.

Comme je te l'ai dit, si RPC était planté, ce serait tout Windows qui le
serait.

Je me demande aussi s'il n'y a pas une mise à jour vicieuse de W2000
qui le désactiverait comme c'est le cas dans le 2003 ou XP. En effet,
j'ai réinstallé mon serveur et je l'ai patché au maximum.
Ce n'est pas impossible ...


Le module binaire qui gère ce service sous W2K est :
%SystemRoot%system32regsvc.exe

(Pour info, sous XP, c'est une DLL : %SystemRoot%system32regsvc.dll)

Il a été remis à jour dans le SP4 (fichier x:i386regsvc.ex_)

Donc, au cas où il aurait été corrompu, je te suggère une réinstallation
du SP4.
Cela ne peut pas faire de mal de toute façon...


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr





Publicité
Poster une réponse
Anonyme