Service Windev pour imprimer directement un Etat

Le
soulahsen
SVP je crée un service Windev pour imprimer directement un Etat bas=
sur une requête, le problème est que la requête s=
exécute bien mais sans aucune impression. Aidez moi. Merci infinime=
nt.
Je signale qu en mode Déboguer le service fonctionne correctement.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tjfromparis
Le #26423867
un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec une session windows derriere) et n'a pas le meme comportement lorsqu'il tourne en service ca ne m'etonne pas.
t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'imprimante ?
soulahsen
Le #26423874
Le lundi 16 janvier 2017 16:43:55 UTC, a écrit  :
SVP je crée un service Windev pour imprimer directement un Etat bas é sur une requête, le problème est que la requête s⠀™exécute bien mais sans aucune impression. Aidez moi. Merci infin iment.
Je signale qu en mode Déboguer le service fonctionne correctement.

Merci beaucoup pour votre intervention.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALO RS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN
soulahsen
Le #26423876
Le lundi 16 janvier 2017 20:27:59 UTC, a écrit  :
un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec u ne session windows derriere) et n'a pas le meme comportement lorsqu'il tour ne en service ca ne m'etonne pas.
t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'impriman te ?

Merci beaucoup pour votre intervention.
Oui.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALO RS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN
Raminagrobis
Le #26423977
a couché sur son écran :
SVP je crée un service Windev pour imprimer directement un Etat basé sur une
requête, le problème est que la requête s’exécute bien mais sans aucune
impression. Aidez moi. Merci infiniment. Je signale qu en mode Déboguer le
service fonctionne correctement.

J'ai eu le même problème, confronté à des problèmes de droits vis à vis
du service et de l'impression j'ai abandonné.
Le Service lance maintenant un executable qui lui accède correctement à
l'impression.
phig
Le #26424006
Le 16/01/2017 à 23:31, a écrit :
Le lundi 16 janvier 2017 20:27:59 UTC, a écrit :
un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec une session windows derriere) et n'a pas le meme comportement lorsqu'il tourne en service ca ne m'etonne pas.
t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'imprimante ?

Merci beaucoup pour votre intervention.
Oui.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALORS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN

ca doit fonctionner si le service tourne avec un utilisateur autre que
system et qui les droits sur l'imprimante en question...
soulahsen
Le #26424112
Le mercredi 18 janvier 2017 13:36:25 UTC, phig a écrit :
Le 16/01/2017 à 23:31, a écrit :
Le lundi 16 janvier 2017 20:27:59 UTC, a écrit :
un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc ave c une session windows derriere) et n'a pas le meme comportement lorsqu'il t ourne en service ca ne m'etonne pas.
t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'impri mante ?

Merci beaucoup pour votre intervention.
Oui.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALORS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN

ca doit fonctionner si le service tourne avec un utilisateur autre que
system et qui les droits sur l'imprimante en question...

Merci de m'expliquer plus Mr. PHIG.
phig
Le #26424144
Le 19/01/2017 à 18:35, a écrit :
Le mercredi 18 janvier 2017 13:36:25 UTC, phig a écrit :
Le 16/01/2017 à 23:31, a écrit :
Le lundi 16 janvier 2017 20:27:59 UTC, a écrit :
un service peut acceder aux imprimantes ????
jamais essayé mais si ton soft fonctionne en mode debug (donc avec une session windows derriere) et n'a pas le meme comportement lorsqu'il tourne en service ca ne m'etonne pas.
t'as pas plus d'infos ?
c'est le service qui effectue la requete et qui l'envoi à l'imprimante ?

Merci beaucoup pour votre intervention.
Oui.
Voici la procedure executée dans le bloc (appelé en boucle):
PROCEDURE pG_imprime()
HExécuteRequête(REQ_MImprime)
SI HLitPremier(REQ_MImprime) ALORS
TANTQUE HTrouve(REQ_MImprime)
iInitRequêteEtat(ETAT_ticketM,REQ_MImprime.IDcommandes)
iAperçu(iImprimante)
iFenêtreAbandon(Faux)
iImprimeEtat(ETAT_ticketM)
SI HLitRecherchePremier(commandes,IDcommandes,REQ_MImprime.IDcommandes) ALORS
commandes.imprime=0
HModifie(commandes)
FIN
HLitSuivant(REQ_MImprime)
FIN
FIN

ca doit fonctionner si le service tourne avec un utilisateur autre que
system et qui les droits sur l'imprimante en question...

Merci de m'expliquer plus Mr. PHIG.

ca va être compliqué, d'expliquer plus, si tu ne connais pas la notion
de user sous windows !
un service, ca "tourne" dans un userspace. par defaut, c'est
l'utilisateur SYSTEM. mais SYSTEM n'a pas tous les droits ( par exemple,
il n'a pas forcement accès aux ressources reseaux, comme les imprimantes
réseau ou les disques partagés, ou aux dossiers locaux avec des droits).
Il faut donc dire à windows que le service doit être lancé avec le user
xxx ( dans le panneau de gestion des services, clic droit, proprité,
onglet connexion) que tu auras créé sur la machine et qui aura les
droits pour acceder aux imprimantes et aux disques. pour verifier que
cela fonctionne, lances ton programme ( pas en mode service) avec le
user defini et vois si ca fonctionne...
Publicité
Poster une réponse
Anonyme