SI colA ou colB ou colC Egal à OUI ==> mettre Oui dans colD ?

Le
joël[2]
Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début de VB
un bouquin facile Par l'exemple ?



--
Rollier-jo@noos.fr
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas B.
Le #1282415
Salut,

Pour la deuxième question (où est passée la première ?), tu peux le faire en
ET et OU ou (ça va, tu t'y retrouve ? ;-) en "opérations logiques" (+ pour
OU et * pour ET) :

=SI(OU(ET(A1="Oui";B1="Non");ET(A1="";C1="Inconnu"));"ok";"")
=SI((A1="Oui")*(B1="Non")+(A1="")*(C1="Inconnu");"ok";"")


A+
--
Nicolas B.


Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début
de VB un bouquin facile Par l'exemple ?



--



Philippe.R
Le #1282414
Bonsoir,
=si(ou(a1="OUI";b1="OUI";c1="OUI");"OUI";"")
=si(ou(et(a1="OUI";b1="NON");et(a1=" ";c1="inconnu"));"OK";"")
Pour les bouquins, voir la bibliographie de la FAQ par exemple
--
Amicales Salutations
Retirer A_S_ pour répondre.
XL 97 / 2000 / 2002
Pour suivre le forum :
news://msnews.microsoft.com/microsoft.public.fr.excel
(Voulez-vous vous abonner ? -> Oui)

"joël[2]" news:
Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début de VB
un bouquin facile Par l'exemple ?



--





ru-th
Le #1282413
Salut

1- =SI(NB.SI(A1:B1;"oui")=1;"OUI";"NON")
2-=SI(OU(ET(A2="OUI";B2="NON");ET(A2=" ";C2="Inconnu"));"OK";" ")
avec la remarque que A2=" " signifies qu'il y a réellement un espace dans A2
a+
rural thierry
Veaux et Broutards d'Anjou
Wicasa on kin nape yapi inahni yo (à l'essai)

"joël[2]" news:
Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début de VB
un bouquin facile Par l'exemple ?



--





joël[2]
Le #1279233
Merci

Et si pour ta réponse 2- A2 est vide (pas remplie) ?

"ru-th" news:
Salut

1- =SI(NB.SI(A1:B1;"oui")=1;"OUI";"NON")
2-=SI(OU(ET(A2="OUI";B2="NON");ET(A2=" ";C2="Inconnu"));"OK";" ")
avec la remarque que A2=" " signifies qu'il y a réellement un espace dans
A2

a+
rural thierry
Veaux et Broutards d'Anjou
Wicasa on kin nape yapi inahni yo (à l'essai)

"joël[2]" news:
Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début de
VB


un bouquin facile Par l'exemple ?



--









ru-th
Le #1279230
re-
1- petit correctif =SI(NB.SI(A1:C1;"oui")=1;"OUI";"NON")
2- =SI(OU(ET(A2="OUI";B2="NON");ET(A2=0;C2="Inconnu"));"OK";" ")

a+
rural thierry
Veaux et Broutards d'Anjou
Wicasa on kin nape yapi inahni yo (à l'essai)

"joël[2]" news:uNXh$
Merci

Et si pour ta réponse 2- A2 est vide (pas remplie) ?

"ru-th" news:
Salut

1- =SI(NB.SI(A1:B1;"oui")=1;"OUI";"NON")
2-=SI(OU(ET(A2="OUI";B2="NON");ET(A2=" ";C2="Inconnu"));"OK";" ")
avec la remarque que A2=" " signifies qu'il y a réellement un espace
dans


A2
a+
rural thierry
Veaux et Broutards d'Anjou
Wicasa on kin nape yapi inahni yo (à l'essai)

"joël[2]" news:
Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début
de



VB
un bouquin facile Par l'exemple ?



--













Jean-François Aubert
Le #1279228
Salut,

=SI(OU(ET(A2="OUI";B2="NON");ET(A2="";C2="Inconnu"));"OK";" ")

pour le: ET(A2=""

" " c'est un espace
" " c'est deux espace
"" c'est rien d'affiché( mais il peut y avoir une formule qui renvoie pas de résultat)

--
Amicalement

Jean-François Aubert
{Vaudois de la Côte Lémanique}


"joël[2]" news:uNXh$
Merci

Et si pour ta réponse 2- A2 est vide (pas remplie) ?

"ru-th" news:
Salut

1- =SI(NB.SI(A1:B1;"oui")=1;"OUI";"NON")
2-=SI(OU(ET(A2="OUI";B2="NON");ET(A2=" ";C2="Inconnu"));"OK";" ")
avec la remarque que A2=" " signifies qu'il y a réellement un espace dans
A2

a+
rural thierry
Veaux et Broutards d'Anjou
Wicasa on kin nape yapi inahni yo (à l'essai)

"joël[2]" news:
Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début de
VB


un bouquin facile Par l'exemple ?



--













joël[2]
Le #1279227
merci ça marche grâce à vous

Alors je vais aller plus loin ..

Je viens d'utiliser cette fonction pour une cellule :
=SI((AG4="oui")+(AI4="oui")+(AK4="oui");"Admis";"NON Admis ")

Pour les "admis" c'est ce que je veux faire donc touchons a rien

Mais là ou g mis en vrac "Non Admis" j'aurais voulu pour cette cellule

Choisir : Si j'ai eu un "non" dans une de les 2 cellules AI4ouAK4 Mettre :
"déjà loupé" et si dans la cellule AG4 j'ai un Non Mettre "loupé cette
année"
Et dans le cas ou je n'ai Ni un ADMIS,Ni un "déjà loupé",Ni un "loupé cette
année" Mettre " Pas Encore Passé"

je ne sais pas si vous me suivez , ..

merci pour votre aide

joël


"Nicolas B." news:
Salut,

Pour la deuxième question (où est passée la première ?), tu peux le faire
en

ET et OU ou (ça va, tu t'y retrouve ? ;-) en "opérations logiques" (+ pour
OU et * pour ET) :

=SI(OU(ET(A1="Oui";B1="Non");ET(A1="";C1="Inconnu"));"ok";"")
=SI((A1="Oui")*(B1="Non")+(A1="")*(C1="Inconnu");"ok";"")


A+
--
Nicolas B.


Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début
de VB un bouquin facile Par l'exemple ?



--







Nicolas B.
Le #1279226
Ceci devrait fonctionner :

=SI(OU(AG4="oui";AI4="oui";AK4="oui");"admis";SI(AG4="non";"loupé cette
année";SI(OU(AI4="non";AK4="non");"déjà loupé";"pas encore passé")))

Mais dans ton problème, il y a des conditions qui se recoupent : si tu as
AG4="non" et si AI4 ou AK4 contiennent aussi "non", veux-tu afficher "déjà
loupé" ou "loupé cette année" ? La formule plus haut donne "loupé cette
année".

Aussi, tu peux peut-être simplifier ta formule avec des nb.si comme dans la
solution de thierry à condition que dans les cellules AH4 et AJ4 il n'y ait
ni "oui" ni "non" :
=SI(NB.SI(AG4:AK4;"oui");"admis";SI(AG4="non";"loupé cette
année";SI(NB.SI(AI4:AK4;"non");"déjà loupé";"pas encore passé")))


A+
--
Nicolas B.


merci ça marche grâce à vous

Alors je vais aller plus loin ..

Je viens d'utiliser cette fonction pour une cellule :
=SI((AG4="oui")+(AI4="oui")+(AK4="oui");"Admis";"NON Admis ")

Pour les "admis" c'est ce que je veux faire donc touchons a rien

Mais là ou g mis en vrac "Non Admis" j'aurais voulu pour cette cellule

Choisir : Si j'ai eu un "non" dans une de les 2 cellules AI4ouAK4
Mettre : "déjà loupé" et si dans la cellule AG4 j'ai un Non Mettre
"loupé cette année"
Et dans le cas ou je n'ai Ni un ADMIS,Ni un "déjà loupé",Ni un "loupé
cette année" Mettre " Pas Encore Passé"

je ne sais pas si vous me suivez , ..

merci pour votre aide

joël


"Nicolas B." message de news:
Salut,

Pour la deuxième question (où est passée la première ?), tu peux le
faire en ET et OU ou (ça va, tu t'y retrouve ? ;-) en "opérations
logiques" (+ pour OU et * pour ET) :

=SI(OU(ET(A1="Oui";B1="Non");ET(A1="";C1="Inconnu"));"ok";"")
=SI((A1="Oui")*(B1="Non")+(A1="")*(C1="Inconnu");"ok";"")


A+
--
Nicolas B.


Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début
de VB un bouquin facile Par l'exemple ?



--







joël[2]
Le #1279207
Merci Je vais testé comme cela Et vous dirais ..
En fait dans chacune des trois cellules Il y a respectivement des infos
sur 2004,2003,2003 Avec des possibilités de "OUI" "NON" "Pas convoqué"
dans chacune des 3 années

Au niveau syntaxe , je lis plus facilement ta présentation juste ci dessous
J'espère que ça veut bien dire : je lis le premier si et si je trouve Je
me débranche (goto fin pour moi rire ou goto suite et si la condition
suivante marche aussi Il prendrait le résultat de la condition suivante En
cas de recoupement comme tu écris ci-dessous) et je traite le second etc..

remarque perso sur les ET/OU
Quand vous mettez =SI(ET5(AG8 etc... je comprends que ce doit être des ET
Mais j'ai cru voir dans un exemple un =SI(OU(ET(AG8... Cela veux dire
quoi ?

Il me faudrait un exemple avec SI(OU(ET Si g pas rêvé

En tout cas merci beaucoup

je vais tester

noël


"Nicolas B." news:
Ceci devrait fonctionner :

=SI(OU(AG4="oui";AI4="oui";AK4="oui");"admis";SI(AG4="non";"loupé cette
année";SI(OU(AI4="non";AK4="non");"déjà loupé";"pas encore passé")))

Mais dans ton problème, il y a des conditions qui se recoupent : si tu as
AG4="non" et si AI4 ou AK4 contiennent aussi "non", veux-tu afficher "déjà
loupé" ou "loupé cette année" ? La formule plus haut donne "loupé cette
année".

Aussi, tu peux peut-être simplifier ta formule avec des nb.si comme dans
la

solution de thierry à condition que dans les cellules AH4 et AJ4 il n'y
ait

ni "oui" ni "non" :
=SI(NB.SI(AG4:AK4;"oui");"admis";SI(AG4="non";"loupé cette
année";SI(NB.SI(AI4:AK4;"non");"déjà loupé";"pas encore passé")))


A+
--
Nicolas B.


merci ça marche grâce à vous

Alors je vais aller plus loin ..

Je viens d'utiliser cette fonction pour une cellule :
=SI((AG4="oui")+(AI4="oui")+(AK4="oui");"Admis";"NON Admis ")

Pour les "admis" c'est ce que je veux faire donc touchons a rien

Mais là ou g mis en vrac "Non Admis" j'aurais voulu pour cette cellule

Choisir : Si j'ai eu un "non" dans une de les 2 cellules AI4ouAK4
Mettre : "déjà loupé" et si dans la cellule AG4 j'ai un Non Mettre
"loupé cette année"
Et dans le cas ou je n'ai Ni un ADMIS,Ni un "déjà loupé",Ni un "loupé
cette année" Mettre " Pas Encore Passé"

je ne sais pas si vous me suivez , ..

merci pour votre aide

joël


"Nicolas B." message de news:
Salut,

Pour la deuxième question (où est passée la première ?), tu peux le
faire en ET et OU ou (ça va, tu t'y retrouve ? ;-) en "opérations
logiques" (+ pour OU et * pour ET) :

=SI(OU(ET(A1="Oui";B1="Non");ET(A1="";C1="Inconnu"));"ok";"")
=SI((A1="Oui")*(B1="Non")+(A1="")*(C1="Inconnu");"ok";"")


A+
--
Nicolas B.


Es ce possible ?

comment écrire cette fonction ?


Et autre question : Si colA =OUI et colB=NON
OU colA=" " et
ColC=inconnu

Mettre colonneD===> OK

merci de m'aider avec les ou et Et

Avec quelques exemples ? et réponse a ma 1ere question si possible

joel

ps: Existe t il un bouquin ou on explique les fonctions et un début
de VB un bouquin facile Par l'exemple ?



--











Nicolas B.
Le #1239715
Salut,

Mais j'ai cru voir dans un exemple un =SI(OU(ET(AG8... Cela veux dire
quoi ?


On peut toujours imbriquer des ET et des OU, car la formule renvoyée par un
ET (ou un OU) est en fait une condition qui renvoit VRAI ou FAUX.

Pour comprendre une formule, il ne faut pas toujours essayer de la lire
simplement de gauche à droite.

Dans l'exemple suivant (condN sont des conditions, par exemple A1>6) :
=si(ou(et(condA;condB);condC);"ok";"")

On peut lire une formule en commençant par les parenthèses les plus à
l'intérieur, c'est-à-dire dans ce cas et(condA;condB). Ce morceau va
renvoyer VRAI seulement si condA et condB sont vérifiées.
On s'intéresse maintenant au ou(et(condA;condB);condC), qu'on peut écrire
ou(condD;condC) avec condD la condition formée par le ET précédent. Il
suffit là que CondD ou condC soit vérifiée, ou encore que le ET renvoie VRAI
ou que condC renvoie VRAI.

En français on a donc :
si condC est vérifiée,
ou condA et condB sont toutes deux vérifiées
alors "Ok"


A+
(Joyeuses Pâques à tous,
et attention à ne pas trop manger de chocolats ;-)
--
Nicolas B.


Merci Je vais testé comme cela Et vous dirais ..
En fait dans chacune des trois cellules Il y a respectivement des
infos sur 2004,2003,2003 Avec des possibilités de "OUI" "NON"
"Pas convoqué" dans chacune des 3 années

Au niveau syntaxe , je lis plus facilement ta présentation juste ci
dessous J'espère que ça veut bien dire : je lis le premier si et
si je trouve Je me débranche (goto fin pour moi rire ou goto suite et
si la condition suivante marche aussi Il prendrait le résultat de la
condition suivante En cas de recoupement comme tu écris ci-dessous)
et je traite le second etc..

remarque perso sur les ET/OU
Quand vous mettez =SI(ET5(AG8 etc... je comprends que ce doit être
des ET Mais j'ai cru voir dans un exemple un =SI(OU(ET(AG8... Cela
veux dire quoi ?

Il me faudrait un exemple avec SI(OU(ET Si g pas rêvé

En tout cas merci beaucoup

je vais tester

noël


Publicité
Poster une réponse
Anonyme