somme deux critères

Le
Syleg
Bonjour

Pouvez-vous me dire ce que je dois modifier à ma formule ci-dessous po=
ur ajouter un autre critères c'est-à-dire je voudrais tenir compt=
e pour faire la somme des montant négatif que soit indiquer en colonne=
(A) "CPTC"

Bonne journée à vous

=SI(SOMME.SI(E5:E70;"<0")=0;"";SOMME.SI(E5:E70;"<0"))
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #26482306
Bonjour,
Voici un petit doc avec 3 sortes de sommes (normale, des nb négatifs et des
nb positifs)
https://www.cjoint.com/c/HGkpbV8rnzv
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
Pouvez-vous me dire ce que je dois modifier à ma formule ci-dessous pour
ajouter un autre critères c'est-à-dire je voudrais tenir compte pour faire
la somme des montant négatif que soit indiquer en colonne (A) "CPTC"
Bonne journée à vous
=SI(SOMME.SI(E5:E70;"<0")=0;"";SOMME.SI(E5:E70;"<0"))
Syleg
Le #26482308
Bonjour
merci pour ta réponse
mais je veux deux critères
1) somme en-dessous de zéro
2) Col (A) égale à CPTC
Le mardi 10 juillet 2018 17:11:56 UTC+2, Jacquouille a écrit :
Bonjour,
Voici un petit doc avec 3 sortes de sommes (normale, des nb négatifs et des
nb positifs)
https://www.cjoint.com/c/HGkpbV8rnzv
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
Pouvez-vous me dire ce que je dois modifier à ma formule ci-dessous pour
ajouter un autre critères c'est-à-dire je voudrais tenir compte pour faire
la somme des montant négatif que soit indiquer en colonne (A) "CPTC"
Bonne journée à vous
=SI(SOMME.SI(E5:E70;"<0")=0;"";SOMME.SI(E5:E70;"<0"))
Michd
Le #26482315
Bonjour,
Colonne A : Des valeurs textes dont "CPTC"
Colonne B : Des valeurs numériques
La formule somme seulement les valeurs négatives de la colonne B dont la valeur en colonne A est
"CPTC"
Validation matricielle : Maj + Ctrl + Enter
=SOMME(SI(((A1:A5="CPTC")*(B1:B5<0)=1);B1:B5))
MichD
Syleg
Le #26482321
Bonjour Michd
Merci pour ta réponse ça fonctionne nickel, mais dans ma formule j'avais ajouter que si résultat =0;"" es-ce que c'est possible de ra jouter a une validation matricielle ?
Le mardi 10 juillet 2018 19:14:23 UTC+2, Michd a écrit :
Bonjour,
Colonne A : Des valeurs textes dont "CPTC"
Colonne B : Des valeurs numériques
La formule somme seulement les valeurs négatives de la colonne B don t la valeur en colonne A est
"CPTC"
Validation matricielle : Maj + Ctrl + Enter
=SOMME(SI(((A1:A5="CPTC")*(B1:B5<0)=1);B1:B5))
MichD
Syleg
Le #26482326
Michd
Bonsoir
J'ai réussi à remettre dans ta formule si résultat =0;""
=SI(SOMME(SI(((A5:A70="CPTC")*(E5:E70<0)=1);E5:E70))=0;"";SOMME(SI( ((A5:A70="CPTC")*(E5:E70<0)=1);E5:E70)))
Merci pour ton aide
bonne soirée
Le mardi 10 juillet 2018 19:14:23 UTC+2, Michd a écrit :
Bonjour,
Colonne A : Des valeurs textes dont "CPTC"
Colonne B : Des valeurs numériques
La formule somme seulement les valeurs négatives de la colonne B don t la valeur en colonne A est
"CPTC"
Validation matricielle : Maj + Ctrl + Enter
=SOMME(SI(((A1:A5="CPTC")*(B1:B5<0)=1);B1:B5))
MichD
Michd
Le #26482364
Tu peux conserver ma formule et définir un format personnalisé de la cellule ressemblant à ceci :
[<>0];"-"# ##0,00;
Le Symbole "-" est devant le nombre. Si le résultat de la formule est 0, rien ne s'affichera dans la
cellule.
MichD
Michd
Le #26482389
Il y a aussi ce format de cellule qui masque les "0"
Standard;standard;;Standard <<<<====
Pour :
Positif; Négatif; Valeur nullle (0); Texte
MichD
Jacquouille
Le #26482405
Bonjour,
Avec SOMMEPROD, tu peux ajouter beaucoup de critères. j'en ai testé 33
..... jadis.
plA = plage ("a1:a10")
plB = plage ("b1:b10")
=SOMMEPROD((plA="CPTC")*(plB<0)*(plB))
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
merci pour ta réponse
mais je veux deux critères
1) somme en-dessous de zéro
2) Col (A) égale à CPTC
Le mardi 10 juillet 2018 17:11:56 UTC+2, Jacquouille a écrit :
Bonjour,
Voici un petit doc avec 3 sortes de sommes (normale, des nb négatifs et
des
nb positifs)
https://www.cjoint.com/c/HGkpbV8rnzv
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
Pouvez-vous me dire ce que je dois modifier à ma formule ci-dessous pour
ajouter un autre critères c'est-à-dire je voudrais tenir compte pour faire
la somme des montant négatif que soit indiquer en colonne (A) "CPTC"
Bonne journée à vous
=SI(SOMME.SI(E5:E70;"<0")=0;"";SOMME.SI(E5:E70;"<0"))
Syleg
Le #26482410
Bonjour à tous
Merci pour toutes vos réponses
Bonne journée à vous
Le mercredi 11 juillet 2018 12:56:17 UTC+2, Jacquouille a écrit :
Bonjour,
Avec SOMMEPROD, tu peux ajouter beaucoup de critères. j'en ai test é 33
..... jadis.
plA = plage ("a1:a10")
plB = plage ("b1:b10")
=SOMMEPROD((plA="CPTC")*(plB<0)*(plB))
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
merci pour ta réponse
mais je veux deux critères
1) somme en-dessous de zéro
2) Col (A) égale à CPTC
Le mardi 10 juillet 2018 17:11:56 UTC+2, Jacquouille a écrit :
Bonjour,
Voici un petit doc avec 3 sortes de sommes (normale, des nb négati fs et
des
nb positifs)
https://www.cjoint.com/c/HGkpbV8rnzv
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
Pouvez-vous me dire ce que je dois modifier à ma formule ci-dessou s pour
ajouter un autre critères c'est-à-dire je voudrais tenir comp te pour faire
la somme des montant négatif que soit indiquer en colonne (A) "CPT C"
Bonne journée à vous
=SI(SOMME.SI(E5:E70;"<0")=0;"";SOMME.SI(E5:E70;"<0"))
Jacquouille
Le #26482412
Re,
=si(SOMMEPROD((plA="CPTC")*(plB<0)*(plB))=0;"";SOMMEPROD((plA="CPTC")*(plB<0)*(plB)))
beau, mais, si on ne met rien, comment savoir que c'est 0 et pas une erreur
ou un manque quelconque?
Mais c'est beau et cela éclaircit les tableaux de réponses.
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour à tous
Merci pour toutes vos réponses
Bonne journée à vous
Le mercredi 11 juillet 2018 12:56:17 UTC+2, Jacquouille a écrit :
Bonjour,
Avec SOMMEPROD, tu peux ajouter beaucoup de critères. j'en ai testé 33
..... jadis.
plA = plage ("a1:a10")
plB = plage ("b1:b10")
=SOMMEPROD((plA="CPTC")*(plB<0)*(plB))
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
merci pour ta réponse
mais je veux deux critères
1) somme en-dessous de zéro
2) Col (A) égale à CPTC
Le mardi 10 juillet 2018 17:11:56 UTC+2, Jacquouille a écrit :
Bonjour,
Voici un petit doc avec 3 sortes de sommes (normale, des nb négatifs et
des
nb positifs)
https://www.cjoint.com/c/HGkpbV8rnzv
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Syleg" a écrit dans le message de groupe de discussion :

Bonjour
Pouvez-vous me dire ce que je dois modifier à ma formule ci-dessous pour
ajouter un autre critères c'est-à-dire je voudrais tenir compte pour
faire
la somme des montant négatif que soit indiquer en colonne (A) "CPTC"
Bonne journée à vous
=SI(SOMME.SI(E5:E70;"<0")=0;"";SOMME.SI(E5:E70;"<0"))
Publicité
Poster une réponse
Anonyme