SOMME.SI avec 2 conditions et pb avec INDIRECT

Le
Zebulion
Bonjour à tous

J'ai un petit souci car je n'arrive pas à donner 2 conditions dans un
somme.si:
j'ai 3 plages projet_mar; sujet_mar et temps_mar
lorsque je fais un =SOMME.SI(sujet_mar;"extracteur";temps_mar) tout va bien
et mes temps sont bien sommés.
Par contre, lorsque j'introduis un second critère
=SOMME.SI((projet_mar;"globe")sujet_mar;"extracteur";temps_mar) j'obtiens la
super boîte "votre formule contient uns anomaliequelque soit l'endroit de
mes parenthèses
Ais-je le droit d'introduire cette seconde condition et si oui comment bien
codifier la condition.Et si non, l'aide d'excel me laissant entendre que
non, comment puis-je contourner le pb??

J'ai en même temps un autre pb: projet_mar; sujet_mar et temps_mar sont des
noms attribués pour la feuille de mars et je suis obligé de reprendre chaque
mois toutes mes références dans mes somme.si puisqu'ils font référence à ces
noms
J'ai trouvé une fonction INDIRECT, mais je n'ai pas réussi à entrer des noms
avec ceci et suis donc obligé chaque mois de me livrer au copier-coller puis
au renommage de tous mes noms et de modifier toutes mes formules, avec bien
sur de temps en temps quelques oublis
Pouvez vous m'indiquer comment saisir les noms avec indirect et comment les
utiliser dans mes somme.si?

Merci d'avance pour vos réponses à ces deux préoccupations.


--
Cordialement,
Philippe

La théorie, c'est quand on sait tout et que rien ne fonctionne.
La pratique, c'est quand tout fonctionne et que l'on ne sait pas pouquoi
(A.S.)

****-*****--*****--****-*****--*****--*****
Vos réponses
Trier par : date / pertinence
michdenis
Le #3775541
Bonjour Zebulion,

La fonction Somme.Si() est limité à une condition.

Cependant tu peux utiliser la fonction SommeProd()

Exemple : Additonne les cellules de la plage C1:C10
qui répond aux 2 conditions suivantes :
A1:A10 > 5
B1:B10 = "toto"

=Sommeprod((A1:A10>5)*(B1:B10= "toto")*(C1:C10))

P.S. Le nombre de lignes des plages doivent être identiques



Salutations!



"Zebulion" Bonjour à tous

J'ai un petit souci car je n'arrive pas à donner 2 conditions dans un
somme.si:
j'ai 3 plages projet_mar; sujet_mar et temps_mar
lorsque je fais un =SOMME.SI(sujet_mar;"extracteur";temps_mar) tout va bien
et mes temps sont bien sommés.
Par contre, lorsque j'introduis un second critère
=SOMME.SI((projet_mar;"globe")sujet_mar;"extracteur";temps_mar) j'obtiens la
super boîte "votre formule contient uns anomalie...quelque soit l'endroit de
mes parenthèses...
Ais-je le droit d'introduire cette seconde condition et si oui comment bien
codifier la condition.Et si non, l'aide d'excel me laissant entendre que
non, comment puis-je contourner le pb??

J'ai en même temps un autre pb: projet_mar; sujet_mar et temps_mar sont des
noms attribués pour la feuille de mars et je suis obligé de reprendre chaque
mois toutes mes références dans mes somme.si puisqu'ils font référence à ces
noms...
J'ai trouvé une fonction INDIRECT, mais je n'ai pas réussi à entrer des noms
avec ceci et suis donc obligé chaque mois de me livrer au copier-coller puis
au renommage de tous mes noms et de modifier toutes mes formules, avec bien
sur de temps en temps quelques oublis...
Pouvez vous m'indiquer comment saisir les noms avec indirect et comment les
utiliser dans mes somme.si?

Merci d'avance pour vos réponses à ces deux préoccupations.


--
Cordialement,
Philippe

La théorie, c'est quand on sait tout et que rien ne fonctionne.
La pratique, c'est quand tout fonctionne et que l'on ne sait pas pouquoi
(A.S.)

---****----*****-----*****-----****----*****-----*****-----*****
Zebulion
Le #3773671
Merci. Ca marche effectivement très bien..

--
Cordialement,
Philippe

La théorie, c'est quand on sait tout et que rien ne fonctionne.
La pratique, c'est quand tout fonctionne et que l'on ne sait pas pouquoi
(A.S.)

---****----*****-----*****-----****----*****-----*****-----*****


"michdenis"
Bonjour Zebulion,

La fonction Somme.Si() est limité à une condition.

Cependant tu peux utiliser la fonction SommeProd()

Exemple : Additonne les cellules de la plage C1:C10
qui répond aux 2 conditions suivantes :
A1:A10 > 5
B1:B10 = "toto"

=Sommeprod((A1:A10>5)*(B1:B10= "toto")*(C1:C10))

P.S. Le nombre de lignes des plages doivent être identiques



Salutations!



"Zebulion"
Bonjour à tous

J'ai un petit souci car je n'arrive pas à donner 2 conditions dans un
somme.si:
j'ai 3 plages projet_mar; sujet_mar et temps_mar
lorsque je fais un =SOMME.SI(sujet_mar;"extracteur";temps_mar) tout va
bien
et mes temps sont bien sommés.
Par contre, lorsque j'introduis un second critère
=SOMME.SI((projet_mar;"globe")sujet_mar;"extracteur";temps_mar) j'obtiens
la
super boîte "votre formule contient uns anomalie...quelque soit l'endroit
de
mes parenthèses...
Ais-je le droit d'introduire cette seconde condition et si oui comment
bien
codifier la condition.Et si non, l'aide d'excel me laissant entendre que
non, comment puis-je contourner le pb??

J'ai en même temps un autre pb: projet_mar; sujet_mar et temps_mar sont
des
noms attribués pour la feuille de mars et je suis obligé de reprendre
chaque
mois toutes mes références dans mes somme.si puisqu'ils font référence à
ces
noms...
J'ai trouvé une fonction INDIRECT, mais je n'ai pas réussi à entrer des
noms
avec ceci et suis donc obligé chaque mois de me livrer au copier-coller
puis
au renommage de tous mes noms et de modifier toutes mes formules, avec
bien
sur de temps en temps quelques oublis...
Pouvez vous m'indiquer comment saisir les noms avec indirect et comment
les
utiliser dans mes somme.si?

Merci d'avance pour vos réponses à ces deux préoccupations.


--
Cordialement,
Philippe

La théorie, c'est quand on sait tout et que rien ne fonctionne.
La pratique, c'est quand tout fonctionne et que l'on ne sait pas pouquoi
(A.S.)

---****----*****-----*****-----****----*****-----*****-----*****






Publicité
Poster une réponse
Anonyme